tomka       15/03/05 15:09:25

  Modified:             ChangeLog
  Added:                polymake-2.14.ebuild
  Log:
  Bump to 2.14
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.15                 sci-mathematics/polymake/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/ChangeLog?rev=1.15&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/ChangeLog?rev=1.15&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/ChangeLog?r1=1.14&r2=1.15

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v
retrieving revision 1.14
retrieving revision 1.15
diff -u -r1.14 -r1.15
--- ChangeLog   3 Mar 2015 09:34:22 -0000       1.14
+++ ChangeLog   5 Mar 2015 15:09:25 -0000       1.15
@@ -1,6 +1,11 @@
 # ChangeLog for sci-mathematics/polymake
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.14 
2015/03/03 09:34:22 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/polymake/ChangeLog,v 1.15 
2015/03/05 15:09:25 tomka Exp $
+
+*polymake-2.14 (05 Mar 2015)
+
+  05 Mar 2015; Thomas Kahle <to...@gentoo.org> +polymake-2.14.ebuild:
+  Bump to 2.14
 
   03 Mar 2015; Thomas Kahle <to...@gentoo.org> +files/polymake_gcc49.patch,
   polymake-2.13.ebuild:



1.1                  sci-mathematics/polymake/polymake-2.14.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/polymake-2.14.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/polymake/polymake-2.14.ebuild?rev=1.1&content-type=text/plain

Index: polymake-2.14.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sci-mathematics/polymake/polymake-2.14.ebuild,v 1.1 
2015/03/05 15:09:25 tomka Exp $

EAPI=5

inherit eutils flag-o-matic

DESCRIPTION="research tool for polyhedral geometry and combinatorics"
SRC_URI="http://polymake.org/lib/exe/fetch.php/download/${P}.tar.bz2";
HOMEPAGE="http://polymake.org";

IUSE="libpolymake"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"

DEPEND="dev-libs/gmp
        dev-libs/boost
        dev-libs/libxml2:2
        dev-perl/XML-LibXML
        dev-libs/libxslt
        dev-perl/XML-LibXSLT
        dev-perl/XML-Writer
        dev-perl/Term-ReadLine-Gnu"
RDEPEND="${DEPEND}"

src_prepare() {
        # Don't strip
        sed -i '/system "strip $to"/d' support/install.pl || die

        einfo "During compile this package uses up to"
        einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
        einfo "you run into trouble."
}

src_configure () {
        export CXXOPT=$(get-flag -O)
        # Configure does not accept --host, therefore econf cannot be used
        ./configure --prefix="${EPREFIX}/usr" \
                --without-java \
                $(use_with libpolymake callable) \
                --without-prereq \
                --libdir="${EPREFIX}/usr/$(get_libdir)" \
                --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
                "${myconf}" || die
}

src_install(){
        emake -j1 DESTDIR="${D}" install
        dosym libpolymake.so "${EPREFIX}/usr/$(get_libdir)/libpolymake.so.0"
}

pkg_postinst(){
        elog "Docs can be found on 
http://www.polymake.org/doku.php/documentation";
        elog " "
        elog "Support for jreality is missing, sorry (see bug #346073)."
}




Reply via email to