ssuominen    14/05/14 21:30:39

  Modified:             kmod-9999.ebuild kmod-17.ebuild metadata.xml
                        kmod-16.ebuild ChangeLog
  Log:
  Punt USE="openrc" which was to allow USE=-openrc install 
<sys-apps/openrc-0.12, but now they are no longer in portage, which obviously 
means we don't need USE="opnerc" here anymore. Futher, installing init scripts 
always is preferred anyway as sys-apps/openrc is the gentoo default. Futher, 
this is the exact same behavior in pkg_postinst() as with 
sys-fs/udev-init-scripts. Both, sys-fs/udev-init-scripts and sys-apps/kmod are 
pulled in by sys-apps/systemd, and sys-fs/udev.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
4868F14D)

Revision  Changes    Path
1.77                 sys-apps/kmod/kmod-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild?rev=1.77&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild?rev=1.77&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild?r1=1.76&r2=1.77

Index: kmod-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v
retrieving revision 1.76
retrieving revision 1.77
diff -u -r1.76 -r1.77
--- kmod-9999.ebuild    24 Apr 2014 19:52:33 -0000      1.76
+++ kmod-9999.ebuild    14 May 2014 21:30:38 -0000      1.77
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.76 
2014/04/24 19:52:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.77 
2014/05/14 21:30:38 ssuominen Exp $
 
 EAPI=5
 
@@ -22,7 +22,7 @@
 
 LICENSE="LGPL-2"
 SLOT="0"
-IUSE="debug doc lzma +openrc python static-libs +tools zlib"
+IUSE="debug doc lzma python static-libs +tools zlib"
 
 # Upstream does not support running the test suite with custom configure flags.
 # I was also told that the test suite is intended for kmod developers.
@@ -32,8 +32,8 @@
 
 RDEPEND="!sys-apps/module-init-tools
        !sys-apps/modutils
+       !<sys-apps/openrc-0.12
        lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
-       openrc? ( !<sys-apps/openrc-0.12 )
        python? ( ${PYTHON_DEPS} )
        zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
 DEPEND="${RDEPEND}
@@ -161,34 +161,32 @@
        insinto /lib/modprobe.d
        doins "${T}"/usb-load-ehci-first.conf #260139
 
-       use openrc && doinitd "${FILESDIR}"/kmod-static-nodes
+       doinitd "${FILESDIR}"/kmod-static-nodes
 }
 
 pkg_postinst() {
-       if use openrc; then
-               if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
-                       ewarn "Removing old conflicting static-nodes init 
script from the boot runlevel"
-                       rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
-               fi
+       if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
+               ewarn "Removing old conflicting static-nodes init script from 
the boot runlevel"
+               rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
+       fi
 
-               # Add kmod to the runlevel automatically if this is the first 
install of this package.
-               if [[ -z ${REPLACING_VERSIONS} ]]; then
-                       if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
-                               mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
-                       fi
-                       if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
-                               ln -s /etc/init.d/kmod-static-nodes 
"${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
-                       fi
+       # Add kmod to the runlevel automatically if this is the first install 
of this package.
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
+                       mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
                fi
+               if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
+                       ln -s /etc/init.d/kmod-static-nodes 
"${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
+               fi
+       fi
 
-               if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
-                       if [[ ! -e 
${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
-                               ewarn
-                               ewarn "You need to add kmod-static-nodes to the 
sysinit runlevel for"
-                               ewarn "kernel modules to have required static 
nodes!"
-                               ewarn "Run this command:"
-                               ewarn "\trc-update add kmod-static-nodes 
sysinit"
-                       fi
+       if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
+               if [[ ! -e ${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes 
]]; then
+                       ewarn
+                       ewarn "You need to add kmod-static-nodes to the sysinit 
runlevel for"
+                       ewarn "kernel modules to have required static nodes!"
+                       ewarn "Run this command:"
+                       ewarn "\trc-update add kmod-static-nodes sysinit"
                fi
        fi
 }



1.8                  sys-apps/kmod/kmod-17.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-17.ebuild?rev=1.8&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-17.ebuild?rev=1.8&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-17.ebuild?r1=1.7&r2=1.8

Index: kmod-17.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-17.ebuild,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- kmod-17.ebuild      14 May 2014 21:18:32 -0000      1.7
+++ kmod-17.ebuild      14 May 2014 21:30:38 -0000      1.8
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-17.ebuild,v 1.7 
2014/05/14 21:18:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-17.ebuild,v 1.8 
2014/05/14 21:30:38 ssuominen Exp $
 
 EAPI=5
 
@@ -22,7 +22,7 @@
 
 LICENSE="LGPL-2"
 SLOT="0"
-IUSE="debug doc lzma +openrc python static-libs +tools zlib"
+IUSE="debug doc lzma python static-libs +tools zlib"
 
 # Upstream does not support running the test suite with custom configure flags.
 # I was also told that the test suite is intended for kmod developers.
@@ -32,8 +32,8 @@
 
 RDEPEND="!sys-apps/module-init-tools
        !sys-apps/modutils
+       !<sys-apps/openrc-0.12
        lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
-       openrc? ( !<sys-apps/openrc-0.12 )
        python? ( ${PYTHON_DEPS} )
        zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
 DEPEND="${RDEPEND}
@@ -161,34 +161,32 @@
        insinto /lib/modprobe.d
        doins "${T}"/usb-load-ehci-first.conf #260139
 
-       use openrc && doinitd "${FILESDIR}"/kmod-static-nodes
+       doinitd "${FILESDIR}"/kmod-static-nodes
 }
 
 pkg_postinst() {
-       if use openrc; then
-               if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
-                       ewarn "Removing old conflicting static-nodes init 
script from the boot runlevel"
-                       rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
-               fi
+       if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
+               ewarn "Removing old conflicting static-nodes init script from 
the boot runlevel"
+               rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
+       fi
 
-               # Add kmod to the runlevel automatically if this is the first 
install of this package.
-               if [[ -z ${REPLACING_VERSIONS} ]]; then
-                       if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
-                               mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
-                       fi
-                       if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
-                               ln -s /etc/init.d/kmod-static-nodes 
"${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
-                       fi
+       # Add kmod to the runlevel automatically if this is the first install 
of this package.
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
+                       mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
                fi
+               if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
+                       ln -s /etc/init.d/kmod-static-nodes 
"${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
+               fi
+       fi
 
-               if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
-                       if [[ ! -e 
${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
-                               ewarn
-                               ewarn "You need to add kmod-static-nodes to the 
sysinit runlevel for"
-                               ewarn "kernel modules to have required static 
nodes!"
-                               ewarn "Run this command:"
-                               ewarn "\trc-update add kmod-static-nodes 
sysinit"
-                       fi
+       if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
+               if [[ ! -e ${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes 
]]; then
+                       ewarn
+                       ewarn "You need to add kmod-static-nodes to the sysinit 
runlevel for"
+                       ewarn "kernel modules to have required static nodes!"
+                       ewarn "Run this command:"
+                       ewarn "\trc-update add kmod-static-nodes sysinit"
                fi
        fi
 }



1.11                 sys-apps/kmod/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/metadata.xml?rev=1.11&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/metadata.xml?rev=1.11&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/metadata.xml?r1=1.10&r2=1.11

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/kmod/metadata.xml,v
retrieving revision 1.10
retrieving revision 1.11
diff -u -r1.10 -r1.11
--- metadata.xml        23 Jul 2013 10:31:20 -0000      1.10
+++ metadata.xml        14 May 2014 21:30:38 -0000      1.11
@@ -6,7 +6,6 @@
                <email>udev-b...@gentoo.org</email>
        </maintainer>
        <use>
-               <flag name='openrc'>Install the OpenRC init scripts</flag>
                <flag name='tools'>Install module loading/unloading 
tools.</flag>
        </use>
 </pkgmetadata>



1.15                 sys-apps/kmod/kmod-16.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-16.ebuild?rev=1.15&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-16.ebuild?rev=1.15&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-16.ebuild?r1=1.14&r2=1.15

Index: kmod-16.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-16.ebuild,v
retrieving revision 1.14
retrieving revision 1.15
diff -u -r1.14 -r1.15
--- kmod-16.ebuild      5 Apr 2014 11:02:10 -0000       1.14
+++ kmod-16.ebuild      14 May 2014 21:30:38 -0000      1.15
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-16.ebuild,v 1.14 
2014/04/05 11:02:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-16.ebuild,v 1.15 
2014/05/14 21:30:38 ssuominen Exp $
 
 EAPI=5
 inherit bash-completion-r1 eutils multilib
@@ -19,7 +19,7 @@
 
 LICENSE="LGPL-2"
 SLOT="0"
-IUSE="debug doc lzma +openrc static-libs +tools zlib"
+IUSE="debug doc lzma static-libs +tools zlib"
 
 # Upstream does not support running the test suite with custom configure flags.
 # I was also told that the test suite is intended for kmod developers.
@@ -30,7 +30,7 @@
 RDEPEND="!sys-apps/module-init-tools
        !sys-apps/modutils
        lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
-       openrc? ( !<sys-apps/openrc-0.12 )
+       !<sys-apps/openrc-0.12
        zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
 DEPEND="${RDEPEND}
        dev-libs/libxslt
@@ -105,34 +105,32 @@
        insinto /lib/modprobe.d
        doins "${T}"/usb-load-ehci-first.conf #260139
 
-       use openrc && doinitd "${FILESDIR}"/kmod-static-nodes
+       doinitd "${FILESDIR}"/kmod-static-nodes
 }
 
 pkg_postinst() {
-       if use openrc; then
-               if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
-                       ewarn "Removing old conflicting static-nodes init 
script from the boot runlevel"
-                       rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
-               fi
+       if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
+               ewarn "Removing old conflicting static-nodes init script from 
the boot runlevel"
+               rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
+       fi
 
-               # Add kmod to the runlevel automatically if this is the first 
install of this package.
-               if [[ -z ${REPLACING_VERSIONS} ]]; then
-                       if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
-                               mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
-                       fi
-                       if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
-                               ln -s /etc/init.d/kmod-static-nodes 
"${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
-                       fi
+       # Add kmod to the runlevel automatically if this is the first install 
of this package.
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
+                       mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
                fi
+               if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
+                       ln -s /etc/init.d/kmod-static-nodes 
"${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
+               fi
+       fi
 
-               if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
-                       if [[ ! -e 
${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
-                               ewarn
-                               ewarn "You need to add kmod-static-nodes to the 
sysinit runlevel for"
-                               ewarn "kernel modules to have required static 
nodes!"
-                               ewarn "Run this command:"
-                               ewarn "\trc-update add kmod-static-nodes 
sysinit"
-                       fi
+       if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
+               if [[ ! -e ${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes 
]]; then
+                       ewarn
+                       ewarn "You need to add kmod-static-nodes to the sysinit 
runlevel for"
+                       ewarn "kernel modules to have required static nodes!"
+                       ewarn "Run this command:"
+                       ewarn "\trc-update add kmod-static-nodes sysinit"
                fi
        fi
 }



1.151                sys-apps/kmod/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/ChangeLog?rev=1.151&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/ChangeLog?rev=1.151&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/ChangeLog?r1=1.150&r2=1.151

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v
retrieving revision 1.150
retrieving revision 1.151
diff -u -r1.150 -r1.151
--- ChangeLog   14 May 2014 21:18:32 -0000      1.150
+++ ChangeLog   14 May 2014 21:30:38 -0000      1.151
@@ -1,6 +1,16 @@
 # ChangeLog for sys-apps/kmod
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.150 2014/05/14 
21:18:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.151 2014/05/14 
21:30:38 ssuominen Exp $
+
+  14 May 2014; Samuli Suominen <ssuomi...@gentoo.org> kmod-16.ebuild,
+  kmod-17.ebuild, kmod-9999.ebuild, metadata.xml:
+  Punt USE="openrc" which was to allow USE=-openrc install <sys-
+  apps/openrc-0.12, but now they are no longer in portage, which obviously 
means
+  we don't need USE="opnerc" here anymore. Futher, installing init scripts
+  always is preferred anyway as sys-apps/openrc is the gentoo default. Futher,
+  this is the exact same behavior in pkg_postinst() as with sys-fs/udev-init-
+  scripts. Both, sys-fs/udev-init-scripts and sys-apps/kmod are pulled in by
+  sys-apps/systemd, and sys-fs/udev.
 
   14 May 2014; Samuli Suominen <ssuomi...@gentoo.org> kmod-17.ebuild:
   amd64/x86 stable wrt #509924




Reply via email to