idella4     15/01/27 01:14:23

  Modified:             ChangeLog
  Added:                roccat-tools-2.4.0.ebuild
  Removed:              roccat-tools-1.4.1.ebuild roccat-tools-1.1.0.ebuild
                        roccat-tools-1.0.0.ebuild roccat-tools-1.4.0.ebuild
                        roccat-tools-1.6.0.ebuild
  Log:
  bump, add IUSE for tyon device, rm old, fixes bug #537490 by maintainer
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.13                 sys-apps/roccat-tools/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/ChangeLog?rev=1.13&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/ChangeLog?rev=1.13&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/ChangeLog?r1=1.12&r2=1.13

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v
retrieving revision 1.12
retrieving revision 1.13
diff -u -r1.12 -r1.13
--- ChangeLog   4 Oct 2014 12:34:01 -0000       1.12
+++ ChangeLog   27 Jan 2015 01:14:23 -0000      1.13
@@ -1,6 +1,14 @@
 # ChangeLog for sys-apps/roccat-tools
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.12 
2014/10/04 12:34:01 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.13 
2015/01/27 01:14:23 idella4 Exp $
+
+*roccat-tools-2.4.0 (27 Jan 2015)
+
+  27 Jan 2015; Ian Delaney <idel...@gentoo.org> +roccat-tools-2.4.0.ebuild,
+  -roccat-tools-1.0.0.ebuild, -roccat-tools-1.1.0.ebuild,
+  -roccat-tools-1.4.0.ebuild, -roccat-tools-1.4.1.ebuild,
+  -roccat-tools-1.6.0.ebuild:
+  bump, add IUSE for tyon device, rm old, fixes bug #537490 by maintainer
 
 *roccat-tools-2.2.0 (04 Oct 2014)
 



1.1                  sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild?rev=1.1&content-type=text/plain

Index: roccat-tools-2.4.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-2.4.0.ebuild,v 1.1 
2015/01/27 01:14:23 idella4 Exp $

EAPI=5

inherit readme.gentoo cmake-utils gnome2-utils udev user

DESCRIPTION="Utility for advanced configuration of Roccat devices"

HOMEPAGE="http://roccat.sourceforge.net/";
SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE_INPUT_DEVICES="
        input_devices_roccat_arvo
        input_devices_roccat_isku
        input_devices_roccat_iskufx
        input_devices_roccat_kone
        input_devices_roccat_koneplus
        input_devices_roccat_konepure
        input_devices_roccat_konepuremilitary
        input_devices_roccat_konepureoptical
        input_devices_roccat_konextd
        input_devices_roccat_konextdoptical
        input_devices_roccat_kovaplus
        input_devices_roccat_lua
        input_devices_roccat_pyra
        input_devices_roccat_savu
        input_devices_roccat_ryos
        input_devices_roccat_tyon
"
IUSE="${IUSE_INPUT_DEVICES}"

RDEPEND="
        >=dev-libs/libgaminggear-0.5
        x11-libs/gtk+:2
        x11-libs/libnotify
        media-libs/libcanberra
        virtual/libusb:1
        dev-libs/dbus-glib
        virtual/libgudev:=
"

DEPEND="${RDEPEND}"

pkg_setup() {
        enewgroup roccat
}

src_configure() {
        local UDEVDIR="$(get_udevdir)"/rules.d
        local MODELS=${INPUT_DEVICES//roccat_/}
        mycmakeargs=( -DDEVICES=${MODELS// /;} \
        -DUDEVDIR="${UDEVDIR/"//"//}" )
        cmake-utils_src_configure
}
src_install() {
        cmake-utils_src_install
        local stat_dir=/var/lib/roccat
        keepdir $stat_dir
        fowners root:roccat $stat_dir
        fperms 2770 $stat_dir
        readme.gentoo_src_install
}
pkg_preinst() {
        gnome2_icon_savelist
}
pkg_postinst() {
        gnome2_icon_cache_update
        readme.gentoo_print_elog
}

pkg_postrm() {
        gnome2_icon_cache_update
}




Reply via email to