patrick     14/04/01 04:09:36

  Added:                toybox-9999.ebuild metadata.xml toybox-0.4.7.ebuild
                        Manifest ChangeLog
  Log:
  Initial import, ebuild by me
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.1                  sys-apps/toybox/toybox-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/toybox-9999.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/toybox-9999.ebuild?rev=1.1&content-type=text/plain

Index: toybox-9999.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/toybox-9999.ebuild,v 1.1 
2014/04/01 04:09:36 patrick Exp $

EAPI=5

inherit eutils git-r3

DESCRIPTION="Common linux commands in a multicall binary"
HOMEPAGE="http://landley.net/code/toybox/";
EGIT_REPO_URI="https://github.com/gfto/toybox.git";

# The source code does not explicitly say that it's BSD, but the author has 
repeatedly said it
LICENSE="BSD-2"
SLOT="0"
KEYWORDS=""
IUSE=""

src_configure() {
        make defconfig || die
}

src_compile() {
        emake || die
}

src_test() {
        emake test || die
}

src_install() {
        mkdir -p "${D}/usr/bin"
        cp toybox "${D}/usr/bin" || die
}



1.1                  sys-apps/toybox/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/metadata.xml?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/metadata.xml?rev=1.1&content-type=text/plain

Index: metadata.xml
===================================================================
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
<pkgmetadata>
  <maintainer>
    <email>patr...@gentoo.org</email>
    <name>Patrick Lauer</name>
  </maintainer>
</pkgmetadata>



1.1                  sys-apps/toybox/toybox-0.4.7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/toybox-0.4.7.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/toybox-0.4.7.ebuild?rev=1.1&content-type=text/plain

Index: toybox-0.4.7.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/toybox-0.4.7.ebuild,v 1.1 
2014/04/01 04:09:36 patrick Exp $

EAPI=5

inherit eutils

# makefile is stupid
RESTRICT="test"

DESCRIPTION="Common linux commands in a multicall binary"
HOMEPAGE="http://landley.net/code/toybox/";
SRC_URI="http://landley.net/code/toybox/downloads/${P}.tar.bz2";

# The source code does not explicitly say that it's BSD, but the author has 
repeatedly said it
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""

src_configure() {
        :;
}

src_compile() {
        emake || die
}

src_test() {
        emake test || die
}

src_install() {
        mkdir -p "${D}/usr/bin"
        cp toybox "${D}/usr/bin" || die
}



1.1                  sys-apps/toybox/Manifest

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/Manifest?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/Manifest?rev=1.1&content-type=text/plain

Index: Manifest
===================================================================
DIST toybox-0.4.7.tar.bz2 464545 SHA256 
56392d602c21a3c9e05f94a64e194ff6467cb8e98ee10c4735e9d659a42c66d1 SHA512 
77fa2eb7775d2f9fda5053048f902b91597ca5f1898f1819dc4308b7f6d10b96a09979d4f9853345598d30cce5c773f441454c97472920fffe3abf1cb4234741
 WHIRLPOOL 
270b25188291d06fb490268aa9e3efa26fe6cb6ca2fd2d3fef43f40c3ecbc6bd69a6303f487ce29e2078c6fc24e71c09de5c8e1e4743bb597f7d02b6f62460f9
EBUILD toybox-0.4.7.ebuild 670 SHA256 
8f1dea4b46249ee573a9a0ed69691a14d2a5a525372493e4778f49d648323bfa SHA512 
de72a0f8325bade24d106d43c3ef8b13a9a79eef1706f7783c520500cdb2638e0b25fd8c252d8775a008188f7e23ac62e9e893bff12b6f7a028b67c8529f380a
 WHIRLPOOL 
ff3df4b7a795748abd5364b44ab36ed0ba838ecfc10691a9dec40a2be23915f027eb33710ff043def634a64faa498b8170ad4ebfec28dc8b6413ec4b33b01af7
EBUILD toybox-9999.ebuild 634 SHA256 
200acc574cb5c7f45b5f76dc7a89ffe653367ddd96cbabc60b773ddd24a07179 SHA512 
47b3b61a329785b7edc068325cc0ae9e5abbf669ecd0c05eb3cfe1e183dbc57d053c07156ac57cb048ec469e6d37a6c138c1c638878fa77c0ed4b5c7f06935ba
 WHIRLPOOL 
9a6697576d6afc7bbf97df83af6cb2384a49beec716ba26e2777c07deda0fa87cfe703c9cc44e0f4e772d6562475e7bdfbc14855c812021b6f936053b479e32e
MISC metadata.xml 239 SHA256 
57c79f6c1b1b06b8d90265f1cc0affe89b5548b63e811f0313bfb2a0a0aa201a SHA512 
1898d4e8bb4f02ffdad555a095ee76f934bd6ee1f914564eac1932f0dd96f26a52f47047324ed0a81009516a84bf72e1b10922fa751f322abf17517f84f62156
 WHIRLPOOL 
7375ace29b0d9c7e945e141c09b70c79599780bc9d3478e59fbc85dc4330aeda6bf2bb54fde24d25feb181f88618e11e022a90674d1f26ff9ef692bd698ff754



1.1                  sys-apps/toybox/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/ChangeLog?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/toybox/ChangeLog?rev=1.1&content-type=text/plain

Index: ChangeLog
===================================================================
# ChangeLog for sys-apps/toybox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/sys-apps/toybox/ChangeLog,v 1.1 2014/04/01 
04:09:36 patrick Exp $

*toybox-9999 (01 Apr 2014)
*toybox-0.4.7 (01 Apr 2014)

  01 Apr 2014; Patrick Lauer <patr...@gentoo.org> +metadata.xml,
  +toybox-0.4.7.ebuild, +toybox-9999.ebuild:
  Initial import, ebuild by me




Reply via email to