hwoarang    14/06/14 12:13:29

  Modified:             ChangeLog
  Added:                sssd-1.11.6.ebuild
  Log:
  Version bump. Bug #477190
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
09BF4F54C2BA7F3C!)

Revision  Changes    Path
1.55                 sys-auth/sssd/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?rev=1.55&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?rev=1.55&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?r1=1.54&r2=1.55

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v
retrieving revision 1.54
retrieving revision 1.55
diff -u -r1.54 -r1.55
--- ChangeLog   27 May 2014 06:32:32 -0000      1.54
+++ ChangeLog   14 Jun 2014 12:13:29 -0000      1.55
@@ -1,6 +1,11 @@
 # ChangeLog for sys-auth/sssd
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.54 2014/05/27 
06:32:32 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.55 2014/06/14 
12:13:29 hwoarang Exp $
+
+*sssd-1.11.6 (14 Jun 2014)
+
+  14 Jun 2014; Markos Chandras <hwoar...@gentoo.org> +sssd-1.11.6.ebuild:
+  Version bump. Bug #477190
 
   27 May 2014; Michał Górny <mgo...@gentoo.org> sssd-1.9.6-r3.ebuild:
   Convert to python-single-r1.



1.1                  sys-auth/sssd/sssd-1.11.6.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/sssd-1.11.6.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/sssd-1.11.6.ebuild?rev=1.1&content-type=text/plain

Index: sssd-1.11.6.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.11.6.ebuild,v 1.1 
2014/06/14 12:13:29 hwoarang Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )

AUTOTOOLS_IN_SOURCE_BUILD=1
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all

inherit python-single-r1 multilib pam linux-info autotools-utils systemd

DESCRIPTION="System Security Services Daemon provides access to identity and 
authentication"
HOMEPAGE="http://fedorahosted.org/sssd/";
SRC_URI="http://fedorahosted.org/released/${PN}/${P}.tar.gz";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="autofs +locator netlink nls +manpages python selinux sudo ssh test"

COMMON_DEP="
        virtual/pam
        >=dev-libs/popt-1.16
        dev-libs/glib:2
        >=dev-libs/ding-libs-0.2
        >=sys-libs/talloc-2.0.7
        >=sys-libs/tdb-1.2.9
        >=sys-libs/tevent-0.9.16
        >=sys-libs/ldb-1.1.17-r1:=
        >=net-nds/openldap-2.4.30[sasl]
        >=dev-libs/libpcre-8.30
        >=app-crypt/mit-krb5-1.10.3
        >=sys-apps/keyutils-1.5
        >=net-dns/c-ares-1.7.4
        >=dev-libs/nss-3.12.9
        selinux? (
                >=sys-libs/libselinux-2.1.9
                >=sys-libs/libsemanage-2.1
                >=sec-policy/selinux-sssd-2.20120725-r9
        )
        >=net-dns/bind-tools-9.9[gssapi]
        >=dev-libs/cyrus-sasl-2.1.25-r3[kerberos]
        >=sys-apps/dbus-1.6
        nls? ( >=sys-devel/gettext-0.18 )
        virtual/libintl
        netlink? ( dev-libs/libnl:3 )
        "

RDEPEND="${COMMON_DEP}
        || ( <=sys-libs/glibc-2.16.9999 >=sys-libs/glibc-2.17[nscd] )
        "
DEPEND="${COMMON_DEP}
        test? ( dev-libs/check )
        manpages? (
                >=dev-libs/libxslt-1.1.26
                app-text/docbook-xml-dtd:4.4
                )"

CONFIG_CHECK="~KEYS"

pkg_setup(){
        use python && python-single-r1_pkg_setup
        linux-info_pkg_setup
}

src_prepare() {
        autotools-utils_src_prepare
}

src_configure(){
        # no samba4 per 447022
        # set initscript to sysv because the systemd option needs systemd to
        # be installed. We provide our own systemd file anyway.
        local myeconfargs=(
                --localstatedir="${EPREFIX}"/var
                --enable-nsslibdir="${EPREFIX}"/$(get_libdir)
                --with-plugin-path="${EPREFIX}"/usr/$(get_libdir)/sssd
                --enable-pammoddir="${EPREFIX}"/$(getpam_mod_dir)
                --with-ldb-lib-dir="${EPREFIX}"/usr/$(get_libdir)/samba/ldb
                --without-nscd
                --with-unicode-lib="glib2"
                --disable-rpath
                --enable-silent-rules
                --sbindir=/usr/sbin
                --without-samba
                $(use_with selinux)
                $(use_with selinux semanage)
                $(use_with python python-bindings)
                $(use_enable locator krb5-locator-plugin)
                $(use_enable nls )
                $(use_with netlink libnl)
                $(use_with manpages)
                $(use_with sudo)
                $(use_with autofs)
                $(use_with ssh)
                --with-crypto="libcrypto"
                --with-initscript="sysv"
                )

        autotools-utils_src_configure
}

src_install(){
        autotools-utils_src_install
        use python && python_optimize

        insinto /etc/sssd
        insopts -m600
        doins "${S}"/src/examples/sssd-example.conf

        insinto /etc/logrotate.d
        insopts -m644
        newins "${S}"/src/examples/logrotate sssd

        newconfd "${FILESDIR}"/sssd.conf sssd

        systemd_dounit "${FILESDIR}/${PN}.service"
}

src_test() {
        autotools-utils_src_test
}

pkg_postinst(){
        elog "You must set up sssd.conf (default installed into /etc/sssd)"
        elog "and (optionally) configuration in /etc/pam.d in order to use SSSD"
        elog "features. Please see howto in     
http://fedorahosted.org/sssd/wiki/HOWTO_Configure_1_0_2";
}




Reply via email to