dlan        14/03/29 22:43:59

  Modified:             ChangeLog
  Added:                ceph-0.78.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 
0xAABEFD55)

Revision  Changes    Path
1.48                 sys-cluster/ceph/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/ceph/ChangeLog?rev=1.48&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/ceph/ChangeLog?rev=1.48&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/ceph/ChangeLog?r1=1.47&r2=1.48

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v
retrieving revision 1.47
retrieving revision 1.48
diff -u -r1.47 -r1.48
--- ChangeLog   20 Feb 2014 10:18:55 -0000      1.47
+++ ChangeLog   29 Mar 2014 22:43:59 -0000      1.48
@@ -1,6 +1,11 @@
 # ChangeLog for sys-cluster/ceph
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.47 
2014/02/20 10:18:55 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.48 
2014/03/29 22:43:59 dlan Exp $
+
+*ceph-0.78 (29 Mar 2014)
+
+  29 Mar 2014; Yixun Lan <d...@gentoo.org> +ceph-0.78.ebuild:
+  version bump
 
 *ceph-0.77 (20 Feb 2014)
 *ceph-0.72.2-r3 (20 Feb 2014)



1.1                  sys-cluster/ceph/ceph-0.78.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/ceph/ceph-0.78.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/ceph/ceph-0.78.ebuild?rev=1.1&content-type=text/plain

Index: ceph-0.78.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.78.ebuild,v 1.1 
2014/03/29 22:43:59 dlan Exp $

EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )

if [[ $PV = *9999* ]]; then
        scm_eclass=git-r3
        EGIT_REPO_URI="
                git://github.com/ceph/ceph.git
                https://github.com/ceph/ceph.git";
        SRC_URI=""
        KEYWORDS=""
else
        SRC_URI="http://ceph.com/download/${P}.tar.bz2";
        KEYWORDS=""
fi

inherit autotools eutils multilib python-any-r1 udev ${scm_eclass}

DESCRIPTION="Ceph distributed filesystem"
HOMEPAGE="http://ceph.com/";

LICENSE="LGPL-2.1"
SLOT="0"
IUSE="cryptopp debug fuse gtk libatomic +libaio +nss radosgw static-libs 
tcmalloc"

CDEPEND="
        app-arch/snappy
        dev-libs/boost:=[threads]
        dev-libs/fcgi
        dev-libs/libaio
        dev-libs/libedit
        dev-libs/leveldb[snappy]
        nss? ( dev-libs/nss )
        cryptopp? ( dev-libs/crypto++ )
        sys-apps/keyutils
        sys-apps/util-linux
        dev-libs/libxml2
        fuse? ( sys-fs/fuse )
        libatomic? ( dev-libs/libatomic_ops )
        gtk? (
                x11-libs/gtk+:2
                dev-cpp/gtkmm:2.4
                gnome-base/librsvg
        )
        radosgw? (
                dev-libs/fcgi
                dev-libs/expat
                net-misc/curl
        )
        tcmalloc? ( dev-util/google-perftools )
        $(python_gen_any_dep '
        virtual/python-argparse[${PYTHON_USEDEP}]
        ' )
        ${PYTHON_DEPS}
        "
DEPEND="${CDEPEND}
        virtual/pkgconfig"
RDEPEND="${CDEPEND}
        sys-apps/hdparm
        $(python_gen_any_dep '
        dev-python/flask[${PYTHON_USEDEP}]
        dev-python/requests[${PYTHON_USEDEP}]
        ' )"
REQUIRED_USE="
        ^^ ( nss cryptopp )
        "

STRIP_MASK="/usr/lib*/rados-classes/*"

PATCHES=( "${FILESDIR}"/${PN}-fix-gnustack.patch )

pkg_setup() {
        python-any-r1_pkg_setup
}

src_prepare() {
        if [ ! -z ${PATCHES[@]} ]; then
                epatch ${PATCHES[@]}
        fi
        sed -e "/bin=/ s:lib:$(get_libdir):" "${FILESDIR}"/${PN}.initd \
                > "${T}"/${PN}.initd || die

        epatch_user
        eautoreconf
}

src_configure() {
        econf \
                --without-hadoop \
                --docdir="${EPREFIX}/usr/share/doc/${PF}" \
                --includedir=/usr/include \
                $(use_with debug) \
                $(use_with fuse) \
                $(use_with libaio) \
                $(use_with libatomic libatomic-ops) \
                $(use_with nss) \
                $(use_with cryptopp) \
                $(use_with radosgw) \
                $(use_with gtk gtk2) \
                $(use_enable static-libs static) \
                $(use_with tcmalloc)
}

src_install() {
        default

        prune_libtool_files --all

        exeinto /usr/$(get_libdir)/ceph
        newexe src/init-ceph ceph_init.sh

        insinto /etc/logrotate.d/
        newins src/logrotate.conf ${PN}

        chmod 644 "${ED}"/usr/share/doc/${PF}/sample.*

        keepdir /var/lib/${PN}
        keepdir /var/lib/${PN}/tmp
        keepdir /var/log/${PN}/stat

        newinitd "${T}/${PN}.initd" ${PN}
        newconfd "${FILESDIR}/${PN}.confd" ${PN}

        _python_rewrite_shebang \
                "${ED}"/usr/sbin/{ceph-disk,ceph-create-keys} \
                "${ED}"/usr/bin/{ceph,ceph-rest-api}

        #install udev rules
        udev_dorules udev/50-rbd.rules
        udev_dorules udev/95-ceph-osd.rules
}

pkg_postinst() {
        elog "We suggest to install following packages"
        elog " sys-block/parted         to manage disk partions"
        elog " sys-fs/btrfs-progs       to use btrfs filesytem"
        elog " sys-fs/cryptsetup        to use encrypted devices with dm-crypt"
}




Reply via email to