maksbotan    15/06/15 10:15:07

  Modified:             ChangeLog
  Added:                vzctl-4.9.2.ebuild
  Log:
  Bump to 4.9.2, thanks to slepnoga
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
F8DBDADE)

Revision  Changes    Path
1.140                sys-cluster/vzctl/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/vzctl/ChangeLog?rev=1.140&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/vzctl/ChangeLog?rev=1.140&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/vzctl/ChangeLog?r1=1.139&r2=1.140

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v
retrieving revision 1.139
retrieving revision 1.140
diff -u -r1.139 -r1.140
--- ChangeLog   14 Jun 2015 07:55:26 -0000      1.139
+++ ChangeLog   15 Jun 2015 10:15:07 -0000      1.140
@@ -1,6 +1,11 @@
 # ChangeLog for sys-cluster/vzctl
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.139 
2015/06/14 07:55:26 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.140 
2015/06/15 10:15:07 maksbotan Exp $
+
+*vzctl-4.9.2 (15 Jun 2015)
+
+  15 Jun 2015; Maxim Koltsov <maksbo...@gentoo.org> +vzctl-4.9.2.ebuild:
+  Bump to 4.9.2, thanks to slepnoga
 
   14 Jun 2015; Mikle Kolyada <zlog...@gentoo.org> -vzctl-4.8.ebuild:
   Drop old.



1.1                  sys-cluster/vzctl/vzctl-4.9.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/vzctl/vzctl-4.9.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-cluster/vzctl/vzctl-4.9.2.ebuild?rev=1.1&content-type=text/plain

Index: vzctl-4.9.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.9.2.ebuild,v 1.1 
2015/06/15 10:15:07 maksbotan Exp $

EAPI="5"

inherit base bash-completion-r1 eutils toolchain-funcs udev

DESCRIPTION="OpenVZ ConTainers control utility"
HOMEPAGE="http://openvz.org/";
SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 -amd64-fbsd -sparc-fbsd -x86-fbsd"
IUSE="+ploop +vzmigrate"

RDEPEND="net-firewall/iptables
                sys-apps/ed
                >=sys-apps/iproute2-3.3.0
                >=sys-fs/vzquota-3.1
                ploop? (
                        >=sys-cluster/ploop-1.13
                        sys-block/parted
                        sys-fs/quota
                        dev-libs/libxml2
                        )
                >=dev-libs/libcgroup-0.38
                vzmigrate? (
                net-misc/openssh
                net-misc/rsync[xattr,acl]
                app-arch/tar[xattr,acl]
                net-misc/bridge-utils
                virtual/awk
                        )
                virtual/udev
                sys-apps/attr
                "

DEPEND="${RDEPEND}
        virtual/pkgconfig
        "

src_prepare() {

        # Set default OSTEMPLATE on gentoo
        sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on 
etc/dists/default failed'
        # Set proper udev directory
        sed -i -e "s:/lib/udev:$(get_udevdir):" src/lib/dev.c || die 'sed on 
src/lib/dev.c failed'
}

src_configure() {

        econf \
                --localstatedir=/var \
                --enable-udev \
                --enable-bashcomp \
                --enable-logrotate \
                --with-vz \
                $(use_with ploop) \
                --with-cgroup
}

src_install() {

        emake DESTDIR="${D}" udevdir="$(get_udevdir)"/rules.d install 
install-gentoo

        # install the bash-completion script into the right location
        rm -rf "${ED}"/etc/bash_completion.d
        newbashcomp etc/bash_completion.d/vzctl.sh ${PN}

        # We need to keep some dirs
        keepdir /vz/{dump,lock,root,private,template/cache}
        keepdir /etc/vz/names /var/lib/vzctl/veip
}

pkg_postinst() {
        einfo "This vzctl release required kernel above 2.6.32.92"

        einfo "If you have checkpoint suspend/restore feature in vanilla kernel"
        einfo "please install "sys-process/criu" "
        einfo "This is experimental and not stable ( in gentoo ) now"

        einfo "if you have work with  .xz compressed template, please install 
app-arch/xz-utils"
        einfo "if you have check signature donwloaded template - install gpg "
}




Reply via email to