vapier      15/03/29 19:24:26

  Modified:             metadata.xml gcc-3.4.6-r2.ebuild ChangeLog
  Log:
  Drop old mips-specific patches -- they can use newer gcc-4 versions.  The 
r10k patch has been moved to the gentoo patchset.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
D2E96200)

Revision  Changes    Path
1.22                 sys-devel/gcc/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/metadata.xml?rev=1.22&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/metadata.xml?rev=1.22&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/metadata.xml?r1=1.21&r2=1.22

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/gcc/metadata.xml,v
retrieving revision 1.21
retrieving revision 1.22
diff -u -r1.21 -r1.22
--- metadata.xml        29 Mar 2015 19:17:06 -0000      1.21
+++ metadata.xml        29 Mar 2015 19:24:26 -0000      1.22
@@ -12,17 +12,11 @@
     <flag name="go">Build the GCC Go language frontend.</flag>
     <flag name="graphite">Add support for the framework for loop
       optimizations based on a polyhedral intermediate representation</flag>
-    <flag name="ip28">Enable building a compiler capable of building a kernel
-      for SGI Indigo2 Impact R10000 (IP28)</flag>
-    <flag name="ip32r10k">Enable building a compiler capable of building an
-      experimental kernel for SGI O2 w/ R1x000 CPUs (IP32)</flag>
     <flag name="libssp">Build SSP support into a dedicated library rather than 
use the
       code in the C library (DO NOT ENABLE THIS IF YOU DON'T KNOW WHAT IT 
DOES)</flag>
     <flag name="mudflap">Add support for mudflap, a pointer use checking 
library</flag>
     <flag name="multislot">Allow for SLOTs to include minor version (3.3.4
       instead of just 3.3)</flag>
-    <flag name="n32">Enable n32 ABI support on mips</flag>
-    <flag name="n64">Enable n64 ABI support on mips</flag>
     <flag name="nopie">Disable PIE support (NOT FOR GENERAL USE)</flag>
     <flag name="nossp">Disable SSP support (NOT FOR GENERAL USE)</flag>
     <flag name="objc">Build support for the Objective C code language</flag>



1.39                 sys-devel/gcc/gcc-3.4.6-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild?rev=1.39&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild?rev=1.39&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild?r1=1.38&r2=1.39

Index: gcc-3.4.6-r2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v
retrieving revision 1.38
retrieving revision 1.39
diff -u -r1.38 -r1.39
--- gcc-3.4.6-r2.ebuild 23 Oct 2014 23:48:17 -0000      1.38
+++ gcc-3.4.6-r2.ebuild 29 Mar 2015 19:24:26 -0000      1.39
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.38 
2014/10/23 23:48:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.39 
2015/03/29 19:24:26 vapier Exp $
 
 EAPI="2"
 
@@ -14,7 +14,6 @@
 inherit eutils toolchain
 
 KEYWORDS="-* alpha amd64 arm ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 
~x86-fbsd"
-IUSE="ip28 ip32r10k n32 n64"
 
 # we need a proper glibc version for the Scrt1.o provided to the pie-ssp specs
 # NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
@@ -41,34 +40,6 @@
 
        # Arch stuff
        case $(tc-arch) in
-               mips)
-                       # If mips, and we DON'T want multilib, then rig gcc to 
only use n32 OR n64
-                       if ! is_multilib; then
-                               use n32 && epatch 
"${FILESDIR}"/3.4.1/gcc-3.4.1-mips-n32only.patch
-                               use n64 && epatch 
"${FILESDIR}"/3.4.1/gcc-3.4.1-mips-n64only.patch
-                       fi
-
-                       # Patch forward-ported from a gcc-3.0.x patch that adds 
-march=r10000 and
-                       # -mtune=r10000 support to gcc (Allows the compiler to 
generate code to
-                       # take advantage of R10k's second ALU, perform shifts, 
etc..
-                       #
-                       # Needs re-porting to DFA in gcc-4.0 - Any Volunteers? 
:)
-                       epatch 
"${FILESDIR}"/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch
-
-                       # This is a very special patch -- it allows us to build 
semi-usable kernels
-                       # on SGI IP28 (Indigo2 Impact R10000) systems.  The 
patch is henceforth
-                       # regarded as a kludge by upstream, and thus, it will 
never get accepted upstream,
-                       # but for our purposes of building a kernel, it works.
-                       # Unless you're building an IP28 kernel, you really 
don't need care about what
-                       # this patch does, because if you are, you are probably 
already aware of what
-                       # it does.
-                       # All that said, the abilities of this patch are 
disabled by default and need
-                       # to be enabled by passing -mip28-cache-barrier.  Only 
used to build kernels,
-                       # There is the possibility it may be used for very 
specific userland apps too.
-                       if use ip28 || use ip32r10k; then
-                               epatch 
"${FILESDIR}"/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch
-                       fi
-                       ;;
                amd64)
                        if is_multilib ; then
                                sed -i -e '/GLIBCXX_IS_NATIVE=/s:false:true:' 
libstdc++-v3/configure || die



1.1054               sys-devel/gcc/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/ChangeLog?rev=1.1054&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/ChangeLog?rev=1.1054&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/gcc/ChangeLog?r1=1.1053&r2=1.1054

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v
retrieving revision 1.1053
retrieving revision 1.1054
diff -u -r1.1053 -r1.1054
--- ChangeLog   29 Mar 2015 19:17:06 -0000      1.1053
+++ ChangeLog   29 Mar 2015 19:24:26 -0000      1.1054
@@ -1,6 +1,15 @@
 # ChangeLog for sys-devel/gcc
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1053 2015/03/29 
19:17:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.1054 2015/03/29 
19:24:26 vapier Exp $
+
+  29 Mar 2015; Mike Frysinger <vap...@gentoo.org>
+  -files/3.4.1/gcc-3.4.1-mips-n32only.patch,
+  -files/3.4.1/gcc-3.4.1-mips-n64only.patch,
+  -files/3.4.2/gcc-3.4.2-mips-ip28_cache_barriers-v4.patch,
+  -files/3.4.2/gcc-3.4.x-mips-add-march-r10k.patch, gcc-3.4.6-r2.ebuild,
+  metadata.xml:
+  Drop old mips-specific patches -- they can use newer gcc-4 versions.  The 
r10k
+  patch has been moved to the gentoo patchset.
 
   29 Mar 2015; Mike Frysinger <vap...@gentoo.org> metadata.xml:
   Add USE=cilk to control support for the Cilk Plus language.




Reply via email to