mgorny      14/06/11 07:49:45

  Modified:             llvm-3.4-r2.ebuild llvm-3.4.1-r1.ebuild ChangeLog
  Log:
  Always use built-in ConfigParser to work-around issues with configparser-3.2, 
bug #500856.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.5                  sys-devel/llvm/llvm-3.4-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild?rev=1.5&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild?rev=1.5&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild?r1=1.4&r2=1.5

Index: llvm-3.4-r2.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- llvm-3.4-r2.ebuild  1 May 2014 15:09:30 -0000       1.4
+++ llvm-3.4-r2.ebuild  11 Jun 2014 07:49:45 -0000      1.5
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild,v 1.4 
2014/05/01 15:09:30 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4-r2.ebuild,v 1.5 
2014/06/11 07:49:45 mgorny Exp $
 
 EAPI=5
 
@@ -167,6 +167,9 @@
        epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
        # Hack cmake search path for Gentoo, bug #496480
        epatch "${FILESDIR}"/${PN}-3.3-cmake-modulepath.patch
+       # Use built-in ConfigParser to avoid failures with configparser-3.2
+       # https://bugs.gentoo.org/show_bug.cgi?id=500856
+       epatch "${FILESDIR}"/${PN}-3.4-cmake-configparser.patch
 
        if use clang; then
                # Automatically select active system GCC's libraries, bugs 
#406163 and #417913



1.2                  sys-devel/llvm/llvm-3.4.1-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild?r1=1.1&r2=1.2

Index: llvm-3.4.1-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- llvm-3.4.1-r1.ebuild        10 May 2014 22:32:59 -0000      1.1
+++ llvm-3.4.1-r1.ebuild        11 Jun 2014 07:49:45 -0000      1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild,v 1.1 
2014/05/10 22:32:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.1-r1.ebuild,v 1.2 
2014/06/11 07:49:45 mgorny Exp $
 
 EAPI=5
 
@@ -170,6 +170,9 @@
        epatch "${FILESDIR}"/${PN}-3.4-gentoo-install.patch
        # Hack cmake search path for Gentoo, bug #496480
        epatch "${FILESDIR}"/${PN}-3.3-cmake-modulepath.patch
+       # Use built-in ConfigParser to avoid failures with configparser-3.2
+       # https://bugs.gentoo.org/show_bug.cgi?id=500856
+       epatch "${FILESDIR}"/${PN}-3.4-cmake-configparser.patch
 
        if use clang; then
                # Automatically select active system GCC's libraries, bugs 
#406163 and #417913



1.198                sys-devel/llvm/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.198&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?rev=1.198&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-devel/llvm/ChangeLog?r1=1.197&r2=1.198

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v
retrieving revision 1.197
retrieving revision 1.198
diff -u -r1.197 -r1.198
--- ChangeLog   11 May 2014 11:17:08 -0000      1.197
+++ ChangeLog   11 Jun 2014 07:49:45 -0000      1.198
@@ -1,6 +1,12 @@
 # ChangeLog for sys-devel/llvm
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.197 2014/05/11 
11:17:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.198 2014/06/11 
07:49:45 mgorny Exp $
+
+  11 Jun 2014; Michał Górny <mgo...@gentoo.org>
+  +files/llvm-3.4-cmake-configparser.patch, llvm-3.4-r2.ebuild,
+  llvm-3.4.1-r1.ebuild:
+  Always use built-in ConfigParser to work-around issues with configparser-3.2,
+  bug #500856.
 
   11 May 2014; Michał Górny <mgo...@gentoo.org> -llvm-3.3-r1.ebuild,
   -llvm-3.4-r1.ebuild, -llvm-3.4.ebuild:




Reply via email to