radhermit    14/08/31 06:11:13

  Modified:             ChangeLog
  Added:                avfs-1.0.2.ebuild
  Log:
  Version bump (bug #516866).
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
4F064CA3)

Revision  Changes    Path
1.51                 sys-fs/avfs/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/avfs/ChangeLog?rev=1.51&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/avfs/ChangeLog?rev=1.51&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/avfs/ChangeLog?r1=1.50&r2=1.51

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v
retrieving revision 1.50
retrieving revision 1.51
diff -u -r1.50 -r1.51
--- ChangeLog   10 Aug 2014 20:19:19 -0000      1.50
+++ ChangeLog   31 Aug 2014 06:11:12 -0000      1.51
@@ -1,6 +1,11 @@
 # ChangeLog for sys-fs/avfs
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.50 2014/08/10 
20:19:19 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.51 2014/08/31 
06:11:12 radhermit Exp $
+
+*avfs-1.0.2 (31 Aug 2014)
+
+  31 Aug 2014; Tim Harder <radher...@gentoo.org> +avfs-1.0.2.ebuild:
+  Version bump (bug #516866).
 
   10 Aug 2014; Sergei Trofimovich <sly...@gentoo.org> avfs-1.0.1.ebuild:
   QA: drop trailing '.' from DESCRIPTION



1.1                  sys-fs/avfs/avfs-1.0.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/avfs/avfs-1.0.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/avfs/avfs-1.0.2.ebuild?rev=1.1&content-type=text/plain

Index: avfs-1.0.2.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-1.0.2.ebuild,v 1.1 
2014/08/31 06:11:13 radhermit Exp $

EAPI=5
inherit eutils

DESCRIPTION="AVFS is a virtual filesystem that allows browsing of compressed 
files"
HOMEPAGE="http://sourceforge.net/projects/avf";
SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
IUSE="static-libs +lzma"

RDEPEND=">=sys-fs/fuse-2.4
        sys-libs/zlib
        app-arch/bzip2
        lzma? ( app-arch/xz-utils )"
DEPEND="${RDEPEND}
        virtual/pkgconfig"

src_configure() {
        econf \
                --enable-fuse \
                --enable-library \
                --enable-shared \
                --with-system-zlib \
                --with-system-bzlib \
                $(use_enable static-libs static) \
                $(use_with lzma xz)
}

src_install() {
        default

        # remove cruft
        rm "${D}"/usr/bin/{davpass,ftppass} || die

        # install docs
        dodoc doc/{api-overview,background,FORMAT,INSTALL.*,README.avfs-fuse}
        dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs

        docinto scripts
        dodoc scripts/{avfscoda*,*pass}

        prune_libtool_files
}

pkg_postinst() {
        einfo "This version of AVFS includes FUSE support. It is user-based."
        einfo "To execute:"
        einfo "1) as user, mkdir ~/.avfs"
        einfo "2) make sure fuse is either compiled into the kernel OR"
        einfo "   modprobe fuse or add to startup."
        einfo "3) run mountavfs"
        einfo "To unload daemon, type umountavfs"
        einfo
        einfo "READ the documentation! Enjoy :)"
}




Reply via email to