vapier      15/01/27 04:48:51

  Modified:             ChangeLog
  Added:                mtd-utils-1.5.1.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
D2E96200)

Revision  Changes    Path
1.62                 sys-fs/mtd-utils/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/mtd-utils/ChangeLog?rev=1.62&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/mtd-utils/ChangeLog?rev=1.62&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/mtd-utils/ChangeLog?r1=1.61&r2=1.62

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v
retrieving revision 1.61
retrieving revision 1.62
diff -u -r1.61 -r1.62
--- ChangeLog   21 Feb 2013 00:03:43 -0000      1.61
+++ ChangeLog   27 Jan 2015 04:48:51 -0000      1.62
@@ -1,6 +1,11 @@
 # ChangeLog for sys-fs/mtd-utils
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.61 
2013/02/21 00:03:43 zmedico Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.62 
2015/01/27 04:48:51 vapier Exp $
+
+*mtd-utils-1.5.1 (27 Jan 2015)
+
+  27 Jan 2015; Mike Frysinger <vap...@gentoo.org> +mtd-utils-1.5.1.ebuild:
+  Version bump.
 
   21 Feb 2013; Zac Medico <zmed...@gentoo.org> mtd-utils-1.5.0.ebuild,
   mtd-utils-99999999.ebuild:



1.1                  sys-fs/mtd-utils/mtd-utils-1.5.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/mtd-utils/mtd-utils-1.5.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-fs/mtd-utils/mtd-utils-1.5.1.ebuild?rev=1.1&content-type=text/plain

Index: mtd-utils-1.5.1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-1.5.1.ebuild,v 
1.1 2015/01/27 04:48:51 vapier Exp $

EAPI="4"

inherit eutils vcs-snapshot

if [[ ${PV} == "99999999" ]] ; then
        EGIT_REPO_URI="git://git.infradead.org/mtd-utils.git"

        inherit git-2
        SRC_URI=""
        #KEYWORDS=""
else
        if [[ ${PV} == *.*.* ]] ; then
                MY_PV="${PV}-*"
                
SRC_URI="http://git.infradead.org/mtd-utils.git/snapshot/v${PV}.tar.gz -> 
${P}.tar.gz"
        else
                MY_PV="${PV}-02ae0aac87576d07202a62d11294ea55b56f450b"
                SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.xz"
        fi
        KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~arm-linux 
~x86-linux"
fi

DESCRIPTION="MTD userspace tools (NFTL, JFFS2, NAND, FTL, UBI)"
HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary";

LICENSE="GPL-2"
SLOT="0"
IUSE="xattr"

# We need libuuid
RDEPEND="!sys-fs/mtd
        dev-libs/lzo
        sys-libs/zlib
        >=sys-apps/util-linux-2.16"
# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
# And ACL brings in Attr as well.
DEPEND="${RDEPEND}
        xattr? ( sys-apps/acl )"

makeopts() {
        # These affect build output, so keep it common between compile & 
install.
        echo CROSS=${CHOST}- V=1
        use xattr || echo WITHOUT_XATTR=1
}

src_compile() {
        tc-export AR CC RANLIB
        local compileopts=(
                AR="${AR}" CC="${CC}" RANLIB="${RANLIB}"
        )
        emake $(makeopts) "${compileopts[@]}"
}

src_install() {
        emake $(makeopts) install DESTDIR="${ED}"
        dodoc *.txt
        newdoc mkfs.ubifs/README README.mkfs.ubifs
        # TODO: check ubi-utils for docs+scripts
}




Reply via email to