ryao        14/04/11 04:42:22

  Modified:             ChangeLog
  Added:                spl-0.6.2-r5.ebuild
  Log:
  The patchset used in sys-kernel/spl-0.6.2-r4 was an early version that was 
not meant to go out to mirrors. It is being replaced with 
sys-kernel/spl-0.6.2-r5, which is what -r4 should have been. No regressions 
occurred as a result of this mistake.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0xBEE84C64)

Revision  Changes    Path
1.69                 sys-kernel/spl/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/spl/ChangeLog?rev=1.69&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/spl/ChangeLog?rev=1.69&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/spl/ChangeLog?r1=1.68&r2=1.69

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v
retrieving revision 1.68
retrieving revision 1.69
diff -u -r1.68 -r1.69
--- ChangeLog   10 Apr 2014 03:12:25 -0000      1.68
+++ ChangeLog   11 Apr 2014 04:42:22 -0000      1.69
@@ -1,6 +1,14 @@
 # ChangeLog for sys-kernel/spl
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.68 2014/04/10 
03:12:25 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/ChangeLog,v 1.69 2014/04/11 
04:42:22 ryao Exp $
+
+*spl-0.6.2-r5 (11 Apr 2014)
+
+  11 Apr 2014; Richard Yao <r...@gentoo.org> +spl-0.6.2-r5.ebuild:
+  The patchset used in sys-kernel/spl-0.6.2-r4 was an early version that was 
not
+  meant to go out to mirrors. It is being replaced with 
sys-kernel/spl-0.6.2-r5,
+  which is what -r4 should have been. No regressions occurred as a result of
+  this mistake.
 
 *spl-0.6.2-r4 (10 Apr 2014)
 



1.1                  sys-kernel/spl/spl-0.6.2-r5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/spl/spl-0.6.2-r5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-kernel/spl/spl-0.6.2-r5.ebuild?rev=1.1&content-type=text/plain

Index: spl-0.6.2-r5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-kernel/spl/spl-0.6.2-r5.ebuild,v 1.1 
2014/04/11 04:42:22 ryao Exp $

EAPI="4"
AUTOTOOLS_AUTORECONF="1"

inherit flag-o-matic linux-info linux-mod autotools-utils

if [[ ${PV} == "9999" ]] ; then
        inherit git-2
        EGIT_REPO_URI="git://github.com/zfsonlinux/${PN}.git"
else
        inherit eutils versionator
        MY_PV=$(replace_version_separator 3 '-')
        
SRC_URI="https://github.com/zfsonlinux/${PN}/archive/${PN}-${MY_PV}.tar.gz
                http://dev.gentoo.org/~ryao/dist/${PN}-${MY_PV}-p4.tar.xz";
        S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
        KEYWORDS="~amd64"
fi

DESCRIPTION="The Solaris Porting Layer is a Linux kernel module which provides 
many of the Solaris kernel APIs"
HOMEPAGE="http://zfsonlinux.org/";

LICENSE="GPL-2"
SLOT="0"
IUSE="custom-cflags debug debug-log"
RESTRICT="test"

COMMON_DEPEND="dev-lang/perl
        virtual/awk"

DEPEND="${COMMON_DEPEND}"

RDEPEND="${COMMON_DEPEND}
        !sys-devel/spl"

AT_M4DIR="config"
AUTOTOOLS_IN_SOURCE_BUILD="1"

pkg_setup() {
        linux-info_pkg_setup
        CONFIG_CHECK="
                !DEBUG_LOCK_ALLOC
                !GRKERNSEC_HIDESYM
                MODULES
                KALLSYMS
                !PAX_KERNEXEC_PLUGIN_METHOD_OR
                ZLIB_DEFLATE
                ZLIB_INFLATE
        "

        kernel_is ge 2 6 26 || die "Linux 2.6.26 or newer required"

        [ ${PV} != "9999" ] && \
                { kernel_is le 3 14 || die "Linux 3.14 is the latest supported 
version."; }

        check_extra_config
}

src_prepare() {
        # Workaround for hard coded path
        sed -i "s|/sbin/lsmod|/bin/lsmod|" scripts/check.sh || die

        if [ ${PV} != "9999" ]
        then
                # Apply patch set
                EPATCH_SUFFIX="patch" \
                EPATCH_FORCE="yes" \
                epatch "${WORKDIR}/${PN}-${MY_PV}-patches"
        fi

        # splat is unnecessary unless we are debugging
        use debug || sed -e 's/^subdir-m += splat$//' -i 
"${S}/module/Makefile.in"

        autotools-utils_src_prepare
}

src_configure() {
        use custom-cflags || strip-flags
        filter-ldflags -Wl,*

        set_arch_to_kernel
        local myeconfargs=(
                --bindir="${EPREFIX}/bin"
                --sbindir="${EPREFIX}/sbin"
                --with-config=all
                --with-linux="${KV_DIR}"
                --with-linux-obj="${KV_OUT_DIR}"
                $(use_enable debug)
                $(use_enable debug-log)
        )
        autotools-utils_src_configure
}

src_install() {
        autotools-utils_src_install
        dodoc AUTHORS DISCLAIMER README.markdown
}

pkg_postinst() {
        linux-mod_pkg_postinst

        # Remove old modules
        if [ -d "${EROOT}lib/modules/${KV_FULL}/addon/spl" ]
        then
                ewarn "${PN} now installs modules in 
${EROOT}lib/modules/${KV_FULL}/extra/spl"
                ewarn "Old modules were detected in 
${EROOT}lib/modules/${KV_FULL}/addon/spl"
                ewarn "Automatically removing old modules to avoid problems."
                rm -r "${EROOT}lib/modules/${KV_FULL}/addon/spl" || die "Cannot 
remove modules"
                rmdir --ignore-fail-on-non-empty 
"${EROOT}lib/modules/${KV_FULL}/addon"
        fi
}




Reply via email to