leio        14/10/06 01:06:16

  Modified:             ChangeLog
  Added:                wxGTK-3.0.1.1.ebuild
  Log:
  Version bump (bug #515120)
  
  (Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)

Revision  Changes    Path
1.315                x11-libs/wxGTK/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/wxGTK/ChangeLog?rev=1.315&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/wxGTK/ChangeLog?rev=1.315&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/wxGTK/ChangeLog?r1=1.314&r2=1.315

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v
retrieving revision 1.314
retrieving revision 1.315
diff -u -r1.314 -r1.315
--- ChangeLog   23 May 2014 08:21:26 -0000      1.314
+++ ChangeLog   6 Oct 2014 01:06:16 -0000       1.315
@@ -1,6 +1,11 @@
 # ChangeLog for x11-libs/wxGTK
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.314 2014/05/23 
08:21:26 rhill Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.315 2014/10/06 
01:06:16 leio Exp $
+
+*wxGTK-3.0.1.1 (06 Oct 2014)
+
+  06 Oct 2014; Mart Raudsepp <l...@gentoo.org> +wxGTK-3.0.1.1.ebuild:
+  Version bump (bug #515120)
 
   23 May 2014; Ryan Hill <rh...@gentoo.org> -wxGTK-2.8.12.1.ebuild,
   wxGTK-2.8.12.1-r1.ebuild, wxGTK-3.0.0.0.ebuild:



1.1                  x11-libs/wxGTK/wxGTK-3.0.1.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/wxGTK/wxGTK-3.0.1.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-libs/wxGTK/wxGTK-3.0.1.1.ebuild?rev=1.1&content-type=text/plain

Index: wxGTK-3.0.1.1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-3.0.1.1.ebuild,v 1.1 
2014/10/06 01:06:16 leio Exp $

EAPI="5"

inherit eutils flag-o-matic

DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
HOMEPAGE="http://wxwidgets.org/";

# we use the wxPython tarballs because they include the full wxGTK sources and
# docs, and are released more frequently than wxGTK.
SRC_URI="mirror://sourceforge/wxpython/wxPython-src-${PV}.tar.bz2
        doc? ( mirror://sourceforge/wxpython/wxPython-docs-${PV}.tar.bz2 )"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 
~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos 
~x86-macos"
IUSE="+X aqua doc debug gstreamer libnotify opengl sdl tiff webkit"

SLOT="3.0"

RDEPEND="
        dev-libs/expat
        sdl?    ( media-libs/libsdl )
        X?  (
                >=dev-libs/glib-2.22:2
                media-libs/libpng:0=
                sys-libs/zlib
                virtual/jpeg
                >=x11-libs/gtk+-2.18:2
                x11-libs/gdk-pixbuf
                x11-libs/libSM
                x11-libs/libXxf86vm
                x11-libs/pango[X]
                gstreamer? (
                        media-libs/gstreamer:0.10
                        media-libs/gst-plugins-base:0.10 )
                libnotify? ( x11-libs/libnotify )
                opengl? ( virtual/opengl )
                tiff?   ( media-libs/tiff:0 )
                webkit? ( net-libs/webkit-gtk:2 )
                )
        aqua? (
                >=x11-libs/gtk+-2.4[aqua=]
                virtual/jpeg
                tiff?   ( media-libs/tiff:0 )
                )"

DEPEND="${RDEPEND}
        virtual/pkgconfig
        opengl? ( virtual/glu )
        X?  (
                x11-proto/xproto
                x11-proto/xineramaproto
                x11-proto/xf86vidmodeproto
                )"

PDEPEND=">=app-admin/eselect-wxwidgets-20131230"

LICENSE="wxWinLL-3
                GPL-2
                doc?    ( wxWinFDL-3 )"

S="${WORKDIR}/wxPython-src-${PV}"

src_prepare() {
        epatch "${FILESDIR}"/${PN}-3.0.0.0-collision.patch

        # https://bugs.gentoo.org/421851
        # https://bugs.gentoo.org/499984
        sed -i -e "/wx_cv_std_libpath=/s:=.*:=$(get_libdir):" configure || die

        epatch_user
}

src_configure() {
        local myconf

        # X independent options
        myconf="
                        --with-zlib=sys
                        --with-expat=sys
                        --enable-compat28
                        $(use_with sdl)"

        # debug in >=2.9
        # there is no longer separate debug libraries (gtk2ud)
        # wxDEBUG_LEVEL=1 is the default and we will leave it enabled
        # wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
        # apps can disable these features by building w/ -NDEBUG or 
wxDEBUG_LEVEL_0.
        # http://docs.wxwidgets.org/3.0/overview_debugging.html
        # 
http://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
        use debug \
                && myconf="${myconf} --enable-debug=max"

        # wxGTK options
        #   --enable-graphics_ctx - needed for webkit, editra
        #   --without-gnomevfs - bug #203389
        use X && \
                myconf="${myconf}
                        --enable-graphics_ctx
                        --with-gtkprint
                        --enable-gui
                        --with-libpng=sys
                        --with-libxpm=sys
                        --with-libjpeg=sys
                        --without-gnomevfs
                        $(use_enable gstreamer mediactrl)
                        $(use_enable webkit webview)
                        $(use_with libnotify)
                        $(use_with opengl)
                        $(use_with tiff libtiff sys)"

        use aqua && \
                myconf="${myconf}
                        --enable-graphics_ctx
                        --enable-gui
                        --with-libpng=sys
                        --with-libxpm=sys
                        --with-libjpeg=sys
                        --with-mac
                        --with-opengl"
                        # cocoa toolkit seems to be broken

        # wxBase options
        if use !X && use !aqua ; then
                myconf="${myconf}
                        --disable-gui"
        fi

        mkdir "${S}"/wxgtk_build
        cd "${S}"/wxgtk_build

        ECONF_SOURCE="${S}" econf ${myconf}
}

src_compile() {
        cd "${S}"/wxgtk_build
        emake
}

src_install() {
        cd "${S}"/wxgtk_build

        emake DESTDIR="${D}" install

        cd "${S}"/docs
        dodoc changes.txt readme.txt
        newdoc base/readme.txt base_readme.txt
        newdoc gtk/readme.txt gtk_readme.txt

        if use doc; then
                dohtml -r "${S}"/docs/doxygen/out/html/*
        fi

        # Stray windows locale file, causes collisions
        local wxmsw="${ED}usr/share/locale/it/LC_MESSAGES/wxmsw.mo"
        [[ -e ${wxmsw} ]] && rm "${wxmsw}"
}

pkg_postinst() {
        has_version app-admin/eselect-wxwidgets \
                && eselect wxwidgets update
}

pkg_postrm() {
        has_version app-admin/eselect-wxwidgets \
                && eselect wxwidgets update
}




Reply via email to