idella4     15/01/26 12:31:03

  Modified:             fluxbox-9999.ebuild fluxbox-1.3.5-r1.ebuild
                        ChangeLog
  Removed:              fluxbox-1.3.6.ebuild
  Log:
  update patch with final form from upstream, add missed addition from bug 
537356 to -1.3.5-r1, full update to live ebuild from patch from same bug, 
remove broken 1.3.6 ebuild, fixes Bugs 537356, 536370 by maintainers
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.14                 x11-wm/fluxbox/fluxbox-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild?rev=1.14&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild?rev=1.14&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild?r1=1.13&r2=1.14

Index: fluxbox-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild,v
retrieving revision 1.13
retrieving revision 1.14
diff -u -r1.13 -r1.14
--- fluxbox-9999.ebuild 8 Jan 2013 21:32:50 -0000       1.13
+++ fluxbox-9999.ebuild 26 Jan 2015 12:31:03 -0000      1.14
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild,v 1.13 
2013/01/08 21:32:50 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-9999.ebuild,v 1.14 
2015/01/26 12:31:03 idella4 Exp $
 
-EAPI=4
+EAPI=5
 inherit eutils flag-o-matic toolchain-funcs git-2 prefix
 
 IUSE="nls xinerama bidi +truetype +imlib +slit +toolbar vim-syntax"
@@ -12,29 +12,32 @@
 EGIT_REPO_URI="git://git.fluxbox.org/fluxbox.git"
 SRC_URI=""
 HOMEPAGE="http://www.fluxbox.org";
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS=""
 
-RDEPEND="x11-libs/libXpm
-       x11-libs/libXrandr
+RDEPEND="
+       !!<=x11-misc/fbdesk-1.2.1
+       !!<=x11-misc/fluxconf-0.9.9
+       !!<x11-themes/fluxbox-styles-fluxmod-20040809-r1
+       bidi? ( >=dev-libs/fribidi-0.19.2 )
+       imlib? ( >=media-libs/imlib2-1.2.0[X] )
+       truetype? ( media-libs/freetype )
+       vim-syntax? ( app-vim/fluxbox-syntax )
        x11-libs/libXext
        x11-libs/libXft
+       x11-libs/libXpm
+       x11-libs/libXrandr
        x11-libs/libXrender
-       || ( x11-misc/gxmessage x11-apps/xmessage )
        xinerama? ( x11-libs/libXinerama )
-       truetype? ( media-libs/freetype )
-       bidi? ( >=dev-libs/fribidi-0.19.2 )
-       imlib? ( >=media-libs/imlib2-1.2.0[X] )
-       vim-syntax? ( app-vim/fluxbox-syntax )
-       !!<x11-themes/fluxbox-styles-fluxmod-20040809-r1
-       !!<=x11-misc/fluxconf-0.9.9
-       !!<=x11-misc/fbdesk-1.2.1"
-DEPEND="bidi? ( virtual/pkgconfig )
+       || ( x11-misc/gxmessage x11-apps/xmessage )
+"
+DEPEND="
+       ${RDEPEND}
+       bidi? ( virtual/pkgconfig )
        nls? ( sys-devel/gettext )
        x11-proto/xextproto
-       ${RDEPEND}"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS=""
+"
 
 src_prepare() {
        ./autogen.sh
@@ -45,6 +48,8 @@
        epatch "${FILESDIR}/gentoo_style_location-1.1.x.patch"
        eprefixify util/fluxbox-generate_menu.in
 
+       epatch "${FILESDIR}"/osx-has-otool.patch
+
        # Add in the Gentoo -r number to fluxbox -version output.
        if [[ "${PR}" == "r0" ]] ; then
                suffix="gentoo"
@@ -59,17 +64,17 @@
 src_configure() {
        use bidi && append-cppflags "$($(tc-getPKG_CONFIG) --cflags fribidi)"
 
-       econf \
-               $(use_enable nls) \
-               $(use_enable xinerama) \
-               $(use_enable truetype xft) \
+       econf ${myconf} \
+               $(use_enable bidi fribidi ) \
                $(use_enable imlib imlib2) \
+               $(use_enable nls) \
                $(use_enable slit ) \
                $(use_enable toolbar ) \
-               $(use_enable bidi fribidi ) \
+               $(use_enable toolbar systray ) \
+               $(use_enable truetype xft) \
+               $(use_enable xinerama) \
                --sysconfdir="${EPREFIX}"/etc/X11/${PN} \
-               --with-style="${EPREFIX}"/usr/share/fluxbox/styles/Emerge \
-               ${myconf}
+               --with-style="${EPREFIX}"/usr/share/fluxbox/styles/Emerge
 }
 
 src_compile() {
@@ -77,29 +82,30 @@
 
        ebegin "Creating a menu file (may take a while)"
        mkdir -p "${T}/home/.fluxbox" || die "mkdir home failed"
+       # Call fluxbox-generate_menu through bash since it lacks +x
+       # chmod 744 may be an equal fix
        MENUFILENAME="${S}/data/menu" MENUTITLE="Fluxbox ${PV}" \
                CHECKINIT="no. go away." HOME="${T}/home" \
-               "${S}/util/fluxbox-generate_menu" -is -ds \
+               bash "${S}/util/fluxbox-generate_menu" -is -ds \
                || die "menu generation failed"
        eend $?
 }
 
 src_install() {
-       dodir /usr/share/fluxbox
        emake DESTDIR="${D}" STRIP="" install
        dodoc README* AUTHORS TODO* ChangeLog NEWS
 
-       dodir /usr/share/xsessions
+       # Install the generated menu
+       insinto /usr/share/fluxbox
+       doins data/menu
+
        insinto /usr/share/xsessions
        doins "${FILESDIR}"/${PN}.desktop
 
        exeinto /etc/X11/Sessions
        newexe "${FILESDIR}"/${PN}.xsession fluxbox
 
-       dodir /usr/share/fluxbox/menu.d
-
        # Styles menu framework
-       dodir /usr/share/fluxbox/menu.d/styles
        insinto /usr/share/fluxbox/menu.d/styles
        doins "${FILESDIR}"/styles-menu-fluxbox
        doins "${FILESDIR}"/styles-menu-commonbox



1.2                  x11-wm/fluxbox/fluxbox-1.3.5-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.5-r1.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.5-r1.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.5-r1.ebuild?r1=1.1&r2=1.2

Index: fluxbox-1.3.5-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.5-r1.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- fluxbox-1.3.5-r1.ebuild     26 Jan 2015 02:37:31 -0000      1.1
+++ fluxbox-1.3.5-r1.ebuild     26 Jan 2015 12:31:03 -0000      1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.5-r1.ebuild,v 
1.1 2015/01/26 02:37:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-1.3.5-r1.ebuild,v 
1.2 2015/01/26 12:31:03 idella4 Exp $
 
 EAPI=5
 inherit eutils flag-o-matic toolchain-funcs prefix
@@ -69,7 +69,7 @@
                $(use_enable imlib imlib2) \
                $(use_enable nls) \
                $(use_enable slit ) \
-               $(use_enable toolbar ) \
+               $(use_enable toolbar systray ) \
                $(use_enable truetype xft) \
                $(use_enable xinerama) \
                --sysconfdir="${EPREFIX}"/etc/X11/${PN} \



1.324                x11-wm/fluxbox/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/ChangeLog?rev=1.324&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/ChangeLog?rev=1.324&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/x11-wm/fluxbox/ChangeLog?r1=1.323&r2=1.324

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v
retrieving revision 1.323
retrieving revision 1.324
diff -u -r1.323 -r1.324
--- ChangeLog   26 Jan 2015 10:18:03 -0000      1.323
+++ ChangeLog   26 Jan 2015 12:31:03 -0000      1.324
@@ -1,6 +1,13 @@
 # ChangeLog for x11-wm/fluxbox
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.323 2015/01/26 
10:18:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.324 2015/01/26 
12:31:03 idella4 Exp $
+
+  26 Jan 2015; Ian Delaney <idel...@gentoo.org> -fluxbox-1.3.6.ebuild,
+  files/1.3.5-generate_menu-printf-fix.patch, fluxbox-1.3.5-r1.ebuild,
+  fluxbox-9999.ebuild:
+  update patch with final form from upstream, add missed addition from bug
+  537356 to -1.3.5-r1, full update to live ebuild from patch from same bug,
+  remove broken 1.3.6 ebuild, fixes Bugs 537356, 536370 by maintainers
 
   26 Jan 2015; Agostino Sarubbo <a...@gentoo.org> fluxbox-1.3.5.ebuild:
   Stable for x86, wrt bug #536086




Reply via email to