On 02:48 Thu 14 Feb     , William Thomson (wltjr) wrote:
> 1.1                  dev-db/hsqldb/hsqldb-1.8.0.9-r1.ebuild
> 
> file : 
> http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.0.9-r1.ebuild?rev=1.1&view=markup
> plain: 
> http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.0.9-r1.ebuild?rev=1.1&content-type=text/plain

> pkg_postinst() {
>       ewarn "If you intend to run Hsqldb in Server mode and you want to 
> create"
>       ewarn "additional databases, remember to put correct information in 
> both"
>       ewarn "'server.properties' and 'sqltool.rc' files."
>       ewarn "(read the 'Init script Setup Procedure' section of the 'Chapter 
> 3."
>       ewarn "UNIX Quick Start' in the Hsqldb docs for more information)"
>       echo
>       einfo "Example:"
>       echo
>       einfo "/etc/hsqldb/server.properties"
>       einfo "============================="
>       einfo "server.database.1=file:xdb/xdb"
>       einfo "server.dbname.1=xdb"
>       einfo "server.urlid.1=xdb"
>       einfo
>       einfo "/etc/hsqldb/sqltool.rc"
>       einfo "======================"
>       einfo "urlid xdb"
>       einfo "url jdbc:hsqldb:hsql://localhost/xdb"
>       einfo "username sa"
>       einfo "password "
>       echo
>       einfo "Also note that each hsqldb server can serve only up to 10"
>       einfo "different databases simultaneously (with consecutive {0-9}"
>       einfo "suffixes in the 'server.properties' file)."
>       echo
>       ewarn "For data manipulation use:"
>       ewarn
>       ewarn "# java -classpath ${HSQLDB_JAR} org.hsqldb.util.DatabaseManager"
>       ewarn "# java -classpath ${HSQLDB_JAR} 
> org.hsqldb.util.DatabaseManagerSwing"
>       ewarn "# java -classpath ${HSQLDB_JAR} org.hsqldb.util.SqlTool \\"
>       ewarn "  --rcFile /var/lib/hsqldb/sqltool.rc <dbname>"
>       echo
>       einfo "The Hsqldb can be run in multiple modes - read 'Chapter 1. 
> Running'"
>       einfo "and Using Hsqldb' in the Hsqldb docs at:"
>       einfo "  http://hsqldb.org/web/hsqlDocsFrame.html";
>       einfo "If you intend to run it in the Server mode, it is suggested to 
> add the"
>       einfo "init script to your start-up scripts, this should be done like 
> this:"
>       einfo "  \`rc-update add hsqldb default\`"
>       echo
> 
>       # Enable CONFIG_PROTECT for hsqldb
>       env-update
>       einfo "Hsqldb stores its database files in ${HSQLDB_HOME} and this 
> directory"
>       einfo "is added to the CONFIG_PROTECT list. In order to immediately 
> activate"
>       einfo "these settings please do:"
>       einfo "  \`env-update && source /etc/profile\`"
>       einfo "Otherwise the settings will become active next time you login"
>       echo
> }

All that einfo stuff should use elog instead.

Thanks,
Donnie
-- 
gentoo-dev@lists.gentoo.org mailing list

Reply via email to