hi,

i'm tring to make  iperf ebuild 
http://dast.nlanr.net/Projects/Iperf/iperfdocs_1.7.0.html
but i'm getting errors... below is the .ebuild and the error i'm getting.

-------------------ebuild-------------------------------

DESCRIPTION="measure maximum TCP bandwidth, delay jitter, datagram loss"
HOMEPAGE="http://dast.nlanr.net/Projects/Iperf/";
SRC_URI="http://dast.nlanr.net/Projects/Iperf/${P}-source.tar.gz";
KEYWORDS="${WORKDIR}/${P}"
S=${WORKDIR}/${P}
src_compile() {
        emake || die
}
src_install() {
        make DESTDIR=${D} install || die
}


-------------------error-------------------------------
# ebuild /arh/myportage/net-analyzer/iperf/iperf-1.7.0-r1.ebuild  compile
>>> md5 src_uri ;-) iperf-1.7.0-source.tar.gz
>>> Checking iperf-1.7.0-source.tar.gz's mtime...
>>> /arh/myportage/net-analyzer/iperf/iperf-1.7.0-r1.ebuild has been updated; 
>>> recreating WORKDIR...
>>> Unpacking source...
>>> Unpacking iperf-1.7.0-source.tar.gz to /var/tmp/portage/iperf-1.7.0-r1/work
>>> Source unpacked.
make config
rm -f cfg/config.h
make[1]: Entering directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
make config
make[1]: Entering directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
 
 
make[2]: Entering directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0/cfg'
./configure
make[2]: Entering directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0/cfg'
./configure
checking for gcc... gcc
checking for gcc... gcc
checking for C compiler default output... checking for C compiler default output... 
a.out
checking whether the C compiler works... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for executable suffix... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
make[2]: *** [all] Error 1
make[2]: Leaving directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0/cfg'
make[1]: *** [config] Error 2
make[1]: Leaving directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0'
make: *** [cfg/config.h] Error 2
make: *** Waiting for unfinished jobs....
 
checking for object suffix... configure: error: cannot compute OBJEXT: cannot compile
sed: can't read confdefs.h: No such file or directory
make[2]: *** [all] Error 1
make[2]: Leaving directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0/cfg'
make[1]: *** [config] Error 2
make[1]: Leaving directory `/var/tmp/portage/iperf-1.7.0-r1/work/iperf-1.7.0'
make: *** [Makefile.rules] Error 2
 
!!! ERROR: net-analyzer/iperf-1.7.0-r1 failed.
!!! Function src_compile, Line 8, Exitcode 2
!!! (no error message)

--
[EMAIL PROTECTED] mailing list

Reply via email to