Re: [RFC] Case insensitive Git attributes

2016-10-16 Thread Torsten Bögershausen
On 17/10/16 05:07, Stefan Beller wrote: On Sun, Oct 16, 2016 at 6:04 PM, Lars Schneider wrote: Hi, Git attributes for path names are generally case sensitive. However, on a case insensitive file system (e.g. macOS/Windows) they appear to be case insensitive

Re: [RFC] Case insensitive Git attributes

2016-10-16 Thread Stefan Beller
On Sun, Oct 16, 2016 at 6:04 PM, Lars Schneider wrote: > Hi, > > Git attributes for path names are generally case sensitive. However, on > a case insensitive file system (e.g. macOS/Windows) they appear to be > case insensitive (`*.bar` would match `foo.bar` and

Re: [PATCH] convert: mark a file-local symbol static

2016-10-16 Thread Jeff King
On Mon, Oct 17, 2016 at 02:37:58AM +0100, Ramsay Jones wrote: > Hmm, well, you have to remember that 'make clean' sometimes > doesn't make clean. Ever since the Makefile was changed to only > remove $(OBJECTS), rather than *.o xdiff/*.o etc., you have to > remember to 'make clean' _before_ you

Re: [PATCH] convert: mark a file-local symbol static

2016-10-16 Thread Ramsay Jones
On 16/10/16 01:15, Lars Schneider wrote: >> On 15 Oct 2016, at 14:01, Ramsay Jones wrote: >> On 15/10/16 16:05, Lars Schneider wrote: On 11 Oct 2016, at 16:46, Ramsay Jones wrote: >> [snip] -void stop_multi_file_filter(struct

[RFC] Case insensitive Git attributes

2016-10-16 Thread Lars Schneider
Hi, Git attributes for path names are generally case sensitive. However, on a case insensitive file system (e.g. macOS/Windows) they appear to be case insensitive (`*.bar` would match `foo.bar` and `foo.BAR`). That works great until a Git users joins the party with a case sensitive file

[PATCH v1 2/2] travis-ci: disable GIT_TEST_HTTPD for macOS

2016-10-16 Thread larsxschneider
From: Lars Schneider TravisCI changed their default macOS image from 10.10 to 10.11 [1]. Unfortunately the HTTPD tests do not run out of the box using the pre-installed Apache web server anymore. Therefore we enable these tests only for Linux and disable them for macOS.

[PATCH v1 0/2] Fix default macOS build locally and on Travis CI

2016-10-16 Thread larsxschneider
From: Lars Schneider Apple removed the OpenSSL header files in macOS and therefore Git does not build out of the box on macOS anymore. See previous discussion with Torsten here: http://public-inbox.org/git/565b3036.8000...@web.de/ This mini series makes Git build out

[PATCH v1 1/2] config.mak.in: set NO_OPENSSL and APPLE_COMMON_CRYPTO for macOS >10.11

2016-10-16 Thread larsxschneider
From: Lars Schneider Apple removed the OpenSSL header files in macOS 10.11 and above. OpenSSL was deprecated since macOS 10.7. Set `NO_OPENSSL` and `APPLE_COMMON_CRYPTO` to `YesPlease` as default for macOS. Make it possible to override this and use OpenSSL by defining

Re: [PATCH v10 13/14] convert: add filter..process option

2016-10-16 Thread Lars Schneider
> On 11 Oct 2016, at 03:09, Torsten Bögershausen wrote: > > On Tue, Oct 11, 2016 at 10:11:22AM +0200, Lars Schneider wrote: >> >>> On 10 Oct 2016, at 21:58, Junio C Hamano wrote: >>> >>> larsxschnei...@gmail.com writes: >>> >>> [...] >>

[PATCH v11 12/14] convert: prepare filter..process option

2016-10-16 Thread larsxschneider
From: Lars Schneider Refactor the existing 'single shot filter mechanism' and prepare the new 'long running filter mechanism'. Signed-off-by: Lars Schneider --- convert.c | 60 ++-- 1

[PATCH v11 14/14] contrib/long-running-filter: add long running filter example

2016-10-16 Thread larsxschneider
From: Lars Schneider Add a simple pass-thru filter as example implementation for the Git filter protocol version 2. See Documentation/gitattributes.txt, section "Filter Protocol" for more info. Signed-off-by: Lars Schneider ---

[PATCH v11 11/14] convert: make apply_filter() adhere to standard Git error handling

2016-10-16 Thread larsxschneider
From: Lars Schneider apply_filter() returns a boolean that tells the caller if it "did convert or did not convert". The variable `ret` was used throughout the function to track errors whereas `1` denoted success and `0` failure. This is unusual for the Git source where

[PATCH v11 10/14] pkt-line: add functions to read/write flush terminated packet streams

2016-10-16 Thread larsxschneider
From: Lars Schneider write_packetized_from_fd() and write_packetized_from_buf() write a stream of packets. All content packets use the maximal packet size except for the last one. After the last content packet a `flush` control packet is written.

[PATCH v11 13/14] convert: add filter..process option

2016-10-16 Thread larsxschneider
From: Lars Schneider Git's clean/smudge mechanism invokes an external filter process for every single blob that is affected by a filter. If Git filters a lot of blobs then the startup time of the external filter processes can become a significant part of the overall Git

[PATCH v11 06/14] pkt-line: extract set_packet_header()

2016-10-16 Thread larsxschneider
From: Lars Schneider Extracted set_packet_header() function converts an integer to a 4 byte hex string. Make this function locally available so that other pkt-line functions could use it. Signed-off-by: Lars Schneider Signed-off-by: Junio C

[PATCH v11 07/14] pkt-line: add packet_write_fmt_gently()

2016-10-16 Thread larsxschneider
From: Lars Schneider packet_write_fmt() would die in case of a write error even though for some callers an error would be acceptable. Add packet_write_fmt_gently() which writes a formatted pkt-line like packet_write_fmt() but does not die in case of an error. The

[PATCH v11 09/14] pkt-line: add packet_write_gently()

2016-10-16 Thread larsxschneider
From: Lars Schneider packet_write_fmt_gently() uses format_packet() which lets the caller only send string data via "%s". That means it cannot be used for arbitrary data that may contain NULs. Add packet_write_gently() which writes arbitrary data and does not die in

[PATCH v11 08/14] pkt-line: add packet_flush_gently()

2016-10-16 Thread larsxschneider
From: Lars Schneider packet_flush() would die in case of a write error even though for some callers an error would be acceptable. Add packet_flush_gently() which writes a pkt-line flush packet like packet_flush() but does not die in case of an error. The function is

[PATCH v11 03/14] run-command: move check_pipe() from write_or_die to run_command

2016-10-16 Thread larsxschneider
From: Lars Schneider Move check_pipe() to run_command and make it public. This is necessary to call the function from pkt-line in a subsequent patch. While at it, make async_exit() static to run_command.c as it is no longer used from outside. Signed-off-by: Lars

[PATCH v11 05/14] pkt-line: rename packet_write() to packet_write_fmt()

2016-10-16 Thread larsxschneider
From: Lars Schneider packet_write() should be called packet_write_fmt() because it is a printf-like function that takes a format string as first parameter. packet_write_fmt() should be used for text strings only. Arbitrary binary data should use a new packet_write()

[PATCH v11 04/14] run-command: add clean_on_exit_handler

2016-10-16 Thread larsxschneider
From: Lars Schneider Some processes might want to perform cleanup tasks before Git kills them due to the 'clean_on_exit' flag. Let's give them an interface for doing this. The feature is used in a subsequent patch. Please note, that the cleanup callback is not executed

[PATCH v11 01/14] convert: quote filter names in error messages

2016-10-16 Thread larsxschneider
From: Lars Schneider Git filter driver commands with spaces (e.g. `filter.sh foo`) are hard to read in error messages. Quote them to improve the readability. Signed-off-by: Lars Schneider Signed-off-by: Junio C Hamano ---

[PATCH v11 02/14] convert: modernize tests

2016-10-16 Thread larsxschneider
From: Lars Schneider Use `test_config` to set the config, check that files are empty with `test_must_be_empty`, compare files with `test_cmp`, and remove spaces after ">" and "<". Please note that the "rot13" filter configured in "setup" keeps using `git config`

[PATCH v11 00/14] Git filter protocol

2016-10-16 Thread larsxschneider
From: Lars Schneider The goal of this series is to avoid launching a new clean/smudge filter process for each file that is filtered. A short summary about v1 to v5 can be found here: https://git.github.io/rev_news/2016/08/17/edition-18/ This series is also published

Re: [PATCH v10 04/14] run-command: add clean_on_exit_handler

2016-10-16 Thread Lars Schneider
> On 16 Oct 2016, at 01:03, Johannes Schindelin > wrote: > > Hi Lars, > > On Sat, 15 Oct 2016, Lars Schneider wrote: > >> >>> On 11 Oct 2016, at 05:12, Johannes Schindelin >>> wrote: >>> >>> On Windows, pid_t translates to long long

Re: link broken on git man page

2016-10-16 Thread Jeff King
On Sun, Oct 16, 2016 at 01:42:12PM -0700, Howard Johnson wrote: > This link below is broken in the man page. (I'm on Debian Jessie). > [...] >Formatted and hyperlinked version of the latest Git documentation can >be viewed at http://git-htmldocs.googlecode.com/git/git.html. This

Re: link broken on git man page

2016-10-16 Thread Pranit Bauva
Hey Howard, On Mon, Oct 17, 2016 at 2:12 AM, Howard Johnson wrote: > This link below is broken in the man page. (I'm on Debian Jessie). > > > GIT(1)Git Manual > GIT(1) > > NAME >git - the stupid content tracker > > SYNOPSIS >

link broken on git man page

2016-10-16 Thread Howard Johnson
This link below is broken in the man page. (I'm on Debian Jessie). GIT(1)Git Manual GIT(1) NAME git - the stupid content tracker SYNOPSIS git [--version] [--help] [-C ] [-c =] [--exec-path[=]] [--html-path]

Draft of Git Rev News edition 20

2016-10-16 Thread Christian Couder
Hi, A draft of a new Git Rev News edition is available here: https://github.com/git/git.github.io/blob/master/rev_news/drafts/edition-20.md Everyone is welcome to contribute in any section either by editing the above page on GitHub and sending a pull request, or by commenting on this GitHub

Re: [PATCH] avoid pointer arithmetic involving NULL in FLEX_ALLOC_MEM

2016-10-16 Thread Jeff King
On Sun, Oct 16, 2016 at 12:06:02PM +0200, René Scharfe wrote: > > Yeah, this NULL computation is pretty nasty. I recall trying to get rid > > of it, but I think it is impossible to do so portably while still using > > the generic xalloc_flex() helper. > > The only way I see is to pass the type

About your late relative

2016-10-16 Thread David Fenton
Hi, There is an Estate belonging to someone who is related to you going by the lineage. I received your file from Mr. Maurice Moreau a genealogical surveys. i would like us us to discuss about it David

Re: [PATCH v3 07/25] sequencer: completely revamp the "todo" script parsing

2016-10-16 Thread Jeff King
On Sun, Oct 16, 2016 at 10:09:12AM +0200, Johannes Schindelin wrote: > > Good catch. It technically needs to check the lower bound, too. In > > theory, if somebody wanted to add an enum value that is negative, you'd > > use a signed cast and check against both 0 and ARRAY_SIZE(). In > > practice,

[GIT PULL] l10n updates for 2.10.0 maint branch

2016-10-16 Thread Jiang Xin
Hi Junio, Please pull the following l10n updates for Git 2.10 to the maint branch. The following changes since commit 9a4b694c539fead26833c2104c1a93d3a2b4c50a: l10n: zh_CN: review for git v2.10.0 l10n (2016-09-11 21:34:23 +0800) are available in the git repository at:

Re: [PATCH] avoid pointer arithmetic involving NULL in FLEX_ALLOC_MEM

2016-10-16 Thread René Scharfe
Am 15.10.2016 um 19:13 schrieb Jeff King: > On Sat, Oct 15, 2016 at 06:23:11PM +0200, René Scharfe wrote: > >> Calculating offsets involving a NULL pointer is undefined. It works in >> practice (for now?), but we should not rely on it. Allocate first and >> then simply refer to the flexible

Re: What's cooking in git.git (Oct 2016, #03; Tue, 11)

2016-10-16 Thread Johannes Schindelin
Hi Junio, On Fri, 14 Oct 2016, Junio C Hamano wrote: > Johannes Schindelin writes: > > >> >> * sb/submodule-ignore-trailing-slash (2016-10-10) 2 commits > >> >> (merged to 'next' on 2016-10-11 at e37425ed17) > >> >> + submodule: ignore trailing slash in relative

Re: [PATCH v3 07/25] sequencer: completely revamp the "todo" script parsing

2016-10-16 Thread Johannes Schindelin
Hi, On Sat, 15 Oct 2016, Jeff King wrote: > On Sat, Oct 15, 2016 at 07:40:15PM +0200, Torsten Bögershausen wrote: > > > > I wonder if: > > > > > > if ((int)command < ARRAY_SIZE(todo_command_strings)) > > > > > > silences the warning (I suppose size_t is probably an even better type, > > >

Re: [PATCH v10 04/14] run-command: add clean_on_exit_handler

2016-10-16 Thread Johannes Schindelin
Hi Lars, On Sat, 15 Oct 2016, Lars Schneider wrote: > > > On 11 Oct 2016, at 05:12, Johannes Schindelin > > wrote: > > > > Hi Lars, > > > > On Sat, 8 Oct 2016, larsxschnei...@gmail.com wrote: > > > >> @@ -31,6 +32,15 @@ static void cleanup_children(int sig, int