Re: Test failures when Git is built with libpcre and grep is built without it

2017-01-01 Thread Jeff King
On Sat, Dec 31, 2016 at 10:59:11PM -0600, A. Wilcox wrote: > I'm attempting to package Git for our new Linux distribution and I > have run in to a failure on our PowerPC builder while running the test > suite. > > The PowerPC builder runs a tiny version of grep(1) that was not built > with PCRE.

Re: [PATCH] contrib: remove gitview

2017-01-01 Thread Aneesh Kumar K.V
Jeff King writes: > On Wed, Dec 28, 2016 at 09:28:37AM -0800, Stefan Beller wrote: > >> gitview did not have meaningful contributions since 2007, which gives the >> impression it is either a mature or dead project. >> >> In both cases we should not carry it in git.git as the

Re: Rebasing multiple branches at once

2017-01-01 Thread Jeff King
On Sat, Dec 31, 2016 at 06:40:33PM -0800, Junio C Hamano wrote: > What people seem to do is to teach the branch that ends with F that > its upstream is the local branch that ends with E, so that they can > be lazy when rebasing a branch that knows its upstream. I suspect > that you would end up

Re: [PATCH v3 00/23] Delete directories left empty after ref deletion

2017-01-01 Thread Jeff King
On Sun, Jan 01, 2017 at 12:36:11PM -0800, Jacob Keller wrote: > But how likely is it to end up with differing binaries running on the > exact same repository concurrently? Basically, I am trying to see > whether or not we could accidentally end up causing problems by trying > to race with other

Re: [PATCH v3 00/23] Delete directories left empty after ref deletion

2017-01-01 Thread Jacob Keller
On Sun, Jan 1, 2017 at 4:43 AM, Philip Oakley wrote: > From: "Jacob Keller" >> I do have one comment regarding this series. Is it ever possible for >> an older version of git to be running a process while a new version of >> git which cleans up dirs

Re: [PATCH] Gitk Inotify support

2017-01-01 Thread Florian Schüller
Just automatically update gitk when working in a terminal on the same repo The commit is also on github if that makes things easier https://github.com/schuellerf/gitk.git (inotify branch) https://github.com/schuellerf/gitk/tree/inotify Features: * Detects inotify support if inotify is not

[PATCH 04/17] builtin/fast-export: convert to struct object_id

2017-01-01 Thread brian m. carlson
In addition to converting to struct object_id, write some hardcoded buffer sizes in terms of GIT_SHA1_RAWSZ. Signed-off-by: brian m. carlson --- builtin/fast-export.c | 58 +-- 1 file changed, 29 insertions(+), 29

[PATCH 05/17] builtin/fmt-merge-message: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert most of the code to use struct object_id, including struct origin_data and struct merge_parents. Convert several instances of hardcoded numbers into references to GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson --- builtin/fmt-merge-msg.c | 70

[PATCH 01/17] builtin/commit: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert most leaf functions to use struct object_id. Signed-off-by: brian m. carlson --- builtin/commit.c | 46 +++--- 1 file changed, 23 insertions(+), 23 deletions(-) diff --git a/builtin/commit.c b/builtin/commit.c index

[PATCH 17/17] wt-status: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert the remaining uses of unsigned char [20] to struct object_id. Signed-off-by: brian m. carlson --- wt-status.c | 44 ++-- 1 file changed, 22 insertions(+), 22 deletions(-) diff --git a/wt-status.c b/wt-status.c index

[PATCH 06/17] builtin/grep: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert several functions to use struct object_id, and rename them so that they no longer refer to SHA-1. Signed-off-by: brian m. carlson --- builtin/grep.c | 24 1 file changed, 12 insertions(+), 12 deletions(-) diff --git

[PATCH 02/17] builtin/diff-tree: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert most leaf functions to struct object_id. Rewrite several hardcoded numbers in terms of GIT_SHA1_HEXSZ, using an intermediate variable where that makes sense. Signed-off-by: brian m. carlson --- builtin/diff-tree.c | 38

[PATCH 08/17] builtin/clone: convert to struct object_id

2017-01-01 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/clone.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/builtin/clone.c b/builtin/clone.c index 5ef81927a..e0916e5f3 100644 --- a/builtin/clone.c +++ b/builtin/clone.c @@ -681,7 +681,7 @@

[PATCH 12/17] reflog-walk: convert struct reflog_info to struct object_id

2017-01-01 Thread brian m. carlson
Convert struct reflog_info to use struct object_id by changing the structure definition and applying the following semantic patch: @@ struct reflog_info E1; @@ - E1.osha1 + E1.ooid.hash @@ struct reflog_info *E1; @@ - E1->osha1 + E1->ooid.hash @@ struct reflog_info E1; @@ - E1.nsha1 +

[PATCH 15/17] Convert object iteration callbacks to struct object_id

2017-01-01 Thread brian m. carlson
Convert each_loose_object_fn and each_packed_object_fn to take a pointer to struct object_id. Update the various callbacks. Convert several 40-based constants to use GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson --- builtin/cat-file.c | 8

[PATCH 14/17] sha1_file: introduce an nth_packed_object_oid function

2017-01-01 Thread brian m. carlson
There are places in the code where we would like to provide a struct object_id *, yet read the hash directly from the pack. Provide an nth_packed_object_oid function that mirrors the nth_packed_object_sha1 function. The required cast is questionable, but should be safe on all known platforms.

[PATCH 16/17] builtin/merge-base: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert the remaining uses of unsigned char [20] to struct object_id. Signed-off-by: brian m. carlson --- builtin/merge-base.c | 28 ++-- 1 file changed, 14 insertions(+), 14 deletions(-) diff --git a/builtin/merge-base.c

[PATCH 10/17] Convert remaining callers of resolve_refdup to object_id

2017-01-01 Thread brian m. carlson
There are a few leaf functions in various files that call resolve_refdup. Convert these functions to use struct object_id internally to prepare for transitioning resolve_refdup itself. Signed-off-by: brian m. carlson --- builtin/notes.c| 18

[PATCH 11/17] builtin/replace: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert various uses of unsigned char [20] to struct object_id. Rename replace_object_sha1 to rename_object_oid. Finally, specify a constant in terms of GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson --- builtin/replace.c | 112

[PATCH 13/17] refs: convert each_reflog_ent_fn to struct object_id

2017-01-01 Thread brian m. carlson
Make each_reflog_ent_fn take two struct object_id pointers instead of two pointers to unsigned char. Convert the various callbacks to use struct object_id as well. Also, rename fsck_handle_reflog_sha1 to fsck_handle_reflog_oid. Signed-off-by: brian m. carlson ---

[PATCH 07/17] builtin/branch: convert to struct object_id

2017-01-01 Thread brian m. carlson
Signed-off-by: brian m. carlson --- builtin/branch.c | 26 +- 1 file changed, 13 insertions(+), 13 deletions(-) diff --git a/builtin/branch.c b/builtin/branch.c index 9d30f55b0..faf472ff8 100644 --- a/builtin/branch.c +++ b/builtin/branch.c

[PATCH 09/17] builtin/merge: convert to struct object_id

2017-01-01 Thread brian m. carlson
Additionally convert several uses of the constant 40 into GIT_SHA1_HEXSZ. Signed-off-by: brian m. carlson --- builtin/merge.c | 136 1 file changed, 68 insertions(+), 68 deletions(-) diff --git

[PATCH 03/17] builtin/describe: convert to struct object_id

2017-01-01 Thread brian m. carlson
Convert the functions in this file and struct commit_name to struct object_id. Signed-off-by: brian m. carlson --- builtin/describe.c | 50 +- 1 file changed, 25 insertions(+), 25 deletions(-) diff --git

[PATCH 00/17] object_id part 6

2017-01-01 Thread brian m. carlson
This is another series in the continuing conversion to struct object_id. This series converts more of the builtin directory and some of the refs code to use struct object_id. Additionally, it implements an nth_packed_object_oid function which provides a struct object_id version of the

Re: [PATCH v15 15/27] bisect--helper: `bisect_next` and `bisect_auto_next` shell function in C

2017-01-01 Thread Pranit Bauva
Hey Stephan, On Sun, Jan 1, 2017 at 9:57 PM, Stephan Beyer wrote: int cmd_bisect__helper(int argc, const char **argv, const char *prefix) @@ -643,6 +794,10 @@ int cmd_bisect__helper(int argc, const char **argv, const char *prefix)

[PATCH] read-cache: mark a file-local symbol with static

2017-01-01 Thread Ramsay Jones
Signed-off-by: Ramsay Jones --- Hi Christian, If you need to re-roll your 'cc/split-index-config' branch, could you please squash this into the relevant patch (commit 8a7e3ef9a6, "read-cache: touch shared index files when used", 26-12-2016). Thanks! ATB, Ramsay

Re: [PATCH v15 15/27] bisect--helper: `bisect_next` and `bisect_auto_next` shell function in C

2017-01-01 Thread Stephan Beyer
Hi Pranit, On 12/31/2016 11:43 AM, Pranit Bauva wrote: >>> + >>> +static int bisect_auto_next(struct bisect_terms *terms, const char *prefix) >>> +{ >>> + if (!bisect_next_check(terms, NULL)) >>> + return bisect_next(terms, prefix); >>> + >>> + return 0; >>> +} >> >> Hmm, the

Re: [PATCH] don't use test_must_fail with grep

2017-01-01 Thread Luke Diamand
On 1 January 2017 at 14:50, Johannes Sixt wrote: > Am 01.01.2017 um 15:23 schrieb Luke Diamand: >> >> On 31 December 2016 at 11:44, Pranit Bauva wrote: >>> >>> diff --git a/t/t9813-git-p4-preserve-users.sh >>> b/t/t9813-git-p4-preserve-users.sh >>> index

Re: [PATCH] don't use test_must_fail with grep

2017-01-01 Thread Johannes Sixt
Am 01.01.2017 um 15:23 schrieb Luke Diamand: On 31 December 2016 at 11:44, Pranit Bauva wrote: diff --git a/t/t9813-git-p4-preserve-users.sh b/t/t9813-git-p4-preserve-users.sh index 0fe231280..2384535a7 100755 --- a/t/t9813-git-p4-preserve-users.sh +++

Re: [PATCH] don't use test_must_fail with grep

2017-01-01 Thread Luke Diamand
On 31 December 2016 at 11:44, Pranit Bauva wrote: > test_must_fail should only be used for testing git commands. To test the > failure of other commands use `!`. > > Reported-by: Stefan Beller > Signed-off-by: Pranit Bauva >

Re: [PATCH v3 00/23] Delete directories left empty after ref deletion

2017-01-01 Thread Philip Oakley
From: "Jacob Keller" Sent: Sunday, January 01, 2017 9:24 AM On Sat, Dec 31, 2016 at 6:32 PM, Junio C Hamano wrote: Jeff King writes: On Sat, Dec 31, 2016 at 04:12:40AM +0100, Michael Haggerty wrote: This is a re-roll of an old

Re: [PATCH v3 13/23] log_ref_setup(): pass the open file descriptor back to the caller

2017-01-01 Thread Junio C Hamano
Jeff King writes: > On Sat, Dec 31, 2016 at 08:58:43AM +0100, Michael Haggerty wrote: > >> > The return value is always "0" or "-1". It seems like it would be >> > simpler to just return the descriptor instead of 0. >> > >> > I guess that makes it hard to identify the case when

Re: Test failures when Git is built with libpcre and grep is built without it

2017-01-01 Thread Torsten Bögershausen
On 01.01.17 05:59, A. Wilcox wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA256 > > Hello! > > I'm attempting to package Git for our new Linux distribution and I > have run in to a failure on our PowerPC builder while running the test > suite. > > The PowerPC builder runs a tiny version

Re: [PATCH v3 00/23] Delete directories left empty after ref deletion

2017-01-01 Thread Jacob Keller
On Sun, Jan 1, 2017 at 1:24 AM, Jacob Keller wrote: > On Sat, Dec 31, 2016 at 6:32 PM, Junio C Hamano wrote: >> Jeff King writes: >> >>> On Sat, Dec 31, 2016 at 04:12:40AM +0100, Michael Haggerty wrote: >>> This is a re-roll of an

Re: [PATCH v3 00/23] Delete directories left empty after ref deletion

2017-01-01 Thread Jacob Keller
On Sat, Dec 31, 2016 at 6:32 PM, Junio C Hamano wrote: > Jeff King writes: > >> On Sat, Dec 31, 2016 at 04:12:40AM +0100, Michael Haggerty wrote: >> >>> This is a re-roll of an old patch series. v1 [1] got some feedback, >>> which I think was all addressed in v2

Re: [PATCH v3 11/23] log_ref_setup(): separate code for create vs non-create

2017-01-01 Thread Michael Haggerty
On 01/01/2017 04:28 AM, Junio C Hamano wrote: > Michael Haggerty writes: > >> +if (errno == ENOENT || errno == EISDIR) { >> +/* >> + * The logfile doesn't already exist, >> +

Re: Rebasing multiple branches at once

2017-01-01 Thread Johannes Sixt
Am 31.12.2016 um 09:14 schrieb Mike Hommey: Hi, I've had this kind of things to do more than once, and had to do it a lot today, so I figured it would be worth discussing whether git-rebase should be enhanced to support this, or if this should go in a separate tool or whatever. So here is what

Re: [PATCH v3 10/23] log_ref_write(): inline function

2017-01-01 Thread Michael Haggerty
On 01/01/2017 03:09 AM, Junio C Hamano wrote: > Michael Haggerty writes: > >> This function doesn't do anything beyond call files_log_ref_write(), so > > s/call//; I think. Thanks; will fix. Michael