Re: [PATCH] t: add clone test for files differing only in case

2018-01-20 Thread Eric Sunshine
On Sun, Jan 21, 2018 at 2:33 AM, Junio C Hamano wrote: > "brian m. carlson" writes: >> +test_expect_success 'clone on case-insensitive fs' ' >> + o=$(git hash-object -w --stdin > + t=$(printf "100644 X\0${o}100644 x\0${o}" | >> + git hash-object -w -t tree --stdin) && >> +

Re: [PATCH] t: add clone test for files differing only in case

2018-01-20 Thread Junio C Hamano
"brian m. carlson" writes: > diff --git a/t/t5601-clone.sh b/t/t5601-clone.sh > index 0f895478f0..53b2dda9d2 100755 > --- a/t/t5601-clone.sh > +++ b/t/t5601-clone.sh > @@ -611,4 +611,17 @@ test_expect_success 'GIT_TRACE_PACKFILE produces a > usable pack' ' > git -C replay.git index-pack -v

Re: [PATCH v3] packed_ref_cache: don't use mmap() for small files

2018-01-20 Thread Michael Haggerty
On 01/17/2018 11:09 PM, Jeff King wrote: > On Tue, Jan 16, 2018 at 08:38:15PM +0100, Kim Gybels wrote: > >> Take a hint from commit ea68b0ce9f8 (hash-object: don't use mmap() for >> small files, 2010-02-21) and use read() instead of mmap() for small >> packed-refs files. >> >> This also fixes the

Re: [PATCH v3] mru: Replace mru.[ch] with list.h implementation

2018-01-20 Thread René Scharfe
Am 20.01.2018 um 23:24 schrieb Gargi Sharma: > On Sat, Jan 20, 2018 at 1:02 AM, Eric Wong wrote: >> Gargi Sharma wrote: >>> --- a/list.h >>> +++ b/list.h >>> @@ -93,6 +93,13 @@ static inline void list_move(struct list_head *elem, >>> struct list_head *head) >>>list_add(elem, head); >>>

RE: [PATCH v2 4/6] Force test suite traps to be cleared for NonStop ksh

2018-01-20 Thread Randall S. Becker
On January 19, 2018 5:29 PM, I wrote: > On January 19, 2018 4:27 PM, Jeff King wrote: > > On Fri, Jan 19, 2018 at 12:34:04PM -0500, randall.s.bec...@rogers.com > wrote: > > > > > From: "Randall S. Becker" > > > > > > * t/lib-git-daemon.sh: fix incompatibilities with ksh traps not being > > > cle

git merge-tree: bug report and some feature requests

2018-01-20 Thread Josh Bleecher Snyder
Hi, all. I'm experimenting with some new porcelain for interactive rebase. One goal is to leave the work tree untouched for most operations. It looks to me like 'git merge-tree' may be the right plumbing command for doing the merge part of the pick work of the todo list, one commit at a time. If I

Re: [PATCH] t: add clone test for files differing only in case

2018-01-20 Thread Eric Sunshine
On Sat, Jan 20, 2018 at 3:33 PM, brian m. carlson wrote: > We recently introduced a regression in cloning repositories onto > case-insensitive file systems where the repository contains multiple > files differing only in case. In such a case, we would segfault. This > segfault has already been f

[PATCH v2 10/12] fetch: stop accessing "remote" variable indirectly

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Access the "remote" variable passed to the fetch_one() directly rather than through the gtransport wrapper struct constructed in this function for other purposes. This makes the code more readable, as it's now obvious that the remote struct doesn't somehow get munged by the prepare_transport() fun

[PATCH v2 08/12] git-fetch & config doc: link to the new PRUNING section

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Amend the documentation for fetch.prune, fetch..prune and --prune to link to the recently added PRUNING section. I'd have liked to link directly to it with "<>" from fetch-options.txt, since it's included in git-fetch.txt (git-pull.txt also includes it, but doesn't include that option). However ma

[PATCH v2 12/12] fetch: add a --fetch-prune option and fetch.pruneTags config

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Add a --fetch-prune option to git-fetch, along with fetch.pruneTags config option. This allows for doing any of: git fetch -p -P git fetch --prune --prune-tags git fetch -p -P origin git fetch --prune --prune-tags origin Or simply: git config fetch.prune true && git confi

[PATCH v2 09/12] fetch: don't redundantly NULL something calloc() gave us

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Stop redundantly NULL-ing the last element of the refs structure, which was retrieved via calloc(), and is thus guaranteed to be pre-NULL'd. This code dates back to b888d61c83 ("Make fetch a builtin", 2007-09-10), where wasn't any reason to do this back then either, it's just something left over f

[PATCH v2 11/12] fetch tests: add scaffolding for the new fetch.pruneTags

2018-01-20 Thread Ævar Arnfjörð Bjarmason
The fetch.pruneTags configuration doesn't exist yet, but will be added in a subsequent commit. Since testing for it requires adding new parameters to the test_configured_prune function it's easier to review this patch first to assert that no functional changes are introduced yet. Signed-off-by: Æv

[PATCH v2 03/12] fetch tests: add a tag to be deleted to the pruning tests

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Add a tag to be deleted to the fetch --prune tests. The tag is always kept for now, which is the expected behavior, but now I can add a test for tag pruning in a later commit. Signed-off-by: Ævar Arnfjörð Bjarmason --- t/t5510-fetch.sh | 93 ---

[PATCH v2 04/12] fetch tests: double quote a variable for interpolation

2018-01-20 Thread Ævar Arnfjörð Bjarmason
If the $cmdline variable contains multiple arguments they won't be interpolated correctly since the body of the test is single quoted. I don't know what part of test-lib.sh is expanding variables within single-quoted strings, but interpolating this inline is the desired behavior here. This will be

[PATCH v2 05/12] fetch tests: test --prune and refspec interaction

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Add a test for the interaction between explicitly provided refspecs and fetch.prune. There's no point in adding this boilerplate to every combination of unset/false/true, it's instructive and sufficient to show that no matter if the variable is unset, false or true the refspec on the command-line

[PATCH v2 06/12] git fetch doc: add a new section to explain the ins & outs of pruning

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Add a new section to canonically explain how remote reference pruning works, and how users should be careful about using it in conjunction with tag refspecs in particular. A subsequent commit will update the git-remote documentation to refer to this section, and details the motivation for writing

[PATCH v2 00/12] document & test fetch pruning & add fetch.pruneTags

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Now v2 and fully non-RFC, changes: Ævar Arnfjörð Bjarmason (12): fetch tests: refactor in preparation for testing tag pruning fetch tests: arrange arguments for future readability fetch tests: add a tag to be deleted to the pruning tests fetch tests: double quote a variable for interpolati

[PATCH v2 02/12] fetch tests: arrange arguments for future readability

2018-01-20 Thread Ævar Arnfjörð Bjarmason
Re-arrange the arguments to the test_configured_prune() function used in this test to pass the arguments to --fetch last. A subsequent change will test for more elaborate fetch arguments, including long refspecs. It'll be more readable to be able to wrap those on a new line of their own. Signed-of

[PATCH v2 07/12] git remote doc: correct dangerous lies about what prune does

2018-01-20 Thread Ævar Arnfjörð Bjarmason
The "git remote prune " command uses the same machinery as "git fetch --prune", and shares all the same caveats, but its documentation has suggested that it'll just "delete stale remote-tracking branches under ". This isn't true, and hasn't been true since at least v1.8.5.6 (the oldest version I

[PATCH v2 01/12] fetch tests: refactor in preparation for testing tag pruning

2018-01-20 Thread Ævar Arnfjörð Bjarmason
In a subsequent commit this function will learn to test for tag pruning, prepare for that by making space for more variables, and making it clear that "expected" here refers to branches. Signed-off-by: Ævar Arnfjörð Bjarmason --- t/t5510-fetch.sh | 9 ++--- 1 file changed, 6 insertions(+), 3

[PATCH v4] mru: Replace mru.[ch] with list.h implementation

2018-01-20 Thread Gargi Sharma
Replace the custom calls to mru.[ch] with calls to list.h. This patch is the final step in removing the mru API completely and inlining the logic. This patch leads to significant code reduction and the mru API hence, is not a useful abstraction anymore. Signed-off-by: Gargi Sharma --- Changes in

Re: [PATCH] enable core.fsyncObjectFiles by default

2018-01-20 Thread Junio C Hamano
Theodore Ts'o writes: > I've never been fond of the "git repack -A" behavior > where it can generate huge numbers of loose files. I'd much prefer it > if the other objects ended up in a separate pack file, and then some > other provision made for nuking that pack file some time later

Re: [PATCH v3] mru: Replace mru.[ch] with list.h implementation

2018-01-20 Thread Gargi Sharma
On Sat, Jan 20, 2018 at 12:59 AM, Eric Sunshine wrote: > On Fri, Jan 19, 2018 at 6:36 PM, Gargi Sharma wrote: >> Replace the custom calls to mru.[ch] with calls to list.h. This patch is >> the final step in removing the mru API completely and inlining the logic. >> This patch leads to significant

Re: [PATCH v3] mru: Replace mru.[ch] with list.h implementation

2018-01-20 Thread Gargi Sharma
On Sat, Jan 20, 2018 at 1:02 AM, Eric Wong wrote: > Gargi Sharma wrote: >> --- a/list.h >> +++ b/list.h >> @@ -93,6 +93,13 @@ static inline void list_move(struct list_head *elem, >> struct list_head *head) >> list_add(elem, head); >> } >> >> +/* Move to the front of the list. */ >> +stati

Re: [PATCH] enable core.fsyncObjectFiles by default

2018-01-20 Thread Theodore Ts'o
On Fri, Jan 19, 2018 at 11:08:46AM -0800, Junio C Hamano wrote: > So..., is it fair to say that the one you sent in > > https://public-inbox.org/git/20180117193510.ga30...@lst.de/ > > is the best variant we have seen in this thread so far? I'll keep > that in my inbox so that I do not forget,

Re: [PATCH 00/11] Some fixes and bunch of object_id conversions

2018-01-20 Thread brian m. carlson
On Thu, Jan 18, 2018 at 03:50:52PM +0100, Patryk Obara wrote: > * brian m. carlson implemented vtable for hash algorithm selection and pushed > the repository format front - thanks to him it's now quite easy to > experimentally replace hashing functions and, e.g. do some performance > testing. Go

RE: [PATCH v2 2/6] Add tar extract install options override in installation processing.

2018-01-20 Thread Randall S. Becker
On January 20, 2018 3:34 PM, Ævar Arnfjörð Bjarmason > On Sat, Jan 20 2018, Randall S. Becker jotted: > > > I will reissue this particular patch shortly. > > It makes sense to base that submission on the next branch instead of master. > I have a patch queued up there which adds two new tar invoca

Re: [PATCH 11/11] sha1_file: convert write_sha1_file to object_id

2018-01-20 Thread brian m. carlson
On Thu, Jan 18, 2018 at 03:51:03PM +0100, Patryk Obara wrote: > diff --git a/sha1_file.c b/sha1_file.c > index 88b960316c..b7baf69041 100644 > --- a/sha1_file.c > +++ b/sha1_file.c > @@ -1420,8 +1420,8 @@ void *read_object_with_reference(const unsigned char > *sha1, > } > > static void write_s

Re: [PATCH v2 2/6] Add tar extract install options override in installation processing.

2018-01-20 Thread Ævar Arnfjörð Bjarmason
On Sat, Jan 20 2018, Randall S. Becker jotted: > I will reissue this particular patch shortly. It makes sense to base that submission on the next branch instead of master. I have a patch queued up there which adds two new tar invocations. Also re your commit message see the formatting guide in

[PATCH] t: add clone test for files differing only in case

2018-01-20 Thread brian m. carlson
We recently introduced a regression in cloning repositories onto case-insensitive file systems where the repository contains multiple files differing only in case. In such a case, we would segfault. This segfault has already been fixed (repository: pre-initialize hash algo pointer), but it's not

RE: [PATCH v2 2/6] Add tar extract install options override in installation processing.

2018-01-20 Thread Randall S. Becker
On January 20, 2018 9:25 AM, René Scharfe wrote: > To: Randall S. Becker ; git@vger.kernel.org > Subject: Re: [PATCH v2 2/6] Add tar extract install options override in > installation processing. > > Am 20.01.2018 um 14:44 schrieb Randall S. Becker: > > On January 20, 2018 7:31 AM, René Scharfe wr

[PATCH v4 6/6] convert: add tracing for 'working-tree-encoding' attribute

2018-01-20 Thread lars . schneider
From: Lars Schneider Add the GIT_TRACE_CHECKOUT_ENCODING environment variable to enable tracing for content that is reencoded with the 'working-tree-encoding' attribute. This is useful to debug encoding issues. Signed-off-by: Lars Schneider --- convert.c| 28 +++

[PATCH v4 4/6] utf8: add function to detect a missing UTF-16/32 BOM

2018-01-20 Thread lars . schneider
From: Lars Schneider If the endianness is not defined in the encoding name, then let's be strict and require a BOM to avoid any encoding confusion. The has_missing_utf_bom() function returns true if a required BOM is missing. The Unicode standard instructs to assume big-endian if there in no BOM

[PATCH v4 3/6] utf8: add function to detect prohibited UTF-16/32 BOM

2018-01-20 Thread lars . schneider
From: Lars Schneider Whenever a data stream is declared to be UTF-16BE, UTF-16LE, UTF-32BE or UTF-32LE a BOM must not be used [1]. The function returns true if this is the case. This function is used in a subsequent commit. [1] http://unicode.org/faq/utf_bom.html#bom10 Signed-off-by: Lars Schn

[PATCH v4 5/6] convert: add 'working-tree-encoding' attribute

2018-01-20 Thread lars . schneider
From: Lars Schneider Git recognizes files encoded with ASCII or one of its supersets (e.g. UTF-8 or ISO-8859-1) as text files. All other encodings are usually interpreted as binary and consequently built-in Git text processing tools (e.g. 'git diff') as well as most Git web front ends do not visu

[PATCH v4 2/6] strbuf: add xstrdup_toupper()

2018-01-20 Thread lars . schneider
From: Lars Schneider Create a copy of an existing string and make all characters upper case. Similar xstrdup_tolower(). This function is used in a subsequent commit. Signed-off-by: Lars Schneider --- strbuf.c | 12 strbuf.h | 1 + 2 files changed, 13 insertions(+) diff --git a/

[PATCH v4 1/6] strbuf: remove unnecessary NUL assignment in xstrdup_tolower()

2018-01-20 Thread lars . schneider
From: Lars Schneider Since 3733e69464 (use xmallocz to avoid size arithmetic, 2016-02-22) we allocate the buffer for the lower case string with xmallocz(). This already ensures a NUL at the end of the allocated buffer. Remove the unnecessary assignment. Signed-off-by: Lars Schneider --- strbu

[PATCH v4 0/6] convert: add support for different encodings

2018-01-20 Thread lars . schneider
From: Lars Schneider Hi, Patches 1-4 and 6 are preparation and helper functions. Patch 5 is the actual change. This series depends on Torsten's "convert_to_git(): safe_crlf/checksafe becomes int conv_flags" patch: https://public-inbox.org/git/20180113224931.27031-1-tbo...@web.de/ Changes since

Re: [PATCH v2 2/6] Add tar extract install options override in installation processing.

2018-01-20 Thread René Scharfe
Am 20.01.2018 um 14:44 schrieb Randall S. Becker: > On January 20, 2018 7:31 AM, René Scharfe wrote: >> Am 19.01.2018 um 18:34 schrieb randall.s.bec...@rogers.com: >>> From: "Randall S. Becker" >>> >>> * Makefile: Add TAR_EXTRACT_OPTIONS to allow platform options to >>> be specified if needed. Th

RE:

2018-01-20 Thread Mr Sheng Li Hung
I am Mr.Sheng Li Hung, from china I got your information while search for a reliable person, I have a very profitable business proposition for you and i can assure you that you will not regret been part of this mutual beneficial transaction after completion. Kindly get back to me for more details o

RE: [PATCH v2 2/6] Add tar extract install options override in installation processing.

2018-01-20 Thread Randall S. Becker
On January 20, 2018 7:31 AM, René Scharfe wrote: > Am 19.01.2018 um 18:34 schrieb randall.s.bec...@rogers.com: > > From: "Randall S. Becker" > > > > * Makefile: Add TAR_EXTRACT_OPTIONS to allow platform options to be > >specified if needed. The default is xof. > > > > Signed-off-by: Randall S.

RE: [PATCH v2 0/6] Force pipes to flush immediately on NonStop platform

2018-01-20 Thread Randall S. Becker
On January 20, 2018 6:10 AM, Torsten Bögershausen wrote: > On Fri, Jan 19, 2018 at 12:33:59PM -0500, randall.s.bec...@rogers.com > wrote: > > From: "Randall S. Becker" > > > > * wrapper.c: called setbuf(stream,0) to force pipe flushes not enabled by > > default on the NonStop platform. > > > >

Re: [PATCH v2 2/6] Add tar extract install options override in installation processing.

2018-01-20 Thread René Scharfe
Am 19.01.2018 um 18:34 schrieb randall.s.bec...@rogers.com: > From: "Randall S. Becker" > > * Makefile: Add TAR_EXTRACT_OPTIONS to allow platform options to be >specified if needed. The default is xof. > > Signed-off-by: Randall S. Becker > --- > Makefile | 6 +- > 1 file changed, 5

Re: [PATCH v3 1/3] read-cache: fix reading the shared index for other repos

2018-01-20 Thread Thomas Gummerer
On 01/19, Junio C Hamano wrote: > Thomas Gummerer writes: > > > read_cache_from() defaults to using the gitdir of the_repository. As it > > is mostly a convenience macro, having to pass get_git_dir() for every > > call seems overkill, and if necessary users can have more control by > > using rea

Re: [PATCH v2 0/6] Force pipes to flush immediately on NonStop platform

2018-01-20 Thread Torsten Bögershausen
On Fri, Jan 19, 2018 at 12:33:59PM -0500, randall.s.bec...@rogers.com wrote: > From: "Randall S. Becker" > > * wrapper.c: called setbuf(stream,0) to force pipe flushes not enabled by > default on the NonStop platform. > > Signed-off-by: Randall S. Becker > --- > wrapper.c | 3 +++ > 1 file c

Re: [PATCH] repository: pre-initialize hash algo pointer

2018-01-20 Thread Eric Sunshine
On Sat, Jan 20, 2018 at 2:01 AM, Junio C Hamano wrote: > Junio C Hamano writes: >> Eric Sunshine writes: >>> Now that we know (due to Duy's excellent detective work[1]) that the >>> trigger is files with names differing only in case on case-insensitive >>> filesystems, the commit message can be

Re: [PATCH 2/8] sequencer: introduce the `merge` command

2018-01-20 Thread Jacob Keller
On Fri, Jan 19, 2018 at 6:45 AM, Phillip Wood wrote: > On 18/01/18 15:35, Johannes Schindelin wrote: >> >> This patch is part of the effort to reimplement `--preserve-merges` with >> a substantially improved design, a design that has been developed in the >> Git for Windows project to maintain the

Re: [PATCH 9/8] [DO NOT APPLY, but squash?] git-rebase--interactive: clarify arguments

2018-01-20 Thread Jacob Keller
On Fri, Jan 19, 2018 at 12:30 PM, Junio C Hamano wrote: > Johannes Schindelin writes: > >> Good idea! I would rather do it as an introductory patch (that only >> converts the existing list). >> >> As to `merge`: it is a bit more complicated ;-) >> >> m, merge ( | "..." ) [] >>