[PATCH v4] Replace memcpy with hashcpy when dealing hash copy globally

2014-03-06 Thread Sun He
as it is, because the function is about the SHA-1 hash algorithm whose output is and will always be 20-byte. Helped-by: Michael Haggerty mhag...@alum.mit.edu Helped-by: Duy Nguyen pclo...@gmail.com Helped-by: Junio C Hamano gits...@pobox.com Signed-off-by: Sun He sunheeh...@gmail.com --- PATCH v4

[PATCH v5] Replace memcpy with hashcpy when dealing hash copy globally

2014-03-06 Thread Sun He
is and will always be 20-byte. Helped-by: Michael Haggerty mhag...@alum.mit.edu Helped-by: Duy Nguyen pclo...@gmail.com Helped-by: Junio C Hamano gits...@pobox.com Signed-off-by: Sun He sunheeh...@gmail.com --- PATCH v5 changed the reason why should take this patch as tutored by Junio C Hamano. Thanks

[PATCH] Setup.c: PATH_MAX is the length including the Nil

2014-03-04 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- Check the limit.h of linux and find out that the MACRO #define PATH_MAX4096/* # chars in a path name including nul */ So if the magic number 40 is just the size it should be. (e.g. hash code) It may bring bugs with the length(4056

[PATCH v3] finish_tmp_packfile():use strbuf for pathname construction

2014-03-03 Thread Sun He
-by: Sun He sunheeh...@gmail.com --- PATCH v3 adds the reason why we should apply this patch. Thanks to Micheal Haggerty. PATCH v3 transposes the space and comma before the third argument as Eric Sunshine suggested to meet the style of existing code. Thanks to Eric Sunshine. PATCH v3 fixes the order

[PATCH v3] Replace memcpy with hashcpy when dealing hash copy globally

2014-03-03 Thread Sun He
-by: Sun He sunheeh...@gmail.com --- PATCH v3 delete the one-space indentation on each line of commit message as is suggested by Eric Sunshine. Thanks to Eric Sunshine. PATCH v2 leave ppc/sha1.c alone. The general rule is if cache.h or git-compat-util.h is included, it is the first #include

[PATCH v3] Place cache.h at the first place to match general rule

2014-03-02 Thread Sun He
The general rule is if cache.h or git-compat-util.h is included, it is the first #include. As builtin.h starts with git-compat-util.h, files that start with builtin.h are not changed. Helped-by: Duy Nguyen pclo...@gmail.com Helped-by: Eric Sunshine sunsh...@sunshineco.com Signed-off-by: Sun

[PATCH v2] Replace memcpy with hashcpy when dealing hash copy globally

2014-03-02 Thread Sun He
-off-by: Sun He sunheeh...@gmail.com --- PATCH v2 leave ppc/sha1.c alone. The general rule is if cache.h or git-compat-util.h is included, it is the first #include, and system includes will be always in git-compat-tuil.h. via Duy Nguyen The change

[PATCH] Place cache.h at the first place to match generl rule

2014-03-01 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com Helped-by: Duy Nguyen pclo...@gmail.com --- The general rule is if cache.h or git-compat-util.h is included, it is the first #include. I parsed all the source files, and find many files start with builtin.h. And git-compat-util.h is the first

[PATCH v2] Place cache.h at the first place to match general rule

2014-03-01 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com Helped-by: Duy Nguyen pclo...@gmail.com --- PATCH v2 Fix the spelling bug of general in subject as is suggested by brain m.calson sand...@crustytoothpaste.net The general rule is if cache.h or git-compat-util.h is included, it is the first #include

[PATCH v2] finish_tmp_packfile():use strbuf for pathname construction

2014-03-01 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com Helped-by: Eric Sunshine sunsh...@sunshineco.com Helped-by: Michael Haggerty mhag...@alum.mit.edu --- This patch has assumed that you have already fix the bug of tmpname in builtin/pack-objects.c:write_pack_file() warning() builtin/pack-objects.c | 15

[PATCH v2] Replace tmpname with pack_tmp_name in warning. The developer mistook tmpname for pack_tmp_name.

2014-03-01 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- As tmpname is used without initialization, it should be a mistake. builtin/pack-objects.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c index c733379..4922ce5 100644

[PATCH v3] write_pack_file: use correct variable in diagnostic

2014-03-01 Thread Sun He
'pack_tmp_name' is the subject of the utime() check, so report it in the warning, not the uninitialized 'tmpname' Signed-off-by: Sun He sunheeh...@gmail.com --- Changing the subject and adding valid information as tutored by Eric Sunshine. Thanks to him. builtin/pack-objects.c | 2 +- 1

[PATCH] Rewrite bulk-checkin.c:finish_bulk_checkin() to use a strbuf for handling packname

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- builtin/pack-objects.c | 17 +++-- bulk-checkin.c | 8 +--- pack-write.c | 20 pack.h | 2 +- 4 files changed, 25 insertions(+), 22 deletions(-) diff --git a/builtin/pack

[PATCH] parse-options.c:parse_options_check() change OPTION_NUMBER to OPTION_CMDMODE

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- parse-options.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/parse-options.c b/parse-options.c index 7b8d3fa..59a52b0 100644 --- a/parse-options.c +++ b/parse-options.c @@ -371,7 +371,7 @@ static void parse_options_check(const

[PATCH] OPTION_CMDMODE should be used when not accept an argument, and OPTION_NUMBER is of special type. So change the mode to OPTION_CMDMODE

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- parse-options.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/parse-options.c b/parse-options.c index 7b8d3fa..59a52b0 100644 --- a/parse-options.c +++ b/parse-options.c @@ -371,7 +371,7 @@ static void parse_options_check(const

[PATCH] OPTION_NUMBER should be replaced by OPTION_CMDMODE

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- parse-options.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/parse-options.c b/parse-options.c index 7b8d3fa..59a52b0 100644 --- a/parse-options.c +++ b/parse-options.c @@ -371,7 +371,7 @@ static void parse_options_check(const

[PATCH] builtin/pack-objects.c:write_pack_file() replace tmpname with pack_tmp_name in warning

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- builtin/pack-objects.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/builtin/pack-objects.c b/builtin/pack-objects.c index c733379..4922ce5 100644 --- a/builtin/pack-objects.c +++ b/builtin/pack-objects.c @@ -823,7 +823,7

[PATCH] builtin/pack-objects.c:write_pack_file() replace tmpname with pack_tmp_name in warning

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- The tmpname is uninitialized and it should a bug Please ignore the former patches about this with wrong format. I am sorry to cause a jam in your inbox. ^_^ In the end, I wanna thank Michael Haggerty who give me help. builtin/pack-objects.c | 2

[PATCH] finish_tmp_packfile():use strbuf for pathname construction

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- I follow the suggestions of Eric Sunshine to fix the patch. Of cause this patch has assumed that you have already fix the bug of tmpname in builtin/pack-objects.c:write_pack_file() warning() I want to say thank you to Eric Sunshine and Michael

[PATCH] Replace memcpy with hashcpy when dealing hash copy globally

2014-02-28 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- Find the potential places with memcpy by the bash command: $ find . | xargs grep memcpy.*\(.*20.*\) Helped-by: Michael Haggertymhag...@alum.mit.edu bundle.c| 2 +- grep.c | 2 +- pack-bitmap-write.c | 2 +- ppc/sha1.c

[PATCH] Rewrite git-compat-util.h:skip_prefix() as a loop

2014-02-27 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- git-compat-util.h |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/git-compat-util.h b/git-compat-util.h index cbd86c3..4daa6cf 100644 --- a/git-compat-util.h +++ b/git-compat-util.h @@ -357,8 +357,8 @@ extern int

[PATCH] Change branch.c:install_branch_config()

2014-02-27 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- branch.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/branch.c b/branch.c index 723a36b..2fe9c05 100644 --- a/branch.c +++ b/branch.c @@ -50,7 +50,7 @@ static int should_setup_rebase(const char *origin) void

[PATCH] Rewrite bulk-checkin.c:finish_bulk_checkin() to use a strbuf for handling packname

2014-02-27 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- bulk-checkin.c | 10 +- 1 files changed, 9 insertions(+), 1 deletions(-) diff --git a/bulk-checkin.c b/bulk-checkin.c index 118c625..8c47d71 100644 --- a/bulk-checkin.c +++ b/bulk-checkin.c @@ -23,7 +23,8 @@ static struct

[PATCH] GSoC2014 microprojects Rewrite bulk-checkin.c:finish_bulk_checkin() to use a strbuf for handling packname

2014-02-27 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- bulk-checkin.c | 10 +- 1 files changed, 9 insertions(+), 1 deletions(-) diff --git a/bulk-checkin.c b/bulk-checkin.c index 118c625..e3c7fb2 100644 --- a/bulk-checkin.c +++ b/bulk-checkin.c @@ -23,7 +23,8 @@ static struct

[PATCH] GSoC2014 microprojects #5 Change bundle.c:add_to_ref_list() to use hashcpy()

2014-02-27 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- bundle.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/bundle.c b/bundle.c index e99065c..7809fbb 100644 --- a/bundle.c +++ b/bundle.c @@ -19,7 +19,7 @@ static void add_to_ref_list(const unsigned char *sha1, const char

[PATCH] GSoC2014 microprojects #6 Change bundle.c:add_to_ref_list() to use ALLOC_GROW()

2014-02-27 Thread Sun He
Signed-off-by: Sun He sunheeh...@gmail.com --- bundle.c |6 +- 1 files changed, 1 insertions(+), 5 deletions(-) diff --git a/bundle.c b/bundle.c index 7809fbb..1a7b7eb 100644 --- a/bundle.c +++ b/bundle.c @@ -14,11 +14,7 @@ static const char bundle_signature[] = # v2 git bundle\n