Re: GIT_INDEX_FILE environment variable

2005-04-22 Thread Zach Welch
Howdy, Linus Torvalds wrote: On Thu, 21 Apr 2005, Junio C Hamano wrote: I am thinking about an alternative way of doing the above by some modifications to the git core. I think the root of this problem is that there is no equivalent to GIT_INDEX_FILE and SHA1_FILE_DIRECTORY that tells the core

[PATCH 0/8] init-db.c cleanup, add INDEX_FILE_DIRECTORY support

2005-04-19 Thread Zach Welch
own independent '.yogi' trees, the very notion of which may cause this whole series to be henceforth flamed into oblivion. Here's to hoping otherwise Cheers, Zach Welch Superlucidity Services These patches are based off commit 5b53d3a08d64198d26d4f2323f235790c04aeaab. There are 8 patches

[PATCH 1/8] init-db.c: [RESEND] remove redundant getenv call

2005-04-19 Thread Zach Welch
init-db calls getenv(DB_ENVIRONMENT) twice. Once should be enough. This patch applies on top of: [PATCH 0/8] init-db.c cleanup, add INDEX_FILE_DIRECTORY support init-db.c |3 +-- 1 files changed, 1 insertion(+), 2 deletions(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] Signed-Off

[PATCH 3/8] init-db.c: refactor directory creation

2005-04-19 Thread Zach Welch
[PATCH 2/8] init-db.c: [RESEND] make init-db work with common objects init-db.c | 61 --- 1 files changed, 34 insertions(+), 27 deletions(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] --- a/init-db.c +++ b/init-db.c @@ -4,43 +4,50 @@ * Copyright (C

[PATCH 4/8] init-db.c: add INDEX_FILE_DIRECTORY support

2005-04-19 Thread Zach Welch
call [PATCH 2/8] init-db.c: [RESEND] make init-db work with common objects [PATCH 3/8] init-db.c: refactor directory creation cache.h |3 +++ init-db.c |5 + 2 files changed, 4 insertions(+), 4 deletions(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] --- a/cache.h

[PATCH 5/8] init-db.c: refactor mkdir logic

2005-04-19 Thread Zach Welch
objects [PATCH 3/8] init-db.c: refactor directory creation [PATCH 4/8] init-db.c: add INDEX_FILE_DIRECTORY support init-db.c | 24 1 files changed, 12 insertions(+), 12 deletions(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] --- a/init-db.c 2005-04-19 01

[PATCH 7/8] read-tree.c: add INDEX_FILE_DIRECTORY support

2005-04-19 Thread Zach Welch
INDEX_FILE_DIRECTORY support read-tree.c | 33 + 1 files changed, 25 insertions(+), 8 deletions(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] read-tree.c: 42556c82def1d23f21116a2c1b3e7ae27c0605c5 --- a/read-tree.c +++ b/read-tree.c @@ -65,12 +65,12 @@ static int

[PATCH 0/3] init-db.c cleanup and fixes

2005-04-19 Thread Zach Welch
init-db. As such, I started from scratch, and came up with a much simpler series of patches. Please continue to ignore the previous series, but consider these new patches in their stead. New GIT_FILE_DIRECTORY patches will follow seperately. Cheers, Zach Welch Superlucidity Services

[PATCH 2/3] init-db.c: normalize env var handling.

2005-04-19 Thread Zach Welch
This patch applies on top of: [PATCH 1/3] init-db.c: cleanup comments init-db.c | 11 +++ 1 files changed, 3 insertions(+), 8 deletions(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] Normalize init-db environment variable handling, allowing the creation of object directories

[PATCH 3/3] init-db.c: create and use safe_create_dir helper

2005-04-19 Thread Zach Welch
This patch applies on top of: [PATCH 1/3] init-db.c: cleanup comments [PATCH 2/3] init-db.c: normalize env var handling. init-db.c | 30 ++ 1 files changed, 14 insertions(+), 16 deletions(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] Factor mkdir

[PATCH 1/3] add GIT_CACHE_DIRECTORY support

2005-04-19 Thread Zach Welch
cache.h|3 +++ init-db.c |9 +++-- read-cache.c | 15 +-- read-tree.c| 35 ++- update-cache.c | 33 - 5 files changed, 73 insertions(+), 22 deletions(-) Signed-Off-By: Zach Welch

[PATCH 2/3] rename object directory symbols

2005-04-19 Thread Zach Welch
-By: Zach Welch [EMAIL PROTECTED] Rename the DB_ENVIRONMENT symbols to match the newly introduced GIT_CACHE_ENVIROMENT symbols. cache.h: 1fca894f485471d51c6a72c16e02df6d56d0052f --- a/cache.h +++ b/cache.h @@ -84,8 +84,8 @@ unsigned int active_nr, active_alloc; #define GIT_CACHE_ENVIRONMENT

[PATCH 3/3] rename SHA1_FILE_DIRECTORY

2005-04-19 Thread Zach Welch
This patch applies on top of: [PATCH 1/3] add GIT_CACHE_DIRECTORY support [PATCH 2/3] rename object directory symbols cache.h |2 +- 1 files changed, 1 insertion(+), 1 deletion(-) Signed-Off-By: Zach Welch [EMAIL PROTECTED] Rename SHA1_FILE_DIRECTORY to GIT_OBJECT_DIRECTORY

Re: [PATCH 2/3] init-db.c: normalize env var handling.

2005-04-19 Thread Zach Welch
Linus Torvalds wrote: For future reference, this is in the wrong order. I feel even more abashed for my earlier scripting faux pas. Would you like me to resend them to you off-list? Cheers, Zach - To unsubscribe from this list: send the line unsubscribe git in the body of a message to [EMAIL

Re: Handling renames.

2005-04-14 Thread Zach Welch
it would be better to distinguish the two layers, perhaps by calling the low-level plumbing... 'gitfs', of course. Cheers, Zach Welch Superlucidity Services - To unsubscribe from this list: send the line unsubscribe git in the body of a message to [EMAIL PROTECTED] More majordomo info at http