[PATCH 1/2] checkout_entry(): use the strbuf throughout the function

2014-03-13 Thread Michael Haggerty
There is no need to break out the buf and len members into separate temporary variables. Rename path_buf to path and use path.buf and path.len directly. This makes it easier to reason about the data flow in the function. Signed-off-by: Michael Haggerty mhag...@alum.mit.edu --- entry.c | 32

Re: [PATCH 1/2] checkout_entry(): use the strbuf throughout the function

2014-03-13 Thread Duy Nguyen
On Thu, Mar 13, 2014 at 4:19 PM, Michael Haggerty mhag...@alum.mit.edu wrote: There is no need to break out the buf and len members into separate temporary variables. Rename path_buf to path and use path.buf and path.len directly. This makes it easier to reason about the data flow in the