[PATCH 14/40] sha1_file: prepare for external odbs

2018-01-03 Thread Christian Couder
In the following commits we will need some functions that were internal to sha1_file.c, so let's first make them non static and declare them in "cache.h". While at it, let's rename 'create_tmpfile()' to 'create_object_tmpfile()' to make its name less generic. Let's also split out 'sha1_file_name_a

Re: [PATCH 14/40] sha1_file: prepare for external odbs

2018-01-04 Thread Jeff Hostetler
On 1/3/2018 11:33 AM, Christian Couder wrote: In the following commits we will need some functions that were internal to sha1_file.c, so let's first make them non static and declare them in "cache.h". While at it, let's rename 'create_tmpfile()' to 'create_object_tmpfile()' to make its name les

Re: [PATCH 14/40] sha1_file: prepare for external odbs

2018-01-15 Thread Christian Couder
On Thu, Jan 4, 2018 at 7:00 PM, Jeff Hostetler wrote: > > > On 1/3/2018 11:33 AM, Christian Couder wrote: >> diff --git a/sha1_file.c b/sha1_file.c >> index 261baf800f..785e8dda03 100644 >> --- a/sha1_file.c >> +++ b/sha1_file.c >> @@ -322,17 +322,22 @@ static void fill_sha1_path(struct strbuf *b