Re: [PATCH v1 2/4] fsmonitor: update GIT_TEST_FSMONITOR support

2018-09-14 Thread Junio C Hamano
Ben Peart writes: > The difference here is that core.fsmonitor isn't a boolean value. It > is a string to a command that is executed so it can't be moved over to > get_env_bool(). Ah, of course ;-) Then please take the following as a review comment for 4/4; checking if each getenv(VAR) should

Re: [PATCH v1 2/4] fsmonitor: update GIT_TEST_FSMONITOR support

2018-09-14 Thread Ben Peart
On 9/14/2018 1:15 PM, Junio C Hamano wrote: Ben Peart writes: diff --git a/config.c b/config.c index 3461993f0a..3555c63f28 100644 --- a/config.c +++ b/config.c @@ -2278,7 +2278,7 @@ int git_config_get_max_percent_split_change(void) int git_config_get_fsmonitor(void) { if

Re: [PATCH v1 2/4] fsmonitor: update GIT_TEST_FSMONITOR support

2018-09-14 Thread Junio C Hamano
Ben Peart writes: > diff --git a/config.c b/config.c > index 3461993f0a..3555c63f28 100644 > --- a/config.c > +++ b/config.c > @@ -2278,7 +2278,7 @@ int git_config_get_max_percent_split_change(void) > int git_config_get_fsmonitor(void) > { > if (git_config_get_pathname("core.fsmonitor",

Re: [PATCH v1 2/4] fsmonitor: update GIT_TEST_FSMONITOR support

2018-09-14 Thread Junio C Hamano
Junio C Hamano writes: > Ben Peart writes: > >> +if test -n "$GIT_FSMONITOR_TEST" >> +then >> +if test -n "$GIT_TEST_FSMONITOR" >> +then >> +echo "warning: the GIT_FSMONITOR_TEST variable has been renamed >> to GIT_TEST_FSMONITOR" >> +else >> +echo "error:

Re: [PATCH v1 2/4] fsmonitor: update GIT_TEST_FSMONITOR support

2018-09-14 Thread Junio C Hamano
Ben Peart writes: > +if test -n "$GIT_FSMONITOR_TEST" > +then > + if test -n "$GIT_TEST_FSMONITOR" > + then > + echo "warning: the GIT_FSMONITOR_TEST variable has been renamed > to GIT_TEST_FSMONITOR" > + else > + echo "error: the GIT_FSMONITOR_TEST variable

[PATCH v1 2/4] fsmonitor: update GIT_TEST_FSMONITOR support

2018-09-14 Thread Ben Peart
Rename GIT_FSMONITOR_TEST to GIT_TEST_FSMONITOR for consistency with the other GIT_TEST_ special setups and properly document its use. Add logic in t/test-lib.sh to give an error when the old variable is set to let people know they need to update their environment to use the new variable. If the