[PATCH v10 3/5] t4205, t6006, t7102: make functions better readable

2013-07-05 Thread Alexey Shumkin
Function 'test_format' has become harder to read after its change in de6029a2 (pretty: Add failing tests: --format output should honor logOutputEncoding, 2013-06-26). Simplify it by moving its should we expect it to fail? parameter to the end. Note, current code does not use this last parameter

Re: [PATCH v10 3/5] t4205, t6006, t7102: make functions better readable

2013-07-05 Thread Junio C Hamano
Alexey Shumkin alex.crez...@gmail.com writes: - msg=$(printf modify 2nd file (ge\303\244ndert)) + msg=modify 2nd file (ge\303\244ndert) if test -n $1 then - msg=$(echo $msg | iconv -f utf-8 -t $1) + print $msg | iconv -f utf-8 -t $1 + else +

Re: [PATCH v10 3/5] t4205, t6006, t7102: make functions better readable

2013-07-05 Thread Junio C Hamano
Junio C Hamano gits...@pobox.com writes: Alexey Shumkin alex.crez...@gmail.com writes: -msg=$(printf modify 2nd file (ge\303\244ndert)) +msg=modify 2nd file (ge\303\244ndert) if test -n $1 then -msg=$(echo $msg | iconv -f utf-8 -t $1) +print $msg