Re: [PATCH v2] test_must_be_empty: simplify file existence check

2018-03-27 Thread Junio C Hamano
Junio C Hamano writes: >> test_must_be_empty () { >> -if ! test -f "$1" >> -then >> -echo "'$1' is missing" >> -return 1 >> -elif test -s "$1" >> +test_path_is_file "$1" && >> +if test -s "$1" >> then >> echo "'$1'

Re: [PATCH v2] test_must_be_empty: simplify file existence check

2018-03-27 Thread Junio C Hamano
SZEDER Gábor writes: > Commit 11395a3b4b (test_must_be_empty: make sure the file exists, not > just empty, 2018-02-27) basically duplicated the 'test_path_is_file' > helper function in 'test_must_be_empty'. > > Just call 'test_path_is_file' to avoid this code duplication. >

[PATCH v2] test_must_be_empty: simplify file existence check

2018-03-26 Thread SZEDER Gábor
Commit 11395a3b4b (test_must_be_empty: make sure the file exists, not just empty, 2018-02-27) basically duplicated the 'test_path_is_file' helper function in 'test_must_be_empty'. Just call 'test_path_is_file' to avoid this code duplication. Signed-off-by: SZEDER Gábor ---