Re: [PATCH v2 2/4] log: add --count option to git log

2015-07-03 Thread Matthieu Moy
Lawrence Siebert lawrencesieb...@gmail.com writes: +static void show_object(struct object *obj, + const struct name_path *path, const char *component, + void *cb_data) +{ + return; +} It seems streange to me to have a function named show_object

Re: [PATCH v2 2/4] log: add --count option to git log

2015-07-03 Thread Lawrence Siebert
traverse_commit_list requires a function to be passed to it. That said, after further review it can probably pass NULL and have it work fine. If not, I'll use your naming convention. `git rev-list --count` (or actually `git rev-list --count HEAD`, which this borrows the code from, produces a

Re: [PATCH v2 2/4] log: add --count option to git log

2015-07-03 Thread Matthieu Moy
Hi, Please, don't top-post on this list. Quote the parts you're replying to and reply below. Lawrence Siebert lawrencesieb...@gmail.com writes: traverse_commit_list requires a function to be passed to it. That said, after further review it can probably pass NULL and have it work fine. If

[PATCH v2 2/4] log: add --count option to git log

2015-07-02 Thread Lawrence Siebert
adds --count from git rev-list to git log, without --use-bitmap-index for the moment. Signed-off-by: Lawrence Siebert lawrencesieb...@gmail.com --- builtin/log.c | 29 + 1 file changed, 29 insertions(+) diff --git a/builtin/log.c b/builtin/log.c index