Re: Add a bugzilla website

2014-01-08 Thread David Aguilar
On Fri, Nov 15, 2013 at 2:34 AM, ycollette.nos...@free.fr wrote: OK, thanks for these informations. From a user perspective, having this volume of devel mails flooding all the bugs mail is very annoying. And following the status of a bug and the history of this bug is very hard too. The

[RFC/PATCH 0/5] branch@{publish} shorthand

2014-01-08 Thread Jeff King
On Wed, Jan 08, 2014 at 03:05:48AM +0530, Ramkumar Ramachandra wrote: Agreed. I'll start working on @{publish}. It's going to take quite a bit of effort, because I won't actually start using it until my prompt is @{publish}-aware. There's a fair bit of refactoring involved. I took a stab at

[PATCH 1/5] sha1_name: refactor upstream_mark

2014-01-08 Thread Jeff King
We will be adding new mark types in the future, so separate the suffix data from the logic. Signed-off-by: Jeff King p...@peff.net --- sha1_name.c | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git a/sha1_name.c b/sha1_name.c index b1873d8..0c50801 100644 ---

[PATCH 3/5] branch_get: return early on error

2014-01-08 Thread Jeff King
Right now we simply check if ret is valid before doing further processing. As we add more processing, this will become more and more cumbersome. Instead, let's just check whether ret is invalid and return early with the error. Signed-off-by: Jeff King p...@peff.net --- remote.c | 5 - 1 file

[PATCH 4/5] branch_get: provide per-branch pushremote pointers

2014-01-08 Thread Jeff King
When a caller uses branch_get to retrieve a struct branch, they get the per-branch remote name and a pointer to the remote struct. However, they have no way of knowing about the per-branch pushremote from this interface. Let's expose that information via fields similar to remote and remote_name.

[PATCH 2/5] interpret_branch_name: factor out upstream handling

2014-01-08 Thread Jeff King
This function checks a few different @{}-constructs. The early part checks for and dispatches us to helpers for each construct, but the code for handling @{upstream} is inline. Let's factor this out into its own function. This makes interpret_branch_name more readable, and will make it much

[PATCH 5/5] implement @{publish} shorthand

2014-01-08 Thread Jeff King
In a triangular workflow, you may have a distinct @{upstream} that you pull changes from, but publish by default (if you typed git push) to a different remote (or a different branch on the remote). It may sometimes be useful to be able to quickly refer to that publishing point (e.g., to see which

Re: [PATCH v3 3/5] refs: teach for_each_ref a flag to avoid recursion

2014-01-08 Thread Jeff King
On Tue, Jan 07, 2014 at 10:47:33PM -0500, Jeff King wrote: On Tue, Jan 07, 2014 at 06:58:50PM -0500, Jeff King wrote: + if (flags DO_FOR_EACH_NO_RECURSE) { + struct ref_dir *subdir = get_ref_dir(entry); +

Re: [PATCH 4/5] branch_get: provide per-branch pushremote pointers

2014-01-08 Thread Jeff King
On Wed, Jan 08, 2014 at 04:35:31AM -0500, Jeff King wrote: @@ -385,8 +387,11 @@ static int handle_config(const char *key, const char *value, void *cb) name = key + 7; /* Handle remote.* variables */ - if (!strcmp(name, pushdefault)) - return

[PATCH] t5531: further matching fixups

2014-01-08 Thread Jeff King
Commit 43eb920 switched one of the sub-repository in this test to matching to prepare for a world where the default becomes simple. However, the main repository needs a similar change. We did not notice any test failure when merged with b2ed944 (push: switch default from matching to simple,

Re: [PATCH 4/5] branch_get: provide per-branch pushremote pointers

2014-01-08 Thread Jeff King
On Wed, Jan 08, 2014 at 05:27:07AM -0500, Jeff King wrote: This patch passes the test suite by itself (with or without that fixup). But oddly, it seems to fail t5531 when merged with 'next'. I can't figure out why, though. It shouldn't affect any code that doesn't look at branch-pushremote.

Re: [PATCH v4 23/28] Support shallow fetch/clone over smart-http

2014-01-08 Thread Jeff King
On Thu, Dec 05, 2013 at 08:02:50PM +0700, Nguyễn Thái Ngọc Duy wrote: Signed-off-by: Nguyễn Thái Ngọc Duy pclo...@gmail.com --- Documentation/gitremote-helpers.txt | 7 +++ builtin/fetch-pack.c| 16 +--- remote-curl.c | 31

Re: [PATCH v3 3/5] refs: teach for_each_ref a flag to avoid recursion

2014-01-08 Thread Michael Haggerty
On 01/08/2014 04:47 AM, Jeff King wrote: On Tue, Jan 07, 2014 at 06:58:50PM -0500, Jeff King wrote: +if (flags DO_FOR_EACH_NO_RECURSE) { +struct ref_dir *subdir = get_ref_dir(entry); +sort_ref_dir(subdir); +

[PATCH] t5537: fix incorrect expectation in test case 10

2014-01-08 Thread Nguyễn Thái Ngọc Duy
Commit 48d25ca adds a new commit 7 to the repo that the next test case in commit 1609488 clones from. But the next test case does not expect this commit. For these tests, it's the bottom that's important, not the top. Fix the expected commit list. While at it, fix the default http port number to

Re: [PATCH 2/5] interpret_branch_name: factor out upstream handling

2014-01-08 Thread Ramkumar Ramachandra
Jeff King wrote: sha1_name.c | 83 ++--- 1 file changed, 52 insertions(+), 31 deletions(-) Thanks. I applied this to my series as-it-is. -- To unsubscribe from this list: send the line unsubscribe git in the body of a message to

Re: [RFC/PATCH 0/5] branch@{publish} shorthand

2014-01-08 Thread Ramkumar Ramachandra
Jeff King wrote: There's a fair bit of refactoring involved. I took a stab at it and came up with the series below. No docs or tests, and some of the refactoring in remote.c feels a little weird. I can't help but feel more of the logic from git push should be shared here. But it at least

[PATCH 1/3] shorten_unambiguous_ref(): introduce a new local variable

2014-01-08 Thread Michael Haggerty
When filling the scanf_fmts array, use a separate variable to keep track of the offset to avoid clobbering total_len (which we will need in the next commit). Signed-off-by: Michael Haggerty mhag...@alum.mit.edu --- refs.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

[PATCH 3/3] shorten_unambiguous_ref(): tighten up pointer arithmetic

2014-01-08 Thread Michael Haggerty
As long as we're being pathologically stingy with mallocs, we might as well do the math right and save 6 (!) bytes. Signed-off-by: Michael Haggerty mhag...@alum.mit.edu --- It is left to the reader to show how another 7 bytes could be saved (11 bytes on a 64-bit architecture!) It probably

[PATCH 0/3] Generate scanf_fmts more simply

2014-01-08 Thread Michael Haggerty
This is just a fun little thing that I noticed while poking around the code: the function gen_scanf_fmt() can be replaced with a simple call to snprintf(). Michael Haggerty (3): shorten_unambiguous_ref(): introduce a new local variable gen_scanf_fmt(): delete function and use snprintf()

[PATCH 2/3] gen_scanf_fmt(): delete function and use snprintf() instead

2014-01-08 Thread Michael Haggerty
To replace %.*s with %s, all we have to do is use snprintf() to interpolate %s into the pattern. Signed-off-by: Michael Haggerty mhag...@alum.mit.edu --- refs.c | 35 +-- 1 file changed, 9 insertions(+), 26 deletions(-) diff --git a/refs.c b/refs.c index

Re: [PATCH v2 4/5] get_sha1: speed up ambiguous 40-hex test

2014-01-08 Thread Michael Haggerty
On 01/08/2014 12:59 AM, Jeff King wrote: Since 798c35f (get_sha1: warn about full or short object names that look like refs, 2013-05-29), a 40-hex sha1 causes us to call dwim_ref on the result, on the off chance that we have a matching ref. This can cause a noticeable slow-down when there are

Re: [PATCH v2 5/5] get_sha1: drop object/refname ambiguity flag

2014-01-08 Thread Michael Haggerty
On 01/08/2014 01:00 AM, Jeff King wrote: Now that our object/refname ambiguity test is much faster (thanks to the previous commit), there is no reason for code like cat-file --batch-check to turn it off. Here are before and after timings with this patch (on git.git): $ git rev-list

[PATCH mm/mv-file-to-no-such-dir-with-slash] mv: let 'git mv file no-such-dir/' error out on Windows, too

2014-01-08 Thread Johannes Sixt
The previous commit c57f628 (mv: let 'git mv file no-such-dir/' error out) relies on that rename(src, dst/) fails if directory dst does not exist (note the trailing slash). This does not work as expected on Windows: This rename() call is successful. Insert an explicit check for this case. This

[PATCH] merge: make merge state available to prepare-commit-msg hook

2014-01-08 Thread Ryan Biesemeyer
From a1f898fdf560e719d447a544569d5d1457307855 Mon Sep 17 00:00:00 2001 From: Ryan Biesemeyer r...@yaauie.com Date: Wed, 8 Jan 2014 04:22:12 + Subject: [PATCH 0/2] merge make merge state available to prepare-commit-msg hook Since prepare-commit-msg hook is given 'merge' as an argument when a

Re: [PATCH] merge: make merge state available to prepare-commit-msg hook

2014-01-08 Thread Ryan Biesemeyer
From 9b431e5206652cf62ebb09dad4607989976e7748 Mon Sep 17 00:00:00 2001 From: Ryan Biesemeyer r...@yaauie.com Date: Wed, 8 Jan 2014 00:46:41 + Subject: [PATCH 1/2] merge: make prepare_to_commit responsible for write_merge_state When merging, make the prepare-commit-msg hook have access to the

Re: [PATCH] merge: make merge state available to prepare-commit-msg hook

2014-01-08 Thread Ryan Biesemeyer
From a1f898fdf560e719d447a544569d5d1457307855 Mon Sep 17 00:00:00 2001 From: Ryan Biesemeyer r...@yaauie.com Date: Wed, 8 Jan 2014 00:47:41 + Subject: [PATCH 2/2] merge: drop unused arg from abort_commit method signature Since abort_commit is no longer responsible for writing merge state,

Re: [PATCH] merge: make merge state available to prepare-commit-msg hook

2014-01-08 Thread Ryan Biesemeyer
On 2014-01-08, at 20:06Z, Matthieu Moy matthieu@grenoble-inp.fr wrote: Ryan Biesemeyer r...@yaauie.com writes: index 3573751..89cdfe8 100755 --- a/t/t7505-prepare-commit-msg-hook.sh +++ b/t/t7505-prepare-commit-msg-hook.sh @@ -181,5 +181,27 @@ test_expect_success 'with failing hook

Re: [PATCH] merge: make merge state available to prepare-commit-msg hook

2014-01-08 Thread Jonathan Nieder
Hi, Ryan Biesemeyer wrote: In this case it was not immediately clear to me how to add cleanup to an existing test that dirtied the state of the test repository by leaving behind an in-progress merge. I see `test_cleanup` defined in the test lib related functions, but see no examples

Re: [PATCH] merge: make merge state available to prepare-commit-msg hook

2014-01-08 Thread Jonathan Nieder
Matthieu Moy wrote: Jonathan's answer is an option. Another one is [...] So if the cleanup goes wrong, one can notice. test_when_finished also makes the test fail if the cleanup failed. Another common strategy is test_expect_success 'my exciting test' ' # this test

Re: Re: [RFC v2] submodule: Respect requested branch on all clones

2014-01-08 Thread Francesco Pretto
2014/1/8 W. Trevor King wk...@tremily.us: To elaborate the idea I sketched out here [2], say you want: Superproject branch Submodule branch Upstream branch === === master mastermaster super-feature

Re: [PATCH 5/5] implement @{publish} shorthand

2014-01-08 Thread Junio C Hamano
Jeff King p...@peff.net writes: In a triangular workflow, you may have a distinct @{upstream} that you pull changes from, but publish by default (if you typed git push) to a different remote (or a different branch on the remote). It may sometimes be useful to be able to quickly refer to that

Re: Re: [RFC v2] submodule: Respect requested branch on all clones

2014-01-08 Thread Francesco Pretto
2014/1/8 W. Trevor King wk...@tremily.us: I also prefer 'checkout' to 'head', because 'checkout' already exists in non-submodule Git for switching between local branches. Reasons I would loosely support 'git submodule checkout'

Re: [RFC v2] submodule: Respect requested branch on all clones

2014-01-08 Thread W. Trevor King
On Thu, Jan 09, 2014 at 12:07:56AM +0100, Francesco Pretto wrote: After long thoughts, I think your idea about a local branch with a differently named remote branch looks interesting but I would be extremely cautious to add a ' submodule.name.local-branch' now. Do we have a similar mechanism

Re: [RFC v2] submodule: Respect requested branch on all clones

2014-01-08 Thread W. Trevor King
On Thu, Jan 09, 2014 at 12:54:54AM +0100, Francesco Pretto wrote: 2) Having 'git checkout', 'git checkout --recurse-submodules' and finally 'git submodule checkout' is too much for me. Agreed. Since 'git checkout' already exists and 'git checkout --recurse-submodules' is close [1,2], I think

[PATCH v2 0/4] merge: make merge state available to prepare-commit-msg hook

2014-01-08 Thread Ryan Biesemeyer
Ensure merge state is available to the prepare-commit-msg hook. v2 patchset incorporates early feedback from the list Matthieu Moy (1): t7505: add missing Ryan Biesemeyer (3): t7505: ensure cleanup after hook blocks merge merge: make prepare_to_commit responsible for write_merge_state

[PATCH v2 3/4] merge: make prepare_to_commit responsible for write_merge_state

2014-01-08 Thread Ryan Biesemeyer
When merging, make the prepare-commit-msg hook have access to the merge state in order to make decisions about the commit message it is preparing. Since `abort_commit` is *only* called after `write_merge_state`, and a successful commit *always* calls `drop_save` to clear the saved state, this

[PATCH v2 2/4] t7505: ensure cleanup after hook blocks merge

2014-01-08 Thread Ryan Biesemeyer
Signed-off-by: Ryan Biesemeyer r...@yaauie.com --- t/t7505-prepare-commit-msg-hook.sh | 25 + 1 file changed, 13 insertions(+), 12 deletions(-) diff --git a/t/t7505-prepare-commit-msg-hook.sh b/t/t7505-prepare-commit-msg-hook.sh index 1c95652..697ecc0 100755 ---

[PATCH v2 1/4] t7505: add missing

2014-01-08 Thread Ryan Biesemeyer
From: Matthieu Moy matthieu@imag.fr Signed-off-by: Ryan Biesemeyer r...@yaauie.com --- t/t7505-prepare-commit-msg-hook.sh | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/t/t7505-prepare-commit-msg-hook.sh b/t/t7505-prepare-commit-msg-hook.sh index 3573751..1c95652 100755

[PATCH v2 4/4] merge: drop unused arg from abort_commit method signature

2014-01-08 Thread Ryan Biesemeyer
Since abort_commit is no longer responsible for writing merge state, remove the unused argument that was originally needed solely for writing merge state. Signed-off-by: Ryan Biesemeyer r...@yaauie.com --- builtin/merge.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff

Re: [RFC v2] submodule: Respect requested branch on all clones

2014-01-08 Thread Francesco Pretto
2014/1/9 W. Trevor King wk...@tremily.us: However, submodule.name.local-branch has nothing to do with remote repositories or tracking branches. My bad: this means the feature is still not entirely clear to me. [branch my-feature] remote = origin merge =

Re: [RFC v2] submodule: Respect requested branch on all clones

2014-01-08 Thread W. Trevor King
On Thu, Jan 09, 2014 at 02:09:37AM +0100, Francesco Pretto wrote: 2014/1/9 W. Trevor King wk...@tremily.us: [branch my-feature] remote = origin merge = refs/heads/my-feature [submodule submod] local-branch = my-feature and I don't think Git's

[PATCH] fetch: Print full url in header

2014-01-08 Thread Tom Miller
Do not remove / and .git from the end of the header url when fetching. This affects the output of fetch and fetch --prune making the header url more consistent with remote --verbose. Add tests to verify that fetch and fetch --prune do not strip the trailing characters from the header url. Output

Nike Air Max 1 Dame Billig

2014-01-08 Thread Stanche
Bare gribe muligheden.Så er der en kræver for dig at købe et enkelt par nye varemærke sko for at spille basketball. Du har været at sætte dette par Nike fodtøj for at spille bolde for omkring to mange år og der er helt sikkert knæk i skoene. Som værende et spørgsmål om det, Nike Air Max 90 Dame

Re: Nike Air Max 1 Dame Billig

2014-01-08 Thread Stanche
Nike basketball sneakers are endorsed by common NBA players like Lebron James, Kobe Bryant and Dwayne Wade, to name a couple of.There is absolutely no ought to value excessive money to buy another sort of sneakers called Nike Air Max Pure Game. You can find some mid sole and manual upper for Air

Verifiable git archives?

2014-01-08 Thread Andy Lutomirski
It's possible, in principle, to shove enough metadata into the output of 'git archive' to allow anyone to verify (without cloning the repo) to verify that the archive is a correct copy of a given commit. Would this be considered a useful feature? Presumably there would be a 'git untar' command

Nike Free 5.0 Sko Billigt

2014-01-08 Thread Stanche
Du kan finde masser af Nike sko, som er tilgængelige over hele og hvis din søgning for Nike vandreture sneakers, de har god top kvalitet vandresko, som er fremragende til vandreture. Her er nogle fra Nike sko.I sommerlejr Nike disciplin Hockey vil atleter træne under formynderskab fra de største

Re: Nike Free 5.0 Sko Billigt

2014-01-08 Thread Stanche
Eftersom avgiften inom stövlar är bara inte riktigt så liten, hur kan vi skaffa billiga air max 2011 sneakers skor? För dem som är lyckliga gott om, du kan köpa billiga stövlar på rea.Men inte alla har denna typ av bra utsikter. Endast en liten mängd befolkning har denna behandling. För personer

[RFC v3 0/4] Preferred local submodule branches

2014-01-08 Thread W. Trevor King
From: W. Trevor King wk...@tremily.us In another branch of the submodule thread Francesco kicked off, I mentioned that we could store the preferred local submodule branch on a per-superbranch level if we used the .git/modules/submodule-name/config for local overrides [1]. Here's a patch series

[RFC v3 3/4] submodule: Teach 'add' about a configurable local-branch

2014-01-08 Thread W. Trevor King
From: W. Trevor King wk...@tremily.us This patch teaches 'git submodule add' to look for a preferred local-branch, and to checkout that branch after the initial clone. The local branch will always point at the commit checked out by the internal 'git clone' operation. For example: $ git

[RFC v3 1/4] submodule: Add helpers for configurable local branches

2014-01-08 Thread W. Trevor King
From: W. Trevor King wk...@tremily.us There are three branches that submodule folks usually care about: 1. The linked $sha1 in the superproject (set explicitly for every superproject commit, and thus for every superproject branch). 2. The remote-tracking submodule.name.branch that tracks a

[RFC v3 4/4] submodule: Add a new 'checkout' command

2014-01-08 Thread W. Trevor King
From: W. Trevor King wk...@tremily.us This borrows a good deal of the cmd_foreach logic to iterate through submodules (potentially recursively), checking out the preferred local branch for each submodule (as appropriate for the current superproject branch). Ideally, this logic would be bundled