Re: [PATCH v3 16/27] attr: convert git_all_attrs() to use "struct attr_check"

2017-01-28 Thread Brandon Williams
On 01/28, Stefan Beller wrote: > > This being moved down to below (being review churn) sounds like a > rebase mistake. ;) > Yep, thanks for catching that. I'll need to fix that up. -- Brandon Williams

git-daemon shallow checkout fail

2017-01-28 Thread Bob Proulx
I am trying to understand a problem with shallow checkouts through the git-daemon. The server side fails trying to create a shallow_XX file in the repository. But of course it can't due to no permissions from the git-daemon user. However the problem driving me crazy is that this only fails

Re: [PATCH v3 16/27] attr: convert git_all_attrs() to use "struct attr_check"

2017-01-28 Thread Stefan Beller
On Fri, Jan 27, 2017 at 6:01 PM, Brandon Williams wrote: > From: Junio C Hamano > > This updates the other two ways the attribute check is done via an > array of "struct attr_check_item" elements. These two niches > appear only in "git check-attr". > > *

Re: [PATCH 1/3] Documentation/stash: remove mention of git reset --hard

2017-01-28 Thread Jeff King
On Sat, Jan 28, 2017 at 07:30:28PM +, Thomas Gummerer wrote: > Thanks all who chimed in here. My new description is definitely not > right. The reason I wanted to change it is part because it's an > implementation detail, and part because it's going to be not quite > right when the filename

[PATCH] use oid_to_hex_r() for converting struct object_id hashes to hex strings

2017-01-28 Thread René Scharfe
Patch generated by Coccinelle and contrib/coccinelle/object_id.cocci. Signed-off-by: Rene Scharfe --- builtin/blame.c | 4 ++-- builtin/merge-index.c | 2 +- builtin/rev-list.c| 2 +- diff.c| 2 +- 4 files changed, 5 insertions(+), 5 deletions(-) diff

[PATCH] checkout: convert post_checkout_hook() to struct object_id

2017-01-28 Thread René Scharfe
Signed-off-by: Rene Scharfe --- builtin/checkout.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/builtin/checkout.c b/builtin/checkout.c index bfe685c198..80d5e38981 100644 --- a/builtin/checkout.c +++ b/builtin/checkout.c @@ -56,8 +56,8 @@ static int

[PATCH] use oidcpy() for copying hashes between instances of struct object_id

2017-01-28 Thread René Scharfe
Patch generated by Coccinelle and contrib/coccinelle/object_id.cocci. Signed-off-by: Rene Scharfe --- refs/files-backend.c | 2 +- wt-status.c | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/refs/files-backend.c b/refs/files-backend.c index

[PATCH 5/5] graph: use SWAP macro

2017-01-28 Thread René Scharfe
Exchange the values of graph->columns and graph->new_columns using the macro SWAP instead of hand-rolled code. The result is shorter and easier to read. This transformation was not done by the semantic patch swap.cocci because there's an unrelated statement between the second and the last step

[PATCH 4/5] diff: use SWAP macro

2017-01-28 Thread René Scharfe
Use the macro SWAP to exchange the value of pairs of variables instead of swapping them manually with the help of a temporary variable. The resulting code is shorter and easier to read. The two cases were not transformed by the semantic patch swap.cocci because it's extra careful and handles

[PATCH 3/5] use SWAP macro

2017-01-28 Thread René Scharfe
Apply the semantic patch swap.cocci to convert hand-rolled swaps to use the macro SWAP. The resulting code is shorter and easier to read, the object code is effectively unchanged. The patch for object.c had to be hand-edited in order to preserve the comment before the change; Coccinelle tried to

[PATCH 2/5] apply: use SWAP macro

2017-01-28 Thread René Scharfe
Use the exported macro SWAP instead of the file-scoped macro swap and remove the latter's definition. Signed-off-by: Rene Scharfe --- apply.c | 23 +++ 1 file changed, 7 insertions(+), 16 deletions(-) diff --git a/apply.c b/apply.c index 2ed808d429..0e2caeab9c

[PATCH 1/5] add SWAP macro

2017-01-28 Thread René Scharfe
Add a macro for exchanging the values of variables. It allows users to avoid repetition and takes care of the temporary variable for them. It also makes sure that the storage sizes of its two parameters are the same. Its memcpy(1) calls are optimized away by current compilers. Also add a

[PATCH 0/5] introduce SWAP macro

2017-01-28 Thread René Scharfe
Exchanging the value of two variables requires declaring a temporary variable and repeating their names. The swap macro in apply.c simplifies this for its callers without changing the compiled binary. Polish this macro and export it, then use it throughout the code to reduce repetition and hide

[PATCH] merge-recursive: make "CONFLICT (rename/delete)" message show both paths

2017-01-28 Thread Matt McCutchen
The current message printed by "git merge-recursive" for a rename/delete conflict is like this: CONFLICT (rename/delete): new-path deleted in HEAD and renamed in other-branch. Version other-branch of new-path left in tree. To be more helpful, the message should show both paths of the rename and

[PATCH] t0001: don't let a default ACL interfere with the umask test

2017-01-28 Thread Matt McCutchen
The "init creates a new deep directory (umask vs. shared)" test expects the permissions of newly created files to be based on the umask, which fails if a default ACL is inherited from the working tree for git. So attempt to remove a default ACL if there is one. Same idea as

Re: [PATCH 1/3] Documentation/stash: remove mention of git reset --hard

2017-01-28 Thread Thomas Gummerer
On 01/25, Junio C Hamano wrote: > Jeff King writes: > > > On Sat, Jan 21, 2017 at 08:08:02PM +, Thomas Gummerer wrote: > > > >> diff --git a/Documentation/git-stash.txt b/Documentation/git-stash.txt > >> index 2e9cef06e6..0ad5335a3e 100644 > >> ---

Re: show all merge conflicts

2017-01-28 Thread Jeff King
On Fri, Jan 27, 2017 at 09:42:41PM -0800, G. Sylvie Davies wrote: > Aside from the usual "git log -cc", I think this should work (replace > HEAD with whichever commit you are analyzing): > > git diff --name-only HEAD^2...HEAD^1 > m1 > git diff --name-only HEAD^1...HEAD^2 > b1 > git diff

INFO

2017-01-28 Thread THANDI ROBERT
Hello my name is Ms. Thandi Robert, from Ivory Coast. My parents were brutally mulled by the former president Laurent Gbagbo because of political crisis as the only survival of my family. I got your email while searching for a reliable personality in my private study on the internet. I am in

Re: show all merge conflicts

2017-01-28 Thread Philip Oakley
From: "G. Sylvie Davies" On Fri, Jan 27, 2017 at 9:51 AM, Jeff King wrote: On Fri, Jan 27, 2017 at 11:56:08AM -0500, Michael Spiegel wrote: I'm trying to determine whether a merge required a conflict to resolve after the merge has occurred. The git

Hopefully

2017-01-28 Thread Rita Micheal
Dear friend, My name is Mr Rita Micheal, I am the Bill and Exchange (assistant) Manager of Bank of Africa Ouagadougou, Burkina Faso. In my department I discovered an abandoned sum of teen million five hundred thousand United State of American dollars (10.5MILLION USA DOLLARS) in an account that