[gwt-contrib] Re: Make ServletValidator not use Jetty (issue284801)

2010-03-30 Thread t . broyer
Looks like it'd also fix issue 4462 http://code.google.com/p/google-web-toolkit/issues/detail?id=4462 (just to make sure it'll be marked fixed at the same time in the issue tracker) http://gwt-code-reviews.appspot.com/284801/diff/1/2 File dev/core/src/com/google/gwt/dev/ServletValidator.java

[gwt-contrib] Re: Removes the completely spurious generatedResource directory. (issue289801)

2010-03-30 Thread jat
Mostly LGTM. http://gwt-code-reviews.appspot.com/289801/diff/1/6 File dev/core/src/com/google/gwt/dev/DevModeBase.java (left): http://gwt-code-reviews.appspot.com/289801/diff/1/6#oldcode444 dev/core/src/com/google/gwt/dev/DevModeBase.java:444: File getShellBaseWorkDir(ModuleDef moduleDef);

[gwt-contrib] Re: Removes the completely spurious generatedResource directory. (issue289801)

2010-03-30 Thread scottb
http://gwt-code-reviews.appspot.com/289801/diff/1/6 File dev/core/src/com/google/gwt/dev/DevModeBase.java (left): http://gwt-code-reviews.appspot.com/289801/diff/1/6#oldcode444 dev/core/src/com/google/gwt/dev/DevModeBase.java:444: File getShellBaseWorkDir(ModuleDef moduleDef); Not sure.. this

[gwt-contrib] Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-30 Thread rchandia
Reviewers: fabbott, Dan Rice, Description: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. Please review this at http://gwt-code-reviews.appspot.com/291801/show Affected files: M bikeshed/src/com/google/gwt/collections/Assertions.java A

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-30 Thread rice
LGTM http://gwt-code-reviews.appspot.com/291801/diff/1/6 File bikeshed/src/com/google/gwt/collections/MutableArray.java (right): http://gwt-code-reviews.appspot.com/291801/diff/1/6#newcode49 bikeshed/src/com/google/gwt/collections/MutableArray.java:49: * Creates and immutable array based on

[gwt-contrib] Re: Implements a reduced scope ValueStore. It's responsible for posting change events (issue290801)

2010-03-30 Thread rjrjr
Desk review notes: Add version (Comparable) to valueskey, get it over the wire. Surely we'll need it. No change events from ValueStoreJsonImpl#setValues. They should be a CRUD side effect only. Or maybe not on new during a get, only on change during a get? Try to make EntityListPresenter not tied

[gwt-contrib] Re: BinaryEmittedArtifact now forces subclasses to implement getLastModified. (issue288801)

2010-03-30 Thread spoon
LGTM. Those are both good catches. http://gwt-code-reviews.appspot.com/288801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email with the

[gwt-contrib] Re: Make ServletValidator not use Jetty (issue284801)

2010-03-30 Thread bobv
LGTM, echoing tbroyer's comment about the main() method. Any reason you didn't re-use the reflective parser with a Schema that ignores unknown elements? http://gwt-code-reviews.appspot.com/284801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this

[gwt-contrib] Re: Removes the completely spurious generatedResource directory. (issue289801)

2010-03-30 Thread bobv
LGTM. http://gwt-code-reviews.appspot.com/289801/diff/1/10 File dev/core/src/com/google/gwt/dev/javac/StandardGeneratorContext.java (right): http://gwt-code-reviews.appspot.com/289801/diff/1/10#newcode240 dev/core/src/com/google/gwt/dev/javac/StandardGeneratorContext.java:240: private final

[gwt-contrib] Re: Make ServletValidator not use Jetty (issue284801)

2010-03-30 Thread scottb
Well that's a kick in the pants. Duh. Yes, of course I should have just used Schema. Do you think it's worth a re-do? http://gwt-code-reviews.appspot.com/284801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to

[gwt-contrib] Re: Make ServletValidator not use Jetty (issue284801)

2010-03-30 Thread bobv
It's not a critical component of the serving infrastructure, but maybe add a comment that any future changes should probably be re-implemented with a Schema. http://gwt-code-reviews.appspot.com/284801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-30 Thread rchandia
http://gwt-code-reviews.appspot.com/291801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email with the words REMOVE ME as the subject.

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-30 Thread rchandia
http://gwt-code-reviews.appspot.com/291801/diff/1/6 File bikeshed/src/com/google/gwt/collections/MutableArray.java (right): http://gwt-code-reviews.appspot.com/291801/diff/1/6#newcode49 bikeshed/src/com/google/gwt/collections/MutableArray.java:49: * Creates and immutable array based on this one

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-30 Thread rice
http://gwt-code-reviews.appspot.com/291801/diff/1/6 File bikeshed/src/com/google/gwt/collections/MutableArray.java (right): http://gwt-code-reviews.appspot.com/291801/diff/1/6#newcode97 bikeshed/src/com/google/gwt/collections/MutableArray.java:97: E[] newElems = (E[]) new Object[oldLen + 1];

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-30 Thread rchandia
http://gwt-code-reviews.appspot.com/291801/diff/1/6 File bikeshed/src/com/google/gwt/collections/MutableArray.java (right): http://gwt-code-reviews.appspot.com/291801/diff/1/6#newcode97 bikeshed/src/com/google/gwt/collections/MutableArray.java:97: E[] newElems = (E[]) new Object[oldLen + 1]; On

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-30 Thread fabbott
The biggie is MutableArray.java:60 http://gwt-code-reviews.appspot.com/291801/diff/4001/5003 File bikeshed/src/com/google/gwt/collections/ImmutableArrayEmptyImpl.java (right): http://gwt-code-reviews.appspot.com/291801/diff/4001/5003#newcode27

[gwt-contrib] Re: Remove JDK 1.6-isms; fix a checkstyle warning (issue281801)

2010-03-30 Thread דניאל רייס
FYI this still needs review for the changes in IFrameLinker (checkstyle) and PrecompressLinkerTest (removing use of String.getBytes(Charset)). Dan On Mon, Mar 29, 2010 at 12:29 PM, r...@google.com wrote: Reviewers: Lex, Description: Remove JDK 1.6-isms; fix a checkstyle warning Please

[gwt-contrib] Re: Remove JDK 1.6-isms; fix a checkstyle warning (issue281801)

2010-03-30 Thread rice
http://gwt-code-reviews.appspot.com/281801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email with the words REMOVE ME as the subject.

[gwt-contrib] Re: Remove JDK 1.6-isms; fix a checkstyle warning (issue281801)

2010-03-30 Thread spoon
LGTM. I didn't realize Charset was 1.6-only. http://gwt-code-reviews.appspot.com/281801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe from this group, send email to google-web-toolkit-contributors+unsubscribegooglegroups.com or reply to this email

[gwt-contrib] Specify a default eclipse import order for unknown packages. (issue281802)

2010-03-30 Thread scottb
Reviewers: jlabanca, Please review this at http://gwt-code-reviews.appspot.com/281802/show Affected files: M eclipse/settings/code-style/gwt.importorder Index: eclipse/settings/code-style/gwt.importorder diff --git a/eclipse/settings/code-style/gwt.importorder

[gwt-contrib] Re: Specify a default eclipse import order for unknown packages. (issue281802)

2010-03-30 Thread scottb
http://gwt-code-reviews.appspot.com/281802/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe, reply using remove me as the subject.

[gwt-contrib] [google-web-toolkit] r7815 committed - Add a test for RPC requests that lack the GWT permutation header....

2010-03-30 Thread codesite-noreply
Revision: 7815 Author: b...@google.com Date: Mon Mar 29 09:57:02 2010 Log: Add a test for RPC requests that lack the GWT permutation header. Patch by: bobv Review by: rjrjr http://code.google.com/p/google-web-toolkit/source/detail?r=7815 Modified:

[gwt-contrib] [google-web-toolkit] r7817 committed - The servlet now reads the enum name from a properties file. Thus, the ...

2010-03-30 Thread codesite-noreply
Revision: 7817 Author: amitman...@google.com Date: Mon Mar 29 14:11:08 2010 Log: The servlet now reads the enum name from a properties file. Thus, the servlet portion responsible for all READ operations is a stock servlet. Patch by: amitmanjhi Review by: rjrjr (desk review) Review at

[gwt-contrib] [google-web-toolkit] r7818 committed - BinaryEmittedArtifact now forces subclasses to implement getLastModifi...

2010-03-30 Thread codesite-noreply
Revision: 7818 Author: sco...@google.com Date: Tue Mar 30 09:00:46 2010 Log: BinaryEmittedArtifact now forces subclasses to implement getLastModified. Review by: sp...@google.com http://code.google.com/p/google-web-toolkit/source/detail?r=7818 Modified:

[gwt-contrib] [google-web-toolkit] r7819 committed - Removes the completely spurious generatedResource directory....

2010-03-30 Thread codesite-noreply
Revision: 7819 Author: sco...@google.com Date: Tue Mar 30 09:15:42 2010 Log: Removes the completely spurious generatedResource directory. The generatedResource directory was an artifact of earlier times. We were literally writing generated resources out to temporary files, just so we could

[gwt-contrib] [google-web-toolkit] r7820 committed - Fixes 1.5-unhappy @Override on interface...

2010-03-30 Thread codesite-noreply
Revision: 7820 Author: sco...@google.com Date: Tue Mar 30 09:43:00 2010 Log: Fixes 1.5-unhappy @Override on interface Review by: r...@google.com http://code.google.com/p/google-web-toolkit/source/detail?r=7820 Modified:

[gwt-contrib] [google-web-toolkit] r7821 committed - Work on selection model in Bikeshed and fix some checkstyle stuff whil...

2010-03-30 Thread codesite-noreply
Revision: 7821 Author: r...@google.com Date: Tue Mar 30 11:18:39 2010 Log: Work on selection model in Bikeshed and fix some checkstyle stuff while we're at it. http://code.google.com/p/google-web-toolkit/source/detail?r=7821 Modified:

[gwt-contrib] Re: Implements a reduced scope ValueStore. It's responsible for posting change events (issue290801)

2010-03-30 Thread rjrjr
Patch updated: On Tue, Mar 30, 2010 at 10:33 AM, rj...@google.com wrote: Desk review notes: Add version (Comparable) to valueskey, get it over the wire. Surely we'll need it. Done   No change events from ValueStoreJsonImpl#setValues. They should be a CRUD side effect only. Or maybe not on

[gwt-contrib] [google-web-toolkit] r7822 committed - Checkstyle fixes.

2010-03-30 Thread codesite-noreply
Revision: 7822 Author: r...@google.com Date: Tue Mar 30 11:21:53 2010 Log: Checkstyle fixes. http://code.google.com/p/google-web-toolkit/source/detail?r=7822 Modified: /trunk/bikeshed/test/com/google/gwt/collections/ObjectArrayTest.java === ---

[gwt-contrib] [google-web-toolkit] r7823 committed - Make ServletValidator not use Jetty....

2010-03-30 Thread codesite-noreply
Revision: 7823 Author: sco...@google.com Date: Tue Mar 30 12:00:11 2010 Log: Make ServletValidator not use Jetty. Jetty's just been too flaky, since this is only for user guidance, just use a loose parser. http://gwt-code-reviews.appspot.com/284801/show Fixes: 4760 Review by:

[gwt-contrib] [google-web-toolkit] r7824 committed - SelectionScriptLinker was setting the wrong timestamp on...

2010-03-30 Thread codesite-noreply
Revision: 7824 Author: sp...@google.com Date: Tue Mar 30 12:06:35 2010 Log: SelectionScriptLinker was setting the wrong timestamp on the generated selection script when used in production mode. It mistakenly thought it was in dev mode. Review at http://gwt-code-reviews.appspot.com/287801 Review

[gwt-contrib] [google-web-toolkit] r7825 committed - Fix java 1.6ism

2010-03-30 Thread codesite-noreply
Revision: 7825 Author: rj...@google.com Date: Tue Mar 30 16:26:30 2010 Log: Fix java 1.6ism http://code.google.com/p/google-web-toolkit/source/detail?r=7825 Modified: /trunk/user/test/com/google/gwt/uibinder/rebind/DomCursorTest.java === ---

[gwt-contrib] Re: Specify a default eclipse import order for unknown packages. (issue281802)

2010-03-30 Thread jlabanca
LGTM Just to make sure I understand, you added the following: 14=\# 15= which specifies the import order for all other packages not mentioned in 0-13? So foo.bar.baz now appears at the end of the imports. http://gwt-code-reviews.appspot.com/281802/show --

[gwt-contrib] [google-web-toolkit] r7827 committed - Create a change branch for code server protocol work.

2010-03-30 Thread codesite-noreply
Revision: 7827 Author: j...@google.com Date: Tue Mar 30 21:24:27 2010 Log: Create a change branch for code server protocol work. http://code.google.com/p/google-web-toolkit/source/detail?r=7827 Added: /changes/jat/csproto -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To