[gwt-contrib] Re: LayoutImplIE6 and onResize()

2010-03-31 Thread jd
Does anyone think this is a bug? Or is it expected behaviour? On Mar 23, 10:40 pm, jd jdpatter...@gmail.com wrote: Something else related to this problem:  when a DockLayoutPanel is animated to resize its children, onResize() is called *before* the resize but my child component was expecting

[gwt-contrib] Re: Comment on DomEventsAndMemoryLeaks in google-web-toolkit

2010-03-31 Thread codesite-noreply
Comment by atul.dambalkar: We also have quite a big GWT based application. In our application, we have also seen similar memory issues showing up in FireFox3.6, IE and Chrome4.1 as well. Browsers eventually stopped responding (with CPU more than 70%) after memory reaching up to 1GB

[gwt-contrib] Re: Comment on DomEventsAndMemoryLeaks in google-web-toolkit

2010-03-31 Thread codesite-noreply
Comment by j...@google.com: I'm not aware of any way on most browsers to force a GC. On IE, there's the global CollectGarbage() function, but IE already runs GC too frequently most of the time anyway, so it's not much help. I'm less familiar with Firefox and Safari, but Chrome's GC is

Re: [gwt-contrib] DockLayoutPanel addLayoutCompleteHandler

2010-03-31 Thread Joel Webber
I was hoping that because most people (not using the Maps API) wouldn't need this, it wouldn't be necessary to provide a special case for layout complete outside of the existing animation callbacks. Does it not work to put the Map in a RequiresResize container and call its layout method when

Re: [gwt-contrib] Re: LayoutImplIE6 and onResize()

2010-03-31 Thread Joel Webber
John, Sorry for the slow response -- I've had a browser window open for several days to respond, but I keep getting pulled off onto other things. It sounds like this is indeed an ordering bug. It's hard to be sure precisely when IE's going to call onresize() (onmove() and onresize() are obscure

Re: [gwt-contrib] TabLayoutPanel suggestion: Add tab-position property

2010-03-31 Thread Joel Webber
On Wed, Mar 24, 2010 at 1:01 PM, dflorey daniel.flo...@gmail.com wrote: I've been missing that one as well. I can provide patches if desired. -- On Wed, Mar 24, 2010 at 11:40 AM, dflorey daniel.flo...@gmail.com wrote: I just needed a TabLayoutPanel with Tabs on the bottom instead of tabs

Re: [gwt-contrib] Re: LayoutImplIE6 and onResize()

2010-03-31 Thread John Patterson
On 31 Mar 2010, at 18:59, Joel Webber wrote: John, Sorry for the slow response -- I've had a browser window open for several days to respond, but I keep getting pulled off onto other things. Ha ha! I know exactly how it is. It sounds like this is indeed an ordering bug. It's hard to

[gwt-contrib] Re: Specify a default eclipse import order for unknown packages. (issue281802)

2010-03-31 Thread Scott Blum
Exactly. Thanks. On Tue, Mar 30, 2010 at 10:51 PM, jlaba...@google.com wrote: LGTM Just to make sure I understand, you added the following: 14=\# 15= which specifies the import order for all other packages not mentioned in 0-13? So foo.bar.baz now appears at the end of the imports.

[gwt-contrib] Re: Remove JDK 1.6-isms; fix a checkstyle warning (issue281801)

2010-03-31 Thread rice
On 2010/03/30 21:40:48, Lex wrote: LGTM. I didn't realize Charset was 1.6-only. It has Charset but not String.getBytes(Charset). http://gwt-code-reviews.appspot.com/281801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe, reply using remove me as the

[gwt-contrib] Fixes a list subset error in AbstractListModel that was breaking paging. (issue293801)

2010-03-31 Thread jgw
Reviewers: ruce_google.com, Description: Fixes a list subset error in AbstractListModel that was breaking paging. Changes ListListModel's deferred command to be more careful about clearing its pending state (so that an exception won't break it permanently). Please review this at

[gwt-contrib] RR : Allow Void-parameterized types to work with GWT RPC (issue294801)

2010-03-31 Thread bobv
Reviewers: Dan Rice, Message: Review requested. Description: GWT RPC doesn't conside GenericTypeVoid to be serializable because it doesn't think that Void is serializable. Please review this at http://gwt-code-reviews.appspot.com/294801/show Affected files: A

[gwt-contrib] [google-web-toolkit] r7828 committed - Initial implementation of Linux-specific Shm+Futex implementation in C...

2010-03-31 Thread codesite-noreply
Revision: 7828 Author: j...@google.com Date: Wed Mar 31 09:29:51 2010 Log: Initial implementation of Linux-specific Shm+Futex implementation in C++. TODO: register Futexes for kernel cleanup on unclean shutdown. http://code.google.com/p/google-web-toolkit/source/detail?r=7828 Added:

Re: [gwt-contrib] RR : Allow Void-parameterized types to work with GWT RPC (issue294801)

2010-03-31 Thread Scott Blum
Could you please explain this? I would assert that GenericTypeVoid should be serializable if and only if it contains no fields of type T, where T is substituted for void. Do you disagree with this assertion, or is there a shortcoming in the current implementation that makes the assertion fail to

Re: [gwt-contrib] RR : Allow Void-parameterized types to work with GWT RPC (issue294801)

2010-03-31 Thread Ray Ryan
I don't follow your assertion, scott. I'm pretty sure that null is the only legal value for a Void field, so what's the big deal about serializing it? On Wed, Mar 31, 2010 at 9:40 AM, Scott Blum sco...@google.com wrote: Could you please explain this?  I would assert that GenericTypeVoid should

[gwt-contrib] [google-web-toolkit] r7829 committed - Run more cycles to get more consistent timing in test, spin longer whi...

2010-03-31 Thread codesite-noreply
Revision: 7829 Author: j...@google.com Date: Wed Mar 31 09:44:49 2010 Log: Run more cycles to get more consistent timing in test, spin longer while waiting for a lock (need to revisit when it is hooked into the real protocol where more work is being done between messages), move spin loop into

Re: [gwt-contrib] RR : Allow Void-parameterized types to work with GWT RPC (issue294801)

2010-03-31 Thread BobV
On Wed, Mar 31, 2010 at 12:42 PM, Ray Ryan rj...@google.com wrote: I don't follow your assertion, scott. I'm pretty sure that null is the only legal value for a Void field, so what's the big deal about serializing it? null is the only value. This supports a command-style use case where you

Re: [gwt-contrib] RR : Allow Void-parameterized types to work with GWT RPC (issue294801)

2010-03-31 Thread Scott Blum
Oh, I get your point now. Sorry. On Wed, Mar 31, 2010 at 12:42 PM, Ray Ryan rj...@google.com wrote: I don't follow your assertion, scott. I'm pretty sure that null is the only legal value for a Void field, so what's the big deal about serializing it? On Wed, Mar 31, 2010 at 9:40 AM, Scott

[gwt-contrib] Reusing com.google.gwt.uibinder.rebind.PrintWriterManager?

2010-03-31 Thread Ray Ryan
I found com.google.gwt.uibinder.rebind.PrintWriterManager very handy for UiBinderGenerator, where one template leads to the creation of a whole family of source files. And I'm about to find it handy again as I write RequestFactoryGenerator in bikeshed. Shall I move it to

[gwt-contrib] [google-web-toolkit] r7830 committed - Add timeout support.

2010-03-31 Thread codesite-noreply
Revision: 7830 Author: j...@google.com Date: Wed Mar 31 10:18:10 2010 Log: Add timeout support. http://code.google.com/p/google-web-toolkit/source/detail?r=7830 Modified: /changes/jat/csproto/plugins/platform/Linux/Futex.cpp /changes/jat/csproto/plugins/platform/Linux/Futex.h

[gwt-contrib] Selenium.start() can block indefinitely (issue296801)

2010-03-31 Thread jlabanca
Reviewers: rdayal, Description: Selenium.start() can block indefinitely if the Selenium RC cannot successfully start an instance of the browser, such as when an unexpected popup appears. This has annoying results for RunStyleSelenium. First, we were calling Selenium.start() inside of the

[gwt-contrib] Re: Reusing com.google.gwt.uibinder.rebind.PrintWriterManager?

2010-03-31 Thread Scott Blum
Well, it looks like the bar for getting code into that package is pretty low, based on the existing classes there. :) But more seriously, this class appears to do three useful things, so let me comment on them in turn: 1) Remember a package name, genCtx, and logger so you don't have to keep

[gwt-contrib] [google-web-toolkit] r7831 committed - Measure and tweak spinlock times, add some of the work to support kern...

2010-03-31 Thread codesite-noreply
Revision: 7831 Author: j...@google.com Date: Wed Mar 31 12:05:41 2010 Log: Measure and tweak spinlock times, add some of the work to support kernel cleanup of futexes, restructure lock loop for better performance. http://code.google.com/p/google-web-toolkit/source/detail?r=7831 Modified:

[gwt-contrib] Updated translations for Showcase (issue297801)

2010-03-31 Thread jlabanca
Reviewers: jat, Description: We got some updated translations for Showcase. I verified that Showcase runs correctly, and that comma-delimited lists have the correct English comma. Please review this at http://gwt-code-reviews.appspot.com/297801/show Affected files:

[gwt-contrib] Re: Updated translations for Showcase (issue297801)

2010-03-31 Thread jat
LGTM with one caveat. http://gwt-code-reviews.appspot.com/297801/diff/1/3 File samples/showcase/src/com/google/gwt/sample/showcase/client/ShowcaseConstants_fr.properties (right): http://gwt-code-reviews.appspot.com/297801/diff/1/3#newcode29

[gwt-contrib] Re: Updated translations for Showcase (issue297801)

2010-03-31 Thread jlabanca
The strings look correct when running the sample. I made sure the files were UTF8 encoded before editing them. http://gwt-code-reviews.appspot.com/297801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe, reply using remove me as the subject.

[gwt-contrib] Use PagingTableListView in TableEntityListView (issue298801)

2010-03-31 Thread rice
Reviewers: Ray Ryan, Description: Use PagingTableListView in TableEntityListView Work on Mail sample app, remove index param from Column.getValue() Review by: rj...@google.com Please review this at http://gwt-code-reviews.appspot.com/298801/show Affected files: M

[gwt-contrib] Re: Use PagingTableListView in TableEntityListView (issue298801)

2010-03-31 Thread Ray Ryan
LGTM -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe, reply using remove me as the subject.

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-31 Thread rchandia
http://gwt-code-reviews.appspot.com/291801/show -- http://groups.google.com/group/Google-Web-Toolkit-Contributors To unsubscribe, reply using remove me as the subject.

[gwt-contrib] Re: Unicode support for Character.is* methods

2010-03-31 Thread Pascal Muetschard
I have uploaded another patch set to http://gwt-code-reviews.appspot.com/226801 to address the concerns raised. See inline messages below. This latest version has an ASCII only option for the is*() methods witch has an overhead of a couple hundred bytes. See below for the size penalties for the

[gwt-contrib] Re: Lightweight collections. ImmutableArray and MutableArray.freeze() implementation. (issue291801)

2010-03-31 Thread rchandia
http://gwt-code-reviews.appspot.com/291801/diff/4001/5003 File bikeshed/src/com/google/gwt/collections/ImmutableArrayEmptyImpl.java (right): http://gwt-code-reviews.appspot.com/291801/diff/4001/5003#newcode27 bikeshed/src/com/google/gwt/collections/ImmutableArrayEmptyImpl.java:27:

[gwt-contrib] [google-web-toolkit] r7832 committed - Add timings, separate detach from destructor.

2010-03-31 Thread codesite-noreply
Revision: 7832 Author: j...@google.com Date: Wed Mar 31 17:07:40 2010 Log: Add timings, separate detach from destructor. http://code.google.com/p/google-web-toolkit/source/detail?r=7832 Modified: /changes/jat/csproto/plugins/platform/Linux/Futex.cpp

[gwt-contrib] [google-web-toolkit] r7834 committed - Initial work on adding pluggable transports on the Java side, adding...

2010-03-31 Thread codesite-noreply
Revision: 7834 Author: j...@google.com Date: Wed Mar 31 20:30:31 2010 Log: Initial work on adding pluggable transports on the Java side, adding prebuilt binaries for Linux JNI code, build changes. http://code.google.com/p/google-web-toolkit/source/detail?r=7834 Added: