[PATCH] dynamic cache allocation

2009-03-07 Thread phcoder
Hello. Discussing with Robert Millan and Bean on IRC we noticed that disk cache index is statically allocated. Here is a proposal to change it to dynamic allocation proportional to the size of available memory. -- Regards Vladimir 'phcoder' Serbinenko Index: kern/disk.c

Re: [PATCH 0/10]: Respin of sparc patches.

2009-03-07 Thread Vincent Pelletier
Le Saturday 07 March 2009 11:37:36 Robert Millan, vous avez écrit : > I'm not sure how many of us are experienced with sparc (Vincent? Who > else?). I wouldn't call me experienced, except if it only means that I did experimentation with that arch :) . > I'm very interested to see proper sparc s

Re: [Design] nested partitions: Unify grub_partition and grub_disk

2009-03-07 Thread phcoder
Bean wrote: Hi, Hello. I was looking into nested partitions issue and propose to unify grub_partition and grub_disk. In this case when a code calls grub_disk_read with a >grub_disk_t which represents a partition it will correct the offset and call grub_disk_read with underlying partition or

Re: [Design] nested partitions: Unify grub_partition and grub_disk

2009-03-07 Thread Bean
Hi, >Hello. I was looking into nested partitions issue and propose to unify >grub_partition and grub_disk. In this case when a code calls grub_disk_read >with a >grub_disk_t which represents a partition it will correct the offset >and call grub_disk_read with underlying partition or disk. In th

Re: [Design] nested partitions: Unify grub_partition and grub_disk

2009-03-07 Thread phcoder
I forgot to speak about another question: partition naming. I see 2 possibilities 1) purely numeric unified naming scheme. It means that (hd0,1,a) becomes (hd0,1,1) On one hand mixed number-letter scheme is similar to what freebsd uses but on the other hand numerical scheme is versatile and allo

Interrupt testing

2009-03-07 Thread phcoder
Hello. Here is a trivial patch for testing which interrupts are and which aren't handled by BIOS. Can be used as a simple but not reliable test for boot viruses -- Regards Vladimir 'phcoder' Serbinenko Index: conf/i386-pc.rmk ===

Re: [Design] nested partitions: Unify grub_partition and grub_disk

2009-03-07 Thread Robert Millan
On Sat, Mar 07, 2009 at 03:58:46PM +0100, phcoder wrote: > Hello. I was looking into nested partitions issue and propose to unify > grub_partition and grub_disk. In this case when a code calls > grub_disk_read with a grub_disk_t which represents a partition it will > correct the offset and ca

[Design] nested partitions: Unify grub_partition and grub_disk

2009-03-07 Thread phcoder
Hello. I was looking into nested partitions issue and propose to unify grub_partition and grub_disk. In this case when a code calls grub_disk_read with a grub_disk_t which represents a partition it will correct the offset and call grub_disk_read with underlying partition or disk. In this way no

Re: [PATCH 1/7]: Fix sparc64 setjmp implementation.

2009-03-07 Thread David Miller
From: Robert Millan Date: Sat, 7 Mar 2009 11:38:38 +0100 > On Sat, Mar 07, 2009 at 12:56:43AM -0500, Pavel Roskin wrote: > > Quoting David Miller : > > > >>> I was considering making grub_size_t long and grub_ssize_t unsigned > >>> long. I remember that it required many changes in string formats

Re: [PATCH 0/10]: Respin of sparc patches.

2009-03-07 Thread David Miller
From: Robert Millan Date: Sat, 7 Mar 2009 11:37:36 +0100 > On Fri, Mar 06, 2009 at 04:38:47PM -0800, David Miller wrote: > > I am able to boot into the GRUB kernel prompt on my test system, > > I have a lot of new code written, I'm _EXTREMELY_ motivated > > and want to get this all working fully

Re: [PATCH] make the generic Linux loader usable on i386-pc again

2009-03-07 Thread phcoder
Small word about xnu. It needs for norma booting just a quite big amount of contiguos memory anywhere below 4GiB. This is typically 64 MiB depending on the amount of loaded modules but can be much larger (e.g. if using ramdisk) In the case of resuming from hibernation it needs small amount at 0

Re: Parser

2009-03-07 Thread Marco Gerards
Kevin Lacquement writes: > Again looking at the script parser, I notices that it uses a > Yacc-generated parser, but a hand-written tokenizer. Is there a reason > that it doesn't use Lex? Is it due to external dependencies, and if so, > is there a way to recreate these deps (library or whatever)

Re: [PATCH] make the generic Linux loader usable on i386-pc again

2009-03-07 Thread Robert Millan
On Fri, Mar 06, 2009 at 10:02:28PM +0200, Vesa Jääskeläinen wrote: > Robert Millan wrote: > > This patch makes the generic Linux loader usable on i386-pc again. It > > doesn't seem like it's badly needed to spend a bit of time and a bit of > > code in adding low memory to the heap, and Vesa's work

Re: [PATCH 1/7]: Fix sparc64 setjmp implementation.

2009-03-07 Thread Robert Millan
On Fri, Mar 06, 2009 at 04:34:47PM -0800, David Miller wrote: > > > > I think we're already using longs this way in quite a few places. It's not > > such a big deal IMHO. > > And ironically enough, using "unsigned long" would allow us to > share this header with any future 32-bit sparc GRUB supp

Re: [PATCH 1/7]: Fix sparc64 setjmp implementation.

2009-03-07 Thread Robert Millan
On Sat, Mar 07, 2009 at 12:56:43AM -0500, Pavel Roskin wrote: > Quoting David Miller : > >>> I was considering making grub_size_t long and grub_ssize_t unsigned >>> long. I remember that it required many changes in string formats, so I >>> didn't feel it would be justified. But we could try it ag

Re: [PATCH 0/10]: Respin of sparc patches.

2009-03-07 Thread Robert Millan
On Fri, Mar 06, 2009 at 04:38:47PM -0800, David Miller wrote: > From: Robert Millan > Date: Fri, 6 Mar 2009 20:01:10 +0100 > > > In the future, please send followup patches in the same thread. It helps > > keeping track of things, which is quite hard for us to keep up with > > already.. > > Su