[PATCH] improve ssl guarding by switching to macro SSL_CLIENT_HELLO_CB instead of openssl version

2021-01-16 Thread Илья Шипицин
Hello, next openssl guarding patch Ilya From b5ff0a9f1e0d2edc84981b39050e7f21d2b08ba8 Mon Sep 17 00:00:00 2001 From: Ilya Shipitsin Date: Sat, 16 Jan 2021 23:15:12 +0500 Subject: [PATCH] BUILD: ssl: guard Client Hello callbacks with SSL_CLIENT_HELLO_CB macro instead of openssl version ---

[PATCH 3/3] CLEANUP: cache: Use proper data types in secondary_key_cmp()

2021-01-16 Thread Tim Duesterhus
- hash_length is `unsigned int` and so should offset. - idx is compared to a `size_t` and thus it should also be. --- src/cache.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/cache.c b/src/cache.c index 9e01de402..f1b64500b 100644 --- a/src/cache.c +++ b/src/cache.c

[PATCH 1/3] MINOR: cache: Remove the `hash` part of the accept-encoding secondary key

2021-01-16 Thread Tim Duesterhus
As of commit 6ca89162dc881df8fecd7713ca1fe5dbaa66b315 this hash no longer is required, because unknown encodings are not longer stored and known encodings do not use the cache. --- include/haproxy/http_ana-t.h | 2 +- src/cache.c | 80 2

[PATCH 2/3] CLEANUP: Rename accept_encoding_hash_cmp to accept_encoding_bitmap_cmp

2021-01-16 Thread Tim Duesterhus
For the `accept-encoding` header a bitmap and not a hash is stored. --- src/cache.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/src/cache.c b/src/cache.c index 965509871..9e01de402 100644 --- a/src/cache.c +++ b/src/cache.c @@ -97,7 +97,7 @@ struct