Re: [Haskell-cafe] ANN: logfloat

2008-08-16 Thread wren ng thornton
-- Announcing: logfloat 0.8.5 New official release of the logfloat package for manipulating log-domain floating numbers. This is primarily a maintenance release updating the documentation and with minor

Re: [Haskell-cafe] What's in a name?

2008-08-15 Thread wren ng thornton
Sean Leather wrote: That doesn't work if you want to use two packages that have modules sharing the same hierarchical name, and this is a definite possibility given my statements above. Of course, having the ability to import modules from specific packages [1] would fix this, but only as long

[Haskell-cafe] ANN: logfloat

2008-08-15 Thread wren ng thornton
-- Announcing: logfloat 0.8.2 I just released a new package, logfloat, for manipulating log-domain floating numbers. The main reason for casting numbers into the log-domain is to prevent underflow when

Re: [Haskell-cafe] ANN: logfloat

2008-08-15 Thread wren ng thornton
wren ng thornton wrote: -- Announcing: logfloat 0.8.2 [...] The code is very heavily documented, largely for pedagogical reasons. Since Haddock doesn't play very nicely with literate Haskell, there's

Re: [Haskell-cafe] ANN: logfloat

2008-08-15 Thread wren ng thornton
Felipe Lessa wrote: I should point out just in case that 1 / 0 isn't infinity on all Fractional types (e.g. Rational). I guess it shouldn't cause a problem with your library, but a warning on the Haddock entry would be nice to avoid surprising people who didn't see the internal implementation.

Re: [Haskell-cafe] What's in a name?

2008-08-15 Thread wren ng thornton
David Menendez wrote: On Fri, Aug 15, 2008 at 7:24 PM, wren ng thornton [EMAIL PROTECTED] wrote: (( For readers who don't want to slog through the rest of this post, the conclusion is that I feel an agile packaging system is an imperative, as discussed above. The trick is finding a way

Re: [Haskell-cafe] self-referential data

2008-08-09 Thread wren ng thornton
brian wrote: From https://secure.wikimedia.org/wikipedia/en/wiki/Bencoding , I think I should code data BValue = BString String | BIntegerInteger | BList [BValue] | BDictionary (M.Map BString BValue) but: Not in scope: type constructor or

Re: [Haskell-cafe] poll: how can we help you contribute to darcs?

2008-08-01 Thread wren ng thornton
Eric Kow wrote: Dear Haskellers, I would like to take an informal poll for the purposes of darcs recruitment. Could you please complete this sentence for me? I would contribute to darcs if only... The answers I am most interested in hearing go beyond ... I had more time. For instance, if

Re: [Haskell-cafe] Using fundeps to resolve polymorphic types to concrete types

2008-07-31 Thread wren ng thornton
Ryan Ingram wrote: Hmm, I'm kind of confused by this now. I feel like the following code really should compile, but it doesn't. There's no use of existentials to hide type information at all. The functional dependency seems like it should give us the constraint (b1 ~ b2) allowing Refl to

Re: [Haskell-cafe] Using fundeps to resolve polymorphic types to concrete types

2008-07-29 Thread wren ng thornton
Bryan Donlan wrote: Hi, Is there any theoretical reason that functional dependencies can't be used to resolve a polymorphic type to a concrete type? For example: -- compile with -fglasgow-exts class DeriveType a b | a - b data A = A data B = B instance DeriveType A B simpleNarrow ::

Re: [Haskell-cafe] Using fundeps to resolve polymorphic types to concrete types

2008-07-29 Thread wren ng thornton
Pablo Nogueira wrote: wren ng thornton wrote: It compiles just fine with (DeriveType A b = b - b) after all, which resolves directly to (B - B) That's not the case: simpleNarrow :: DeriveType A b = b - b simpleNarrow = id Couldn't match expected type `b' (a rigid variable

[Haskell-cafe] ANN: list-extras 0.2.0

2008-07-26 Thread wren ng thornton
hello all~ After some talks with Aditya Mahajan I've overhauled the Data.List.Extras.Argmax module so it's not quite so braindead. Since it breaks backwards compatibility so soon after the initial announcement, I figured it was worth a mention. I also changed the case of the module's name,

[Haskell-cafe] ANN: list-extras 0.1.0

2008-07-22 Thread wren ng thornton
hello all~ I'm pleased to announce the initial version of list-extras, a home for common not-so-common list functions. There are many simple but non-trivial functions for lists which Data.List lacks. Typically we write a version and include it in a larger project or store it in a local

Re: [Haskell-cafe] Human-friendly compiler errors for GHC

2008-07-12 Thread wren ng thornton
Max Bolingbroke wrote: Agreed: I've implemented this too. I've also added fuzzy matching to package search: $ stage2/ghc-inplace --make ../Test1.hs ../Test1.hs:3:7: Could not find module `Data.Lost': Use -v to see a list of the files searched for. Maybe you meant `Data.List'

Re: [Haskell-cafe] Qualified import syntax badly designed (?)

2008-07-08 Thread wren ng thornton
Quoth [EMAIL PROTECTED]: Quoth Neil Mitchell [EMAIL PROTECTED]: [...] Both of these require two imports, yet feel like they should require only one. It seems as though the import syntax more naturally promotes security (preventing access to some functions), rather than namespacing. I

Re: [Haskell-cafe] Portland OSCon

2008-07-07 Thread wren ng thornton
John Goerzen wrote: Hi, OSCon is happening in Portland, OR starting 2 weeks from today, with probably the largest number of people there on July 23 and 24. I know there are a number of Haskellers that live in the Portland area, and I suspect a few more may be going to OSCon. Anyone interested

Re: [Haskell-cafe] What's wrong with the classes/insances?

2008-06-20 Thread wren ng thornton
Pieter Laeremans wrote: HI, What 's wrong with this: [...] class Item a where getCatalog :: Catalog catalog = a - catalog This is a shorthand for class Item a where getCatalog :: forall c. (Catalog c) = a - c That is, the class provides the contract that given some value of

Re: [Haskell-cafe] Re: [Haskell] ANN: random-access-list-0.1

2008-06-13 Thread wren ng thornton
Isaac Dupree wrote: extractHead is an ugly name for a nevertheless standardish-meaning function... what is it usually called? uncons? headTail? (Data.Sequence, which is meant to be left-right symmetric, calls it viewr... except your version doesn't have the Maybe, it's partial instead, fails

<    6   7   8   9   10   11