Re: header file guards conflict

2012-05-21 Thread Hans Aberg
On 21 May 2012, at 18:34, Akim Demaille wrote: > Le 21 mai 2012 à 18:27, Hans Aberg a écrit : > >> On 21 May 2012, at 18:17, Akim Demaille wrote: >> >>> Le 21 mai 2012 à 17:55, Hans Aberg a écrit : >>> Is there any reason to not put all stuff that is public in the parser header? This

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 18:27, Hans Aberg a écrit : > On 21 May 2012, at 18:17, Akim Demaille wrote: > >> Le 21 mai 2012 à 17:55, Hans Aberg a écrit : >> >>> Is there any reason to not put all stuff that is public in the parser >>> header? This would eliminate the need for any additional header files

Re: header file guards conflict

2012-05-21 Thread Hans Aberg
On 21 May 2012, at 18:17, Akim Demaille wrote: > Le 21 mai 2012 à 17:55, Hans Aberg a écrit : > >> Is there any reason to not put all stuff that is public in the parser >> header? This would eliminate the need for any additional header files. > > That's the plan for those that need not be publi

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 17:55, Hans Aberg a écrit : > Is there any reason to not put all stuff that is public in the parser header? > This would eliminate the need for any additional header files. That's the plan for those that need not be public. location.hh is different: you may use it for your ASTs

RFC: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 14:56, Akim Demaille a écrit : > This is the patch that really computes the header guards. > >> From eb76fadde9c5a3b23dc6761ddd4d267a6e7c3965 Mon Sep 17 00:00:00 2001 > From: Akim Demaille > Date: Mon, 21 May 2012 14:21:51 +0200 > Subject: [PATCH 4/4] c++: compute the header gu

Re: header file guards conflict

2012-05-21 Thread Hans Aberg
On 21 May 2012, at 16:02, Akim Demaille wrote: > Le 21 mai 2012 à 15:41, Hans Aberg a écrit : > >> On 21 May 2012, at 11:34, Akim Demaille wrote: >> Is there a better way to do it? >>> >>> This is indeed a problem. I'm sure what the best way to >>> address this is. In addition, in some c

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 16:30, Stefano Lattarini a écrit : >> it's only NEWS. >> > Are you sure it is worth to convert also older NEWS entry to the new > quoting format? Yes, I prefer. That's just more consistent. > Personally, I'd use "" for sentences or quasi-sentences, and '' for > stuff like opt

Re: header file guards conflict

2012-05-21 Thread Stefano Lattarini
On 05/21/2012 04:00 PM, Akim Demaille wrote: > > Le 21 mai 2012 à 15:33, Stefano Lattarini a écrit : > >> Hi Akim. I'm really not knowledgeable enough to comment on this >> patch proper, but I have a nit about quotation usages ... >> >> On 05/21/2012 02:56 PM, Akim Demaille wrote: >>> >>> -** li

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 15:41, Hans Aberg a écrit : > On 21 May 2012, at 11:34, Akim Demaille wrote: > >>> Is there a better way to do it? >> >> This is indeed a problem. I'm sure what the best way to >> address this is. In addition, in some cases, creating the >> files location.hh, stack.hh etc. is

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 15:33, Stefano Lattarini a écrit : > Hi Akim. I'm really not knowledgeable enough to comment on this > patch proper, but I have a nit about quotation usages ... > > On 05/21/2012 02:56 PM, Akim Demaille wrote: >> >> -** liby is no longer asking for "rpl_fprintf" on some platfo

Re: header file guards conflict

2012-05-21 Thread Hans Aberg
On 21 May 2012, at 11:34, Akim Demaille wrote: >> Is there a better way to do it? > > This is indeed a problem. I'm sure what the best way to > address this is. In addition, in some cases, creating the > files location.hh, stack.hh etc. is more troublesome than > useful. Perhaps add infixes 'l

Re: header file guards conflict

2012-05-21 Thread Stefano Lattarini
Hi Akim. I'm really not knowledgeable enough to comment on this patch proper, but I have a nit about quotation usages ... On 05/21/2012 02:56 PM, Akim Demaille wrote: > > -** liby is no longer asking for "rpl_fprintf" on some platforms. > +** liby is no longer asking for `rpl_fprintf' on some pl

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 14:42, Akim Demaille a écrit : > lalr1.cc: extract stack.hh. > To make merging easier in master. > lalr1.cc: improve Doxygen documentation. > To include the prefix part in the \file directive. > skeletons: remove support for unused directive. > Something that should never have

Re: skeletons: remove support for unused directive (was: header file guards conflict)

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 14:42, Akim Demaille a écrit : > lalr1.cc: extract stack.hh. > To make merging easier in master. > lalr1.cc: improve Doxygen documentation. > To include the prefix part in the \file directive. > skeletons: remove support for unused directive. > Something that should never have

Re: lalr1.cc: improve Doxygen documentation (was: header file guards conflict)

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 14:42, Akim Demaille a écrit : > lalr1.cc: extract stack.hh. > To make merging easier in master. > lalr1.cc: improve Doxygen documentation. > To include the prefix part in the \file directive. > skeletons: remove support for unused directive. > Something that should never have

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 14:42, Akim Demaille a écrit : > lalr1.cc: extract stack.hh. > To make merging easier in master. > lalr1.cc: improve Doxygen documentation. > To include the prefix part in the \file directive. > skeletons: remove support for unused directive. > Something that should never have

Re: header file guards conflict

2012-05-21 Thread Wei Song
Thanks for the reply Akim. On 2012/5/21 10:34, Akim Demaille wrote: Currently we use BISON_LOCATION_HH (it is open-coded). One first idea would be to use the output file name, so if for instance you passed "-o lang1/parser.cc", the header would be BISON_LANG1_LOCATION_HH. Would that suffice in

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 21 mai 2012 à 11:34, Akim Demaille a écrit : > > Le 16 mai 2012 à 16:51, Wei Song a écrit : > >> Hi, > > Hi! > >> Just have used Bison for several months. >> >> I have two bison parsers in one project and for some reasons the header >> files of both parsers are included in one cpp code.

Re: header file guards conflict

2012-05-21 Thread Akim Demaille
Le 16 mai 2012 à 16:51, Wei Song a écrit : > Hi, Hi! > Just have used Bison for several months. > > I have two bison parsers in one project and for some reasons the header files > of both parsers are included in one cpp code. > Different namespace names are used, therefore, these two parsers