Re: [Intel-gfx] [Linaro-mm-sig] [PATCH 1/2] dma-buf: Require VM_PFNMAP vma for mmap

2021-02-23 Thread Intel
On 2/23/21 11:59 AM, Daniel Vetter wrote: tldr; DMA buffers aren't normal memory, expecting that you can use them like that (like calling get_user_pages works, or that they're accounting like any other normal memory) cannot be guaranteed. Since some userspace only runs on integrated devices, wh

Re: [Intel-gfx] [PATCH v2 6/7] drm/i915: rename DISP_STEPPING->DISPLAY_STEP and GT_STEPPING->GT_STEP

2021-02-23 Thread Lucas De Marchi
On Tue, Feb 23, 2021 at 05:35:11PM +0200, Jani Nikula wrote: Matter of taste. STEP matches the enums. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_display_power.c | 2 +- drivers/gpu/drm/i915/display/intel_psr.c | 4 ++-- drivers/gpu/drm/i915/display/skl_universal

Re: [Intel-gfx] [PATCH v2 1/7] drm/i915: remove unused ADLS_REVID_* macros

2021-02-23 Thread Lucas De Marchi
On Tue, Feb 23, 2021 at 05:35:06PM +0200, Jani Nikula wrote: It's the adls_revid_step_tbl array indexes that matter. Signed-off-by: Jani Nikula Reviewed-by: Lucas De Marchi Lucas De Marchi --- drivers/gpu/drm/i915/i915_drv.h | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/

Re: [Intel-gfx] [PATCH 06/12] drm/i915/bios: rename display_device_data to intel_bios_encoder_data

2021-02-23 Thread Lucas De Marchi
On Tue, Feb 23, 2021 at 02:50:30PM +0200, Jani Nikula wrote: On Wed, 17 Feb 2021, Jani Nikula wrote: On Wed, 17 Feb 2021, Lucas De Marchi wrote: On Wed, Feb 17, 2021 at 07:03:36PM +0200, Jani Nikula wrote: Make the naming suitable for exposing to the rest of the driver as an opaque type. No

Re: [Intel-gfx] [PATCH 04/12] drm/i915/bios: limit default outputs to ports A through F

2021-02-23 Thread Lucas De Marchi
On Tue, Feb 23, 2021 at 03:34:51PM +0200, Jani Nikula wrote: On Wed, 17 Feb 2021, Lucas De Marchi wrote: On Wed, Feb 17, 2021 at 09:49:57PM +0200, Jani Nikula wrote: On Wed, 17 Feb 2021, Lucas De Marchi wrote: On Wed, Feb 17, 2021 at 09:23:00AM -0800, Lucas De Marchi wrote: On Wed, Feb 17,

[Intel-gfx] [PATCH][next] drm/i915/hdcp: Fix null pointer dereference of connector->encoder

2021-02-23 Thread Colin King
From: Colin Ian King The recent commit 6c63e6e14da7 ("drm/i915/hdcp: No HDCP when encoder is't initialized") added a null pointer check on connector->encoder hence implying that it could potentially be null. This means that the initialization of dig_port via the call intel_attached_dig_port may

Re: [Intel-gfx] [PATCH v3] drm/i915/display: Do not allow DC3CO if PSR SF is enabled

2021-02-23 Thread Mun, Gwan-gyeong
On Tue, 2021-02-23 at 15:38 +0530, Gupta, Anshuman wrote: > > > > -Original Message- > > From: Mun, Gwan-gyeong > > Sent: Tuesday, February 23, 2021 3:00 AM > > To: intel-gfx@lists.freedesktop.org > > Cc: Gupta, Anshuman ; Souza, Jose > > > > Subject: [PATCH v3] drm/i915/display: Do not

Re: [Intel-gfx] ✓ Fi.CI.IGT: success for drm/i915/display: Do not allow DC3CO if PSR SF is enabled (rev4)

2021-02-23 Thread Souza, Jose
Patch pushed, GG will follow up with the proper fix together with Anushuman. On Tue, 2021-02-23 at 02:57 +, Patchwork wrote: Patch Details Series: drm/i915/display: Do not allow DC3CO if PSR SF is enabled (rev4) URL:https://patchwork.freedesktop.org/series/87283/ State: success Details:

Re: [Intel-gfx] [PATCH] drm/i915/tgl+: Sanitize the DDI LANES/IO and AUX power domain names

2021-02-23 Thread Souza, Jose
On Tue, 2021-02-23 at 16:51 +0200, Imre Deak wrote: > On Tue, Feb 23, 2021 at 03:56:12PM +0200, Souza, Jose wrote: > > On Mon, 2021-02-22 at 23:04 +0200, Imre Deak wrote: > > > In Bspec the TGL TypeC ports are TC1-6, the AUX power well request flags > > > are USBC1-6/TBT1-6, so for clarity use thes

[Intel-gfx] [PATCH v2 7/7] drm/i915: rename disp_stepping->display_step and gt_stepping->gt_step

2021-02-23 Thread Jani Nikula
Matter of taste. Step matches the enums. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/i915_drv.h | 4 +-- drivers/gpu/drm/i915/intel_stepping.c | 48 +-- drivers/gpu/drm/i915/intel_stepping.h | 4 +-- 3 files changed, 28 insertions(+), 28 deletions(-) diff

[Intel-gfx] [PATCH v2 6/7] drm/i915: rename DISP_STEPPING->DISPLAY_STEP and GT_STEPPING->GT_STEP

2021-02-23 Thread Jani Nikula
Matter of taste. STEP matches the enums. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_display_power.c | 2 +- drivers/gpu/drm/i915/display/intel_psr.c | 4 ++-- drivers/gpu/drm/i915/display/skl_universal_plane.c | 2 +- drivers/gpu/drm/i915/gt/intel_workarounds.

[Intel-gfx] [PATCH v2 5/7] drm/i915: switch TGL and ADL to the new stepping scheme

2021-02-23 Thread Jani Nikula
This changes the way revids not present in the array are handled: - For gaps in the array, the next present revid is used. - For revids beyond the array, the new STEP_FUTURE is used instead of the last revid in the array. In both cases, we'll get debug logging of what's going on. Signed-off-b

[Intel-gfx] [PATCH v2 4/7] drm/i915: switch KBL to the new stepping scheme

2021-02-23 Thread Jani Nikula
Add new symbolic names for revision ids, and convert KBL revids to use them via the new stepping check macros. This also fixes theoretical out of bounds access to kbl_revids array. Signed-off-by: Jani Nikula --- The initialization sounds like an early part of intel_device_info_runtime_init(),

[Intel-gfx] [PATCH v2 2/7] drm/i915: split out stepping info to a new file

2021-02-23 Thread Jani Nikula
gt/intel_workarounds.c is decidedly the wrong place for handling stepping info. Add new intel_stepping.[ch] for the data, and move the stepping arrays there. No functional changes. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/Makefile | 1 + drivers/gpu/drm/i915/gt/intel_wo

[Intel-gfx] [PATCH v2 3/7] drm/i915: add new helpers for accessing stepping info

2021-02-23 Thread Jani Nikula
Add new runtime info field for stepping. Add new helpers for accessing them. As we'll be switching platforms over to the new scheme incrementally, check for non-initialized steppings. In case a platform does not have separate display and gt steppings, it's okay to use a common shorthand. However,

[Intel-gfx] [PATCH v2 1/7] drm/i915: remove unused ADLS_REVID_* macros

2021-02-23 Thread Jani Nikula
It's the adls_revid_step_tbl array indexes that matter. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/i915_drv.h | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h index f8413b3b9da8..4b457a3c658f 100644 --- a/drivers/

[Intel-gfx] [PATCH v2 0/7] drm/i915: refactor KBL/TGL/ADLS stepping scheme

2021-02-23 Thread Jani Nikula
This cleans up the split display and gt stepping schemes in KBL/TGL/ADLS, and makes it easier to extend for future platforms. We could switch legacy platforms over too, but that would require arrays to convert to the symbolic step enums, for no real benefit, but with the drawback of having to main

Re: [Intel-gfx] [PATCH 2/2] drm/vgem: use shmem helpers

2021-02-23 Thread kernel test robot
Hi Daniel, I love your patch! Yet something to improve: [auto build test ERROR on drm-intel/for-linux-next] [also build test ERROR on drm-tip/drm-tip linus/master next-20210223] [cannot apply to tegra-drm/drm/tegra/for-next drm-exynos/exynos-drm-next drm/drm-next v5.11] [If your patch is

Re: [Intel-gfx] [PATCH RFC v1 5/6] xen-swiotlb: convert variables to arrays

2021-02-23 Thread Stefano Stabellini
On Fri, 19 Feb 2021, Konrad Rzeszutek Wilk wrote: > On Sun, Feb 07, 2021 at 04:56:01PM +0100, Christoph Hellwig wrote: > > On Thu, Feb 04, 2021 at 09:40:23AM +0100, Christoph Hellwig wrote: > > > So one thing that has been on my mind for a while: I'd really like > > > to kill the separate dma ops

Re: [Intel-gfx] [RFC PATCH 0/9] drm/i915/spi: discrete graphics internal spi

2021-02-23 Thread Richard Weinberger
- Ursprüngliche Mail - >> > I'm not sure whether we want to take that path. > > Hi Richard is there any way we can try to unclutter this ? Of course there is a way. :-) Your use-case really seems to be special and MTD needs an improvement. Miquel, Vignesh and I just need to check more int

Re: [Intel-gfx] [PATCH] drm/i915/tgl+: Sanitize the DDI LANES/IO and AUX power domain names

2021-02-23 Thread Imre Deak
On Tue, Feb 23, 2021 at 03:56:12PM +0200, Souza, Jose wrote: > On Mon, 2021-02-22 at 23:04 +0200, Imre Deak wrote: > > In Bspec the TGL TypeC ports are TC1-6, the AUX power well request flags > > are USBC1-6/TBT1-6, so for clarity use these names in the port power > > domain names instead of the D-

Re: [Intel-gfx] [PATCH 19/30] drm/dp: Pass drm_dp_aux to drm_dp_link_train_clock_recovery_delay()

2021-02-23 Thread Rodrigo Vivi
On Fri, Feb 19, 2021 at 04:53:15PM -0500, Lyude Paul wrote: > So that we can start using drm_dbg_*() in > drm_dp_link_train_clock_recovery_delay(). > > Signed-off-by: Lyude Paul I wonder if we could have a drm_dp so we encapsulate both aux and dpcd related information... But this one already so

Re: [Intel-gfx] [PULL] gvt-next-fixes

2021-02-23 Thread Rodrigo Vivi
On Mon, Feb 22, 2021 at 04:34:02PM +0800, Zhenyu Wang wrote: > > Hi, > > Looks last gvt pull missed -gt-next window before CNY holiday. > So here're left three changes for fixing ww locking, cmd parser > fix for i915 state use and one left cleanup fix. no problem at all. I believe we still have

Re: [Intel-gfx] [PATCH 2/2] drm/vgem: use shmem helpers

2021-02-23 Thread kernel test robot
Hi Daniel, I love your patch! Yet something to improve: [auto build test ERROR on drm-intel/for-linux-next] [also build test ERROR on drm-tip/drm-tip linus/master next-20210223] [cannot apply to drm/drm-next v5.11] [If your patch is applied to the wrong git tree, kindly drop us a note. And when

Re: [Intel-gfx] [PATCH] drm/i915/tgl+: Sanitize the DDI LANES/IO and AUX power domain names

2021-02-23 Thread Souza, Jose
On Mon, 2021-02-22 at 23:04 +0200, Imre Deak wrote: > In Bspec the TGL TypeC ports are TC1-6, the AUX power well request flags > are USBC1-6/TBT1-6, so for clarity use these names in the port power > domain names instead of the D-I terminology (which Bspec uses only for > the ICL TypeC ports). > >

Re: [Intel-gfx] [PATCH 04/12] drm/i915/bios: limit default outputs to ports A through F

2021-02-23 Thread Jani Nikula
On Wed, 17 Feb 2021, Lucas De Marchi wrote: > On Wed, Feb 17, 2021 at 09:49:57PM +0200, Jani Nikula wrote: >>On Wed, 17 Feb 2021, Lucas De Marchi wrote: >>> On Wed, Feb 17, 2021 at 09:23:00AM -0800, Lucas De Marchi wrote: On Wed, Feb 17, 2021 at 07:03:34PM +0200, Jani Nikula wrote: >With

[Intel-gfx] ✗ Fi.CI.BUILD: failure for DG2 audio support

2021-02-23 Thread Patchwork
== Series Details == Series: DG2 audio support URL : https://patchwork.freedesktop.org/series/87317/ State : failure == Summary == Applying: ALSA: hda: Add Intel DG2 PCI ID and HDMI codec vid error: sha1 information is lacking or useless (sound/pci/hda/hda_intel.c). error: could not build fake

[Intel-gfx] ✗ Fi.CI.BUILD: failure for series starting with [1/2] dma-buf: Require VM_PFNMAP vma for mmap (rev2)

2021-02-23 Thread Patchwork
== Series Details == Series: series starting with [1/2] dma-buf: Require VM_PFNMAP vma for mmap (rev2) URL : https://patchwork.freedesktop.org/series/87313/ State : failure == Summary == CALLscripts/checksyscalls.sh CALLscripts/atomic/check-atomics.sh DESCEND objtool CHK in

[Intel-gfx] [PATCH 1/1] ALSA: hda: Add Intel DG2 PCI ID and HDMI codec vid

2021-02-23 Thread Kai Vehmanen
Add HD Audio PCI ID and HDMI codec vendor ID for Intel DG2. Signed-off-by: Kai Vehmanen --- sound/pci/hda/hda_intel.c | 6 +- sound/pci/hda/patch_hdmi.c | 1 + 2 files changed, 6 insertions(+), 1 deletion(-) diff --git a/sound/pci/hda/hda_intel.c b/sound/pci/hda/hda_intel.c index 27e02cdef

[Intel-gfx] [REVIEW] Full tree diff against internal/internal

2021-02-23 Thread Kai Vehmanen
Auto-generated diff between internal/internal..internal --- sound/pci/hda/hda_intel.c | 6 +- sound/pci/hda/patch_hdmi.c | 1 + 2 files changed, 6 insertions(+), 1 deletion(-) diff --git a/sound/pci/hda/hda_intel.c b/sound/pci/hda/hda_intel.c index 27e02cdef6d9..8d3d7e700ca3 100644 --- a/sou

[Intel-gfx] [PATCH 0/1] DG2 audio support

2021-02-23 Thread Kai Vehmanen
Hey, small patch to add missing bits to enable audio with DG2. --- baseline: 24107b584f752a997f091ab88491a81bb5c0dea1 pile-commit: 75aa81cc8bc853e937f4dc724379bd11c437 range-diff: -: > 1424: efde3c96d1a9 ALSA: hda: Add Intel DG2 PCI ID and HDMI codec vid series

Re: [Intel-gfx] [PATCH 06/12] drm/i915/bios: rename display_device_data to intel_bios_encoder_data

2021-02-23 Thread Jani Nikula
On Wed, 17 Feb 2021, Jani Nikula wrote: > On Wed, 17 Feb 2021, Lucas De Marchi wrote: >> On Wed, Feb 17, 2021 at 07:03:36PM +0200, Jani Nikula wrote: >>>Make the naming suitable for exposing to the rest of the driver as an >>>opaque type. No functional changes. >> >> ack, but.. >> >>> >>>Cc: Luca

[Intel-gfx] [PATCH] drm/vgem: use shmem helpers

2021-02-23 Thread Daniel Vetter
Aside from deleting lots of code the real motivation here is to switch the mmap over to VM_PFNMAP, to be more consistent with what real gpu drivers do. They're all VM_PFNMP, which means get_user_pages doesn't work, and even if you try and there's a struct page behind that, touching it and mucking a

Re: [Intel-gfx] [PATCH 2/2] drm/vgem: use shmem helpers

2021-02-23 Thread Thomas Zimmermann
Hi Am 23.02.21 um 11:59 schrieb Daniel Vetter: Aside from deleting lots of code the real motivation here is to switch the mmap over to VM_PFNMAP, to be more consistent with what real gpu drivers do. They're all VM_PFNMP, which means get_user_pages doesn't work, and even if you try and there's a

[Intel-gfx] ✗ Fi.CI.BUILD: failure for series starting with [1/2] dma-buf: Require VM_PFNMAP vma for mmap

2021-02-23 Thread Patchwork
== Series Details == Series: series starting with [1/2] dma-buf: Require VM_PFNMAP vma for mmap URL : https://patchwork.freedesktop.org/series/87313/ State : failure == Summary == CALLscripts/checksyscalls.sh CALLscripts/atomic/check-atomics.sh DESCEND objtool CHK include/ge

[Intel-gfx] [PATCH 2/2] drm/vgem: use shmem helpers

2021-02-23 Thread Daniel Vetter
Aside from deleting lots of code the real motivation here is to switch the mmap over to VM_PFNMAP, to be more consistent with what real gpu drivers do. They're all VM_PFNMP, which means get_user_pages doesn't work, and even if you try and there's a struct page behind that, touching it and mucking a

[Intel-gfx] [PATCH 1/2] dma-buf: Require VM_PFNMAP vma for mmap

2021-02-23 Thread Daniel Vetter
tldr; DMA buffers aren't normal memory, expecting that you can use them like that (like calling get_user_pages works, or that they're accounting like any other normal memory) cannot be guaranteed. Since some userspace only runs on integrated devices, where all buffers are actually all resident sys

Re: [Intel-gfx] [PATCH v3] drm/i915/display: Do not allow DC3CO if PSR SF is enabled

2021-02-23 Thread Gupta, Anshuman
> -Original Message- > From: Mun, Gwan-gyeong > Sent: Tuesday, February 23, 2021 3:00 AM > To: intel-gfx@lists.freedesktop.org > Cc: Gupta, Anshuman ; Souza, Jose > > Subject: [PATCH v3] drm/i915/display: Do not allow DC3CO if PSR SF is enabled > > Even though GEN12+ HW supports PSR +