Re: [Intel-gfx] [PATCH 01/10] drm/doc: add rfc section for small BAR uapi

2022-06-16 Thread Intel
On 5/25/22 20:43, Matthew Auld wrote: Add an entry for the new uapi needed for small BAR on DG2+. v2: - Some spelling fixes and other small tweaks. (Akeem & Thomas) - Rework error capture interactions, including no longer needing NEEDS_CPU_ACCESS for objects marked for capture.

Re: [Intel-gfx] [PATCH 1/2] drm/i915: Extract intel_sanitize_fifo_underrun_reporting()

2022-06-16 Thread Jani Nikula
On Wed, 15 Jun 2022, Ville Syrjala wrote: > From: Ville Syrjälä > > Pull the underrun status sanitation into its own helper. > > Signed-off-by: Ville Syrjälä On the series, Reviewed-by: Jani Nikula I'll respin my state readout extraction on top of this once you've merged. > --- >

Re: [Intel-gfx] [PATCH 3/3] drm/i915/bios: Introduce panel_bits() and panel_bool()

2022-06-16 Thread Jani Nikula
On Wed, 15 Jun 2022, Ville Syrjala wrote: > From: Ville Syrjälä > > Abstract the bit extraction from the VBT per-panel bitfields > slightly. > > Signed-off-by: Ville Syrjälä > --- > drivers/gpu/drm/i915/display/intel_bios.c | 31 +-- >

Re: [Intel-gfx] [PATCH 2/3] drm/i915/bios: Don't parse the DPS panel type when the VBT does not have it

2022-06-16 Thread Jani Nikula
On Wed, 15 Jun 2022, Ville Syrjala wrote: > From: Ville Syrjälä > > Older VBTs don't have all the stuff we've defined for the > LVDS options block (40). In particular we're currently parsing > the DPS panel type bits even though they may not exist, which > could mean we end up flagging the

Re: [Intel-gfx] [PATCH 1/3] drm/i915/bios: Move panel_type stuff out of parse_panel_options()

2022-06-16 Thread Jani Nikula
On Wed, 15 Jun 2022, Ville Syrjala wrote: > From: Ville Syrjälä > > Parsing the panel_type is a bit special and should be done > before we parse anything else potentially panel-specific from > the VBT. So move it out from parse_panel_options(). It doesn't > neet to be there anyway since it'll do

Re: [Intel-gfx] [PATCH] drm/i915: Remove bogus LPT iCLKIP WARN

2022-06-16 Thread Jani Nikula
On Thu, 16 Jun 2022, Ville Syrjala wrote: > From: Ville Syrjälä > > The WARN shouldn't have been added yet. For the moment the > clock that gets passed here is just what the user has requested > (via the modeline) and may not be exactly what iCLKIP can > generate. > > Later on the plan is to

Re: [Intel-gfx] [PATCH v3 0/3] Disable connector polling for a headless sku

2022-06-16 Thread Jani Nikula
On Fri, 10 Jun 2022, Jouni Högander wrote: > This patch set disables connector polling when entering runtime > suspend for headless sku to prevent waking it up again when poll > is performed. Pushed to drm-intel-next, thanks for the patches. BR, Jani. > > v3: > - dummy

Re: [Intel-gfx] [PATCH v2 00/11] drm/i915: drm/i915/display: split out verification, hw readout and dump from intel_display.c

2022-06-16 Thread Ville Syrjälä
On Thu, Jun 16, 2022 at 12:48:10PM +0300, Jani Nikula wrote: > v2 of [1]. Address review comments, drop crtc state compare move, add hw > state readout split, and sprinkle some struct > drm_i915_private *i915 cleanups on top. > > BR, > Jani. > > [1]

[Intel-gfx] [PATCH] drm/i915: Remove bogus LPT iCLKIP WARN

2022-06-16 Thread Ville Syrjala
From: Ville Syrjälä The WARN shouldn't have been added yet. For the moment the clock that gets passed here is just what the user has requested (via the modeline) and may not be exactly what iCLKIP can generate. Later on the plan is to change things so that we already get passed the exact clock

[Intel-gfx] [PATCH v2 11/11] drm/i915/display: convert modeset setup to struct drm_i915_private *i915

2022-06-16 Thread Jani Nikula
Pass struct drm_i915_private * instead of struct drm_device *, and rename dev_priv to i915. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_display.c | 4 +- .../drm/i915/display/intel_modeset_setup.c| 199 +- .../drm/i915/display/intel_modeset_setup.h

[Intel-gfx] [PATCH v2 10/11] drm/i915/display: some struct drm_i915_private *i915 conversions

2022-06-16 Thread Jani Nikula
Prefer struct drm_i915_private *i915 over struct drm_device or dev_priv. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_display.c | 60 ++-- 1 file changed, 30 insertions(+), 30 deletions(-) diff --git a/drivers/gpu/drm/i915/display/intel_display.c

[Intel-gfx] [PATCH v2 09/11] drm/i915/display: split out hw state readout and sanitize

2022-06-16 Thread Jani Nikula
Split out the modeset hardware state readout and sanitize, or state setup, to a separate file. Do some drive-by checkpatch fixes while at it. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/Makefile | 1 + drivers/gpu/drm/i915/display/intel_display.c | 730

[Intel-gfx] [PATCH v2 08/11] drm/i915/display: rename dev_priv -> i915 in crtc state dump

2022-06-16 Thread Jani Nikula
Rename dev_priv to i915 in crtc state dumping code. Signed-off-by: Jani Nikula --- .../drm/i915/display/intel_crtc_state_dump.c | 80 +-- 1 file changed, 40 insertions(+), 40 deletions(-) diff --git a/drivers/gpu/drm/i915/display/intel_crtc_state_dump.c

[Intel-gfx] [PATCH v2 07/11] drm/i915/display: change who adds [] around crtc state dump context string

2022-06-16 Thread Jani Nikula
Add the brackets [] around crtc state dump context string in intel_crtc_state_dump() so the callers don't have to. Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/display/intel_crtc_state_dump.c | 2 +- drivers/gpu/drm/i915/display/intel_display.c | 6 +++---

[Intel-gfx] [PATCH v2 06/11] drm/i915/display: split out crtc state dump to a separate file

2022-06-16 Thread Jani Nikula
Declutter intel_display.c by splitting out crtc state dumping to a separate file. v2: intel_pipe_config_dump -> intel_crtc_state_dump Signed-off-by: Jani Nikula --- drivers/gpu/drm/i915/Makefile | 1 + .../drm/i915/display/intel_crtc_state_dump.c | 314 +

[Intel-gfx] [PATCH v2 05/11] drm/i915/display: split out modeset verification code

2022-06-16 Thread Jani Nikula
Add new file intel_modeset_verify.c for high level modeset verification code to declutter intel_display.h. The new file is supposed to be about crtc/encoder/connector verification; the state verification for very specific functionality such as plls or wm should be placed next to the code it

[Intel-gfx] [PATCH v2 04/11] drm/i915/mpllb: move mpllb state check to intel_snps_phy.c

2022-06-16 Thread Jani Nikula
Keep the mpllb implementation details together in intel_snps_phy.c. Also declutter intel_display.c. v2: intel_mpllb_verify_state -> void intel_mpllb_state_verify (Ville) Signed-off-by: Jani Nikula Reviewed-by: Ville Syrjälä --- drivers/gpu/drm/i915/display/intel_display.c | 46

[Intel-gfx] [PATCH v2 03/11] drm/i915/mpllb: use I915_STATE_WARN() for state mismatch warnings

2022-06-16 Thread Jani Nikula
The pipe_config_mismatch() function is primarily for logging comparison results. Signed-off-by: Jani Nikula Reviewed-by: Ville Syrjälä --- drivers/gpu/drm/i915/display/intel_display.c | 14 ++ 1 file changed, 6 insertions(+), 8 deletions(-) diff --git

[Intel-gfx] [PATCH v2 02/11] drm/i915/dpll: move shared dpll state verification to intel_dpll_mgr.c

2022-06-16 Thread Jani Nikula
Keep the shared dpll implementation details together by moving the dpll state verification to intel_dpll_mgr.c. Also declutter intel_display.c. v2: intel_shared_dpll_verify_state -> intel_shared_dpll_state_verify (Ville) Signed-off-by: Jani Nikula Reviewed-by: Ville Syrjälä ---

[Intel-gfx] [PATCH v2 01/11] drm/i915/wm: move wm state verification to intel_pm.c

2022-06-16 Thread Jani Nikula
By moving wm state verification to intel_pm.c, we can make a bunch of functions static, hiding the wm details better. Also declutter intel_display.c. v2: intel_wm_state_verify -> intel_wm_verify_state (Ville) Signed-off-by: Jani Nikula Reviewed-by: Ville Syrjälä ---

[Intel-gfx] [PATCH v2 00/11] drm/i915: drm/i915/display: split out verification, hw readout and dump from intel_display.c

2022-06-16 Thread Jani Nikula
v2 of [1]. Address review comments, drop crtc state compare move, add hw state readout split, and sprinkle some struct drm_i915_private *i915 cleanups on top. BR, Jani. [1] https://patchwork.freedesktop.org/series/105156/ Jani Nikula (11): drm/i915/wm: move wm state verification to

Re: [Intel-gfx] [PATCH 3/3] drm/doc/rfc: VM_BIND uapi definition

2022-06-16 Thread Tvrtko Ursulin
On 15/06/2022 16:20, Niranjana Vishwanathapura wrote: On Wed, Jun 15, 2022 at 08:22:23AM +0100, Tvrtko Ursulin wrote: On 14/06/2022 17:42, Niranjana Vishwanathapura wrote: On Tue, Jun 14, 2022 at 05:07:37PM +0100, Tvrtko Ursulin wrote: On 14/06/2022 17:02, Tvrtko Ursulin wrote: On

[Intel-gfx] ✓ Fi.CI.IGT: success for drm/i915/dsi: add payload receiving code (rev3)

2022-06-16 Thread Patchwork
== Series Details == Series: drm/i915/dsi: add payload receiving code (rev3) URL : https://patchwork.freedesktop.org/series/105096/ State : success == Summary == CI Bug Log - changes from CI_DRM_11763_full -> Patchwork_105096v3_full

[Intel-gfx] [PULL] drm-intel-fixes

2022-06-16 Thread Jani Nikula
Hi Dave & Daniel - drm-intel-fixes-2022-06-16: drm/i915 fixes for v5.19-rc3: - Fix page fault on error state read - Fix memory leaks in per-gt sysfs - Fix multiple fence handling - Remove accidental static from a local variable BR, Jani. The following changes since commit

[Intel-gfx] ✗ Fi.CI.IGT: failure for Get dsc optimal output bpp

2022-06-16 Thread Patchwork
== Series Details == Series: Get dsc optimal output bpp URL : https://patchwork.freedesktop.org/series/105200/ State : failure == Summary == CI Bug Log - changes from CI_DRM_11763_full -> Patchwork_105200v1_full Summary ---

Re: [Intel-gfx] [PATCH 5/6] drm/i915/gt: Serialize GRDOM access between multiple engine resets

2022-06-16 Thread Tvrtko Ursulin
On 15/06/2022 16:27, Mauro Carvalho Chehab wrote: From: Chris Wilson Don't allow two engines to be reset in parallel, as they would both try to select a reset bit (and send requests to common registers) and wait on that register, at the same time. Serialize control of the reset requests/acks

Re: [Intel-gfx] [PATCH 4/6] drm/i915/gt: Only invalidate TLBs exposed to user manipulation

2022-06-16 Thread Tvrtko Ursulin
On 15/06/2022 16:27, Mauro Carvalho Chehab wrote: From: Chris Wilson Don't flush TLBs when the buffer is only used in the GGTT under full control of the kernel, as there's no risk of of concurrent access and stale access from prefetch. We only need to invalidate the TLB if they are

Re: [Intel-gfx] [PATCH 3/6] drm/i915/gt: Skip TLB invalidations once wedged

2022-06-16 Thread Tvrtko Ursulin
On 15/06/2022 16:27, Mauro Carvalho Chehab wrote: From: Chris Wilson Skip all further TLB invalidations once the device is wedged and had been reset, as, on such cases, it can no longer process instructions on the GPU and the user no longer has access to the TLB's in each engine. Fixes:

[Intel-gfx] [PULL] drm-misc-fixes

2022-06-16 Thread Maxime Ripard
Hi Dave, Daniel, Here's this week drm-misc-fixes PR Maxime drm-misc-fixes-2022-06-16: Two fixes for TTM, one for a NULL pointer dereference and one to make sure the buffer is pinned prior to a bulk move, and a fix for a spurious compiler warning. The following changes since commit

Re: [Intel-gfx] [PATCH 1/6] drm/i915/gt: Ignore TLB invalidations on idle engines

2022-06-16 Thread Tvrtko Ursulin
On 15/06/2022 16:27, Mauro Carvalho Chehab wrote: From: Chris Wilson As an extension of the current skip TLB invalidations, check if the device is powered down prior to any engine activity, as, on such cases, all the TLBs were already invalidated, so an explicit TLB invalidation is not

Re: [Intel-gfx] [PATCH 00/15] HuC loading for DG2

2022-06-16 Thread Tvrtko Ursulin
On 15/06/2022 17:14, Ye, Tony wrote: On 6/15/2022 3:13 AM, Tvrtko Ursulin wrote: On 15/06/2022 00:15, Ye, Tony wrote: On 6/14/2022 8:30 AM, Ceraolo Spurio, Daniele wrote: On 6/14/2022 12:44 AM, Tvrtko Ursulin wrote: On 13/06/2022 19:13, Ceraolo Spurio, Daniele wrote: On 6/13/2022 10:39

[Intel-gfx] ✓ Fi.CI.IGT: success for i915: Extract, polish, and document multicast handling

2022-06-16 Thread Patchwork
== Series Details == Series: i915: Extract, polish, and document multicast handling URL : https://patchwork.freedesktop.org/series/105134/ State : success == Summary == CI Bug Log - changes from CI_DRM_11758_full -> Patchwork_105134v1_full

[Intel-gfx] ✓ Fi.CI.BAT: success for drm/i915/dsi: add payload receiving code (rev3)

2022-06-16 Thread Patchwork
== Series Details == Series: drm/i915/dsi: add payload receiving code (rev3) URL : https://patchwork.freedesktop.org/series/105096/ State : success == Summary == CI Bug Log - changes from CI_DRM_11763 -> Patchwork_105096v3 Summary ---

<    1   2