Re: [Intel-gfx] [PATCH v2 00/15] sysctl: Remove sentinel elements from drivers

2023-10-02 Thread Christophe Leroy
Le 02/10/2023 à 10:55, Joel Granados via B4 Relay a écrit : > From: Joel Granados > > What? > These commits remove the sentinel element (last empty element) from the > sysctl arrays of all the files under the "drivers/" directory that use a > sysctl array for registration. The merging of the

Re: [Intel-gfx] [PATCH 00/15] sysctl: Remove sentinel elements from drivers

2023-10-02 Thread Christophe Leroy
Le 02/10/2023 à 10:47, Joel Granados a écrit : > On Thu, Sep 28, 2023 at 04:31:30PM +0000, Christophe Leroy wrote: > I followed this trace and proc_handler is correctly defined in tty_table > (struct ctl_table) in drivers/tty/tty_io.c:tty_init and there is not > path that changes

Re: [Intel-gfx] [PATCH 04/15] tty: Remove now superfluous sentinel element from ctl_table array

2023-10-02 Thread Christophe Leroy
Le 02/10/2023 à 10:17, Jiri Slaby a écrit : > On 28. 09. 23, 15:21, Joel Granados via B4 Relay wrote: >> From: Joel Granados >> >> This commit comes at the tail end of a greater effort to remove the >> empty elements at the end of the ctl_table arrays (sentinels) which >> will reduce the

Re: [Intel-gfx] [PATCH 00/15] sysctl: Remove sentinel elements from drivers

2023-09-28 Thread Christophe Leroy
Le 28/09/2023 à 15:21, Joel Granados via B4 Relay a écrit : > From: Joel Granados Automatic test fails on powerpc, see https://patchwork.ozlabs.org/project/linuxppc-dev/patch/20230928-jag-sysctl_remove_empty_elem_drivers-v1-15-e59120fca...@samsung.com/ Kernel attempted to read user page

Re: [Intel-gfx] [PATCH v5 1/2] module: update dependencies at try_module_get()

2022-05-03 Thread Christophe Leroy
Le 30/04/2022 à 22:04, Mauro Carvalho Chehab a écrit : > Sometimes, device drivers are bound into each other via try_module_get(), > making such references invisible when looking at /proc/modules or lsmod. > > Add a function to allow setting up module references for such > cases, and call it

[Intel-gfx] [PATCH RESEND] drm/i915/gem: Use user_write_access_begin() instead of user_access_begin()

2021-05-03 Thread Christophe Leroy
eb_copy_relocations() only do unsafe_put_user(), it only requires write access to user. Use user_write_access_begin() instead of user_access_begin(). Signed-off-by: Christophe Leroy --- Resending with mm list in addition drivers/gpu/drm/i915/gem/i915_gem_execbuffer.c | 6 +++--- 1 file

[Intel-gfx] [PATCH] drm/i915/gem: Use user_write_access_begin() instead of user_access_begin()

2021-03-10 Thread Christophe Leroy
eb_copy_relocations() only do unsafe_put_user(), it only requires write access to user. Use user_write_access_begin() instead of user_access_begin(). Signed-off-by: Christophe Leroy --- drivers/gpu/drm/i915/gem/i915_gem_execbuffer.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions

Re: [Intel-gfx] [PATCH v2 5/5] uaccess: Rename user_access_begin/end() to user_full_access_begin/end()

2020-04-06 Thread Christophe Leroy
Le 03/04/2020 à 20:01, Linus Torvalds a écrit : On Fri, Apr 3, 2020 at 12:21 AM Christophe Leroy wrote: Now we have user_read_access_begin() and user_write_access_begin() in addition to user_access_begin(). I realize Al asked for this, but I don't think it really adds anything

[Intel-gfx] [PATCH v2 4/5] powerpc/uaccess: Implement user_read_access_begin and user_write_access_begin

2020-04-03 Thread Christophe Leroy
Add support for selective read or write user access with user_read_access_begin/end and user_write_access_begin/end. Signed-off-by: Christophe Leroy Reviewed-by: Kees Cook --- v2: no change --- arch/powerpc/include/asm/book3s/32/kup.h | 4 ++-- arch/powerpc/include/asm/kup.h | 14

[Intel-gfx] [PATCH v2 3/5] drm/i915/gem: Replace user_access_begin by user_write_access_begin

2020-04-03 Thread Christophe Leroy
When i915_gem_execbuffer2_ioctl() is using user_access_begin(), that's only to perform unsafe_put_user() so use user_write_access_begin() in order to only open write access. Signed-off-by: Christophe Leroy Reviewed-by: Kees Cook --- v2: Rebased (one part of the patch flies away) --- drivers

[Intel-gfx] [PATCH v2 1/5] uaccess: Add user_read_access_begin/end and user_write_access_begin/end

2020-04-03 Thread Christophe Leroy
and user_write_access_end to only open write access. By default, when undefined, those new access helpers default on the existing user_access_begin and user_access_end. Signed-off-by: Christophe Leroy Reviewed-by: Kees Cook --- v2: no change in this patch. See each patch for related changes. v1

[Intel-gfx] [PATCH v2 2/5] uaccess: Selectively open read or write user access

2020-04-03 Thread Christophe Leroy
When opening user access to only perform reads, only open read access. When opening user access to only perform writes, only open write access. Signed-off-by: Christophe Leroy Reviewed-by: Kees Cook --- v2: Fixed a mismatched use of _read_ and _write_ in compat_get_bitmap

[Intel-gfx] [PATCH v2 5/5] uaccess: Rename user_access_begin/end() to user_full_access_begin/end()

2020-04-03 Thread Christophe Leroy
with following command, then hand splitted two too long lines. sed -i s/user_access_begin/user_full_access_begin/g `git grep -l user_access_begin` Signed-off-by: Christophe Leroy --- v2: New, based on remark from Al Viro. --- arch/powerpc/include/asm/uaccess.h | 5 +++-- arch/x86/include/asm