[Intel-gfx] [PATCH 3/3] drm/i915/guc/slpc: Update boost sysfs hooks for SLPC

2021-10-20 Thread Vinay Belgaumkar
Add a helper to sort through the SLPC/RPS cases of get/set methods. Boost frequency will be modified as long as it is within the constraints of RP0 and if it is different from the existing one. We will set min freq to boost only if there is an active waiter. Signed-off-by: Vinay Belgaumkar --- d

[Intel-gfx] [PATCH 3/3] drm/i915/guc/slpc: Update boost sysfs hooks for SLPC

2021-10-31 Thread Vinay Belgaumkar
Add a helper to sort through the SLPC/RPS paths of get/set methods. Boost frequency will be modified as long as it is within the constraints of RP0 and if it is different from the existing one. We will set min freq to boost only if there is at least one active waiter. v2: Add num_boosts to guc_slp

[Intel-gfx] [PATCH 3/3] drm/i915/guc/slpc: Update boost sysfs hooks for SLPC

2021-11-01 Thread Vinay Belgaumkar
Add a helper to sort through the SLPC/RPS paths of get/set methods. Boost frequency will be modified as long as it is within the constraints of RP0 and if it is different from the existing one. We will set min freq to boost only if there is at least one active waiter. v2: Add num_boosts to guc_slp

Re: [Intel-gfx] [PATCH 3/3] drm/i915/guc/slpc: Update boost sysfs hooks for SLPC

2021-10-21 Thread Nilawar, Badal
Please fix code style related warnings and errors from checkpatch result. On 21-10-2021 01:22, Vinay Belgaumkar wrote: Add a helper to sort through the SLPC/RPS cases of get/set methods. Boost frequency will be modified as long as it is within the constraints of RP0 and if it is different from t

Re: [Intel-gfx] [PATCH 3/3] drm/i915/guc/slpc: Update boost sysfs hooks for SLPC

2021-11-01 Thread Dixit, Ashutosh
On Sun, 31 Oct 2021 21:39:37 -0700, Belgaumkar, Vinay wrote: > > +static int set_boost_freq(struct intel_rps *rps, u32 val) Since this is legacy rps code path maybe change function name to rps_set_boost_freq?

Re: [Intel-gfx] [PATCH 3/3] drm/i915/guc/slpc: Update boost sysfs hooks for SLPC

2021-11-03 Thread Dixit, Ashutosh
On Mon, 01 Nov 2021 13:28:14 -0700, Dixit, Ashutosh wrote: > > On Sun, 31 Oct 2021 21:39:37 -0700, Belgaumkar, Vinay wrote: > > > > +static int set_boost_freq(struct intel_rps *rps, u32 val) > > Since this is legacy rps code path maybe change function name to > rps_set_boost_freq? Not being able t

Re: [Intel-gfx] [PATCH 3/3] drm/i915/guc/slpc: Update boost sysfs hooks for SLPC

2021-11-03 Thread Dixit, Ashutosh
On Mon, 01 Nov 2021 18:26:08 -0700, Vinay Belgaumkar wrote: > > Add a helper to sort through the SLPC/RPS paths of get/set methods. > Boost frequency will be modified as long as it is within the constraints > of RP0 and if it is different from the existing one. We will set min > freq to boost only