Re: [Intel-gfx] [PATCH v5 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()

2023-11-29 Thread Sean Young
On Fri, Nov 24, 2023 at 02:31:18PM +0100, Thierry Reding wrote: > On Sat, Nov 18, 2023 at 04:16:17PM +, Sean Young wrote: > > In order to introduce a pwm api which can be used from atomic context, > > we will need two functions for applying pwm changes: > > > > int pwm_apply_cansleep(struc

Re: [Intel-gfx] [PATCH v5 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()

2023-11-24 Thread Thierry Reding
On Sat, Nov 18, 2023 at 04:16:17PM +, Sean Young wrote: > In order to introduce a pwm api which can be used from atomic context, > we will need two functions for applying pwm changes: > > int pwm_apply_cansleep(struct pwm *, struct pwm_state *); > int pwm_apply_atomic(struct pwm *,

Re: [Intel-gfx] [PATCH v5 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()

2023-11-23 Thread Lee Jones
On Sat, 18 Nov 2023, Sean Young wrote: > In order to introduce a pwm api which can be used from atomic context, > we will need two functions for applying pwm changes: > > int pwm_apply_cansleep(struct pwm *, struct pwm_state *); > int pwm_apply_atomic(struct pwm *, struct pwm_state *)

[Intel-gfx] [PATCH v5 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()

2023-11-18 Thread Sean Young
In order to introduce a pwm api which can be used from atomic context, we will need two functions for applying pwm changes: int pwm_apply_cansleep(struct pwm *, struct pwm_state *); int pwm_apply_atomic(struct pwm *, struct pwm_state *); This commit just deals with renaming pwm_ap