[PATCH v8 3/3] iommu/mediatek: Allow page table PA up to 35bit

2022-06-11 Thread yf.wang--- via iommu
From: Yunfei Wang Single memory zone feature will remove ZONE_DMA32 and ZONE_DMA. So add the quirk IO_PGTABLE_QUIRK_ARM_MTK_TTBR_EXT to let level 1 and level 2 pgtable support at most 35bit PA. Signed-off-by: Ning Li Signed-off-by: Yunfei Wang --- drivers/iommu/mtk_iommu.c | 14 +-

[PATCH v8 1/3] iommu/io-pgtable-arm-v7s: Add a quirk to allow pgtable PA up to 35bit

2022-06-11 Thread yf.wang--- via iommu
From: Yunfei Wang Single memory zone feature will remove ZONE_DMA32 and ZONE_DMA and cause pgtable PA size larger than 32bit. Since Mediatek IOMMU hardware support at most 35bit PA in pgtable, so add a quirk to allow the PA of pgtables support up to bit35. Signed-off-by: Ning Li Signed-off-by:

[PATCH v8 2/3] iommu/mediatek: Rename MTK_IOMMU_TLB_ADDR to MTK_IOMMU_ADDR

2022-06-11 Thread yf.wang--- via iommu
From: Yunfei Wang Rename MTK_IOMMU_TLB_ADDR to MTK_IOMMU_ADDR, and update MTK_IOMMU_ADDR definition for better generality. Signed-off-by: Ning Li Signed-off-by: Yunfei Wang --- drivers/iommu/mtk_iommu.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/iommu/

Re: [PATCH v5 2/2] iommu/mediatek: Allow page table PA up to 35bit

2022-06-11 Thread yf.wang--- via iommu
On Thu, 2022-05-19 at 14:58 +0800, Yong Wu wrote: > On Mon, 2022-05-16 at 22:16 +0800, yf.w...@mediatek.com wrote: > > From: Yunfei Wang > > > > Add the quirk IO_PGTABLE_QUIRK_ARM_MTK_TTBR_EXT support, so that > > allows > > page table PA up to 35bit, not only in ZONE_DMA32. > > Comment why this

[PATCH v1 4/4] swiotlb: panic if nslabs is too small

2022-06-11 Thread Dongli Zhang
Panic on purpose if nslabs is too small, in order to sync with the remap retry logic. In addition, print the number of bytes for tlb alloc failure. Signed-off-by: Dongli Zhang --- kernel/dma/swiotlb.c | 6 +- 1 file changed, 5 insertions(+), 1 deletion(-) diff --git a/kernel/dma/swiotlb.c

[PATCH v1 3/4] x86/swiotlb: fix param usage in boot-options.rst

2022-06-11 Thread Dongli Zhang
Fix the usage of swiotlb param in kernel doc. Signed-off-by: Dongli Zhang --- Documentation/x86/x86_64/boot-options.rst | 8 +--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a/Documentation/x86/x86_64/boot-options.rst b/Documentation/x86/x86_64/boot-options.rst index 03ec9cf

[PATCH v1 0/4] swiotlb: some cleanup

2022-06-11 Thread Dongli Zhang
Hello, The patch 1-2 are to cleanup unused variable and return type. The patch 3 is to fix the param usage description in kernel doc. The patch 4 is to panic on purpose when nslabs is too small. Dongli Zhang: [PATCH v1 1/4] swiotlb: remove unused swiotlb_force [PATCH v1 2/4] swiotlb: remov

[PATCH v1 2/4] swiotlb: remove useless return

2022-06-11 Thread Dongli Zhang
Both swiotlb_init_remap() and swiotlb_init() have return type void. Signed-off-by: Dongli Zhang --- kernel/dma/swiotlb.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/kernel/dma/swiotlb.c b/kernel/dma/swiotlb.c index cb50f8d38360..fd21f4162f4b 100644 --- a/kernel/dma/swiotl

[PATCH v1 1/4] swiotlb: remove unused swiotlb_force

2022-06-11 Thread Dongli Zhang
The 'swiotlb_force' is removed since commit c6af2aa9ffc9 ("swiotlb: make the swiotlb_init interface more useful"). Signed-off-by: Dongli Zhang --- include/linux/swiotlb.h | 1 - 1 file changed, 1 deletion(-) diff --git a/include/linux/swiotlb.h b/include/linux/swiotlb.h index 7ed35dd3de6e..bdc5