[ https://issues.apache.org/jira/browse/SPARK-5931?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Andrew Or closed SPARK-5931. ---------------------------- Resolution: Fixed Fix Version/s: 1.4.0 > Use consistent naming for time properties > ----------------------------------------- > > Key: SPARK-5931 > URL: https://issues.apache.org/jira/browse/SPARK-5931 > Project: Spark > Issue Type: Improvement > Components: Spark Core > Affects Versions: 1.0.0 > Reporter: Andrew Or > Assignee: Ilya Ganelin > Fix For: 1.4.0 > > > This is SPARK-5932's sister issue. > The naming of existing time configs is inconsistent. We currently have the > following throughout the code base: > {code} > spark.network.timeout // seconds > spark.executor.heartbeatInterval // milliseconds > spark.storage.blockManagerSlaveTimeoutMs // milliseconds > spark.yarn.scheduler.heartbeat.interval-ms // milliseconds > {code} > Instead, my proposal is to simplify the config name itself and make > everything accept time using the following format: 5s, 2ms, 100us. For > instance: > {code} > spark.network.timeout = 5s > spark.executor.heartbeatInterval = 500ms > spark.storage.blockManagerSlaveTimeout = 100ms > spark.yarn.scheduler.heartbeatInterval = 400ms > {code} > All existing configs that are relevant will be deprecated in favor of the new > ones. We should do this soon before we keep introducing more time configs. -- This message was sent by Atlassian JIRA (v6.3.4#6332) --------------------------------------------------------------------- To unsubscribe, e-mail: issues-unsubscr...@spark.apache.org For additional commands, e-mail: issues-h...@spark.apache.org