[jira] Created: (LUCENE-1763) MergePolicy should require an IndexWriter upon construction

2009-07-27 Thread Shai Erera (JIRA)
MergePolicy should require an IndexWriter upon construction --- Key: LUCENE-1763 URL: https://issues.apache.org/jira/browse/LUCENE-1763 Project: Lucene - Java Issue Type: Improvement

[jira] Resolved: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Michael McCandless (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Michael McCandless resolved LUCENE-1754. Resolution: Fixed Thanks Shai! Get rid of NonMatchingScorer from BooleanScorer2

[jira] Resolved: (LUCENE-1595) Split DocMaker into ContentSource and DocMaker

2009-07-27 Thread Michael McCandless (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1595?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Michael McCandless resolved LUCENE-1595. Resolution: Fixed Split DocMaker into ContentSource and DocMaker

RE: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Uwe Schindler
Why do we need this class? There is already a static final empty iterator available in DocIdSetIterator.EMPTY_DOCIDSET_ITERATOR (or something like that name)? - Uwe Schindler H.-H.-Meier-Allee 63, D-28213 Bremen http://www.thetaphi.de eMail: u...@thetaphi.de From: mikemcc...@apache.org

Re: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Robert Muir
here it is: DocIdSet.EMPTY_DOCIDSET /** An empty {...@code DocIdSet} instance for easy use (this is currently * implemented using a {...@link SortedVIntList}). */ On Mon, Jul 27, 2009 at 6:18 AM, Uwe Schindleru...@thetaphi.de wrote: Why do we need this class? There is already a static final

RE: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Uwe Schindler
Right, and you can simply get an iterator from it. - Uwe Schindler H.-H.-Meier-Allee 63, D-28213 Bremen http://www.thetaphi.de eMail: u...@thetaphi.de -Original Message- From: Robert Muir [mailto:rcm...@gmail.com] Sent: Monday, July 27, 2009 12:24 PM To:

Re: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Shai Erera
I don't see this class in DISI. I created it for classes that get a null iterator, but need to have some iterator to work w/, so now they can use EmptyDISI. It not like DocIdSet.EMPTY_DOCIDSET. While the latter allows an impl to return EMPTY as its DocIdSet, the EmptyDISI is for instantiation by

Re: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Shai Erera
And BTW, now that I look at DIS.EMPTY, I think it can be improved by defining it like this: public static final DocIdSet EMPTY_DOCIDSET = new SortedVIntList(new int[0]) { public DocIdSetIterator iterator() { return EmptyDocIdSetIterator.getInstance(); } }; Instead of having its

RE: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Uwe Schindler
I don't understand that. If you need an empty iterator, call: DocIdSet.EMPTY_DOCIDSET.iterator() - bingo. This is always empty. Uwe - Uwe Schindler H.-H.-Meier-Allee 63, D-28213 Bremen http://www.thetaphi.de http://www.thetaphi.de eMail: u...@thetaphi.de _ From: Shai

RE: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Uwe Schindler
This was my second idea, if you really want to have this empty one. Instead of returing a SortedVIntList at all just create a subclass of the abstract one: public static final DocIdSet EMPTY_DOCIDSET = new DocIdSet() { public DocIdSetIterator iterator() { return

Re: svn commit: r798091 - /lucene/java/trunk/src/java/org/apache/lucene/search/EmptyDocIdSetIterator.java

2009-07-27 Thread Shai Erera
Ok I wasn't aware of DIS.EMPTY - calling DIS.EMPTY.iterator() is also acceptable. EmptyDISI does conform to the spec, as the spec says about docID(): returns -1 or NO_MORE_DOCS if nextDoc() or advance(int) were not called yet. Therefore it's ok to return NO_MORE_DOCS upfront. How do you propose

[jira] Reopened: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Shai Erera reopened LUCENE-1754: EmptyDocIdSetIterator is not necessary as DocIdSet already defines an EMPTY_DOCIDSET member. We

[jira] Updated: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Shai Erera updated LUCENE-1754: --- Attachment: LUCENE-1754-2.patch Removed EmptyDocIdSetIterator and changed DocIdSet.EMPTY_DOCIDSET

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Michael McCandless (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735563#action_12735563 ] Michael McCandless commented on LUCENE-1754: New patch looks good Shai,

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735566#action_12735566 ] Shai Erera commented on LUCENE-1754: bq. There is no need to make this empty DIS a

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735564#action_12735564 ] Uwe Schindler commented on LUCENE-1754: --- There is no need to make this empty DIS a

[jira] Updated: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Shai Erera updated LUCENE-1754: --- Attachment: LUCENE-1754-2.patch Wait ! DocIdSet.EMPTY should not do new SortedVIntList, just new

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735568#action_12735568 ] Uwe Schindler commented on LUCENE-1754: --- Hihi! Sometimes it is not the best to be

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Michael McCandless (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735569#action_12735569 ] Michael McCandless commented on LUCENE-1754: bq. DocIdSet.EMPTY should not do

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735570#action_12735570 ] Uwe Schindler commented on LUCENE-1754: --- I also removed the note about

[jira] Resolved: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Michael McCandless (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Michael McCandless resolved LUCENE-1754. Resolution: Fixed Get rid of NonMatchingScorer from BooleanScorer2

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735572#action_12735572 ] Shai Erera commented on LUCENE-1754: bq. I also removed the note about SortedVInitList

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735573#action_12735573 ] Uwe Schindler commented on LUCENE-1754: --- I am a little bit confused about the

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735574#action_12735574 ] Shai Erera commented on LUCENE-1754: bq. Is it really allowed to return null instead

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735575#action_12735575 ] Uwe Schindler commented on LUCENE-1754: --- OK, so maybe we change the JavaDoc and

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735576#action_12735576 ] Shai Erera commented on LUCENE-1754: Even though I don't know if it's optimal, I think

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735578#action_12735578 ] Uwe Schindler commented on LUCENE-1754: --- DONE! I hope this is the last commit for

[jira] Commented: (LUCENE-1754) Get rid of NonMatchingScorer from BooleanScorer2

2009-07-27 Thread Michael McCandless (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1754?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735583#action_12735583 ] Michael McCandless commented on LUCENE-1754: Phew, thanks guys! Get rid of

ShingleFilter + StopWords?

2009-07-27 Thread Jason Rutherglen
I'd like to enable ShingleFilter to only create shingles for a set of (stop) words (rather than for all N tokens). - To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org For additional commands, e-mail:

RE: ShingleFilter + StopWords?

2009-07-27 Thread Steven A Rowe
Hi Jason, On 7/27/2009 at 3:15 PM, Jason Rutherglen wrote: I'd like to enable ShingleFilter to only create shingles for a set of (stop) words (rather than for all N tokens). For purposes of discussion, here's some example input (first sentence from http://en.wikipedia.org/wiki/Manufacturing):

[jira] Updated: (LUCENE-1762) Slightly more readable code in TermAttributeImpl

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1762?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Uwe Schindler updated LUCENE-1762: -- Attachment: LUCENE-1762.patch Extended patch. It adds also tests for the basic attributes (in

[jira] Updated: (LUCENE-1762) Slightly more readable code in TermAttributeImpl

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1762?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Uwe Schindler updated LUCENE-1762: -- Affects Version/s: 2.9 Fix Version/s: 2.9 Slightly more readable code in

[jira] Commented: (LUCENE-1762) Slightly more readable code in TermAttributeImpl

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735798#action_12735798 ] Uwe Schindler commented on LUCENE-1762: --- Eks, the original patch looked good, I did

[jira] Issue Comment Edited: (LUCENE-1762) Slightly more readable code in TermAttributeImpl

2009-07-27 Thread Uwe Schindler (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735796#action_12735796 ] Uwe Schindler edited comment on LUCENE-1762 at 7/27/09 2:56 PM:

[jira] Commented: (LUCENE-1762) Slightly more readable code in TermAttributeImpl

2009-07-27 Thread Eks Dev (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1762?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735809#action_12735809 ] Eks Dev commented on LUCENE-1762: - cool, thanks for the review. Slightly more

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Michael Busch (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735812#action_12735812 ] Michael Busch commented on LUCENE-1567: --- The build.xml seems to be missing in the

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Adriano Crestani (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735820#action_12735820 ] Adriano Crestani commented on LUCENE-1567: -- Hi Michael, I think I excluded by

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Michael Busch (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735835#action_12735835 ] Michael Busch commented on LUCENE-1567: --- Thanks, Adriano. I'll take the files from

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Michael Busch (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735838#action_12735838 ] Michael Busch commented on LUCENE-1567: --- Sorry, my fault. The encoding was not set

[jira] Updated: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Michael Busch (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Michael Busch updated LUCENE-1567: -- Attachment: lucene-1567.patch Fixed the patch so that it compiles against current trunk: -

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Michael Busch (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735842#action_12735842 ] Michael Busch commented on LUCENE-1567: --- {quote} OK, I have submitted the IP

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Michael Busch (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735850#action_12735850 ] Michael Busch commented on LUCENE-1567: --- Luis/Adriano: I find it a bit confusing now

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Luis Alves (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735855#action_12735855 ] Luis Alves commented on LUCENE-1567: Hi Michael, Thanks for updating the patch to

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Grant Ingersoll (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735862#action_12735862 ] Grant Ingersoll commented on LUCENE-1567: - bq. Did it pass the review, Grant?

[jira] Commented: (LUCENE-1076) Allow MergePolicy to select non-contiguous merges

2009-07-27 Thread Shai Erera (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1076?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735905#action_12735905 ] Shai Erera commented on LUCENE-1076: Can someone please help me understand what's

[jira] Updated: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Luis Alves (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Luis Alves updated LUCENE-1567: --- Attachment: lucene_trunk_FlexQueryParser_2009july27_v9.patch The latest patch include: - created

[jira] Updated: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Luis Alves (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Luis Alves updated LUCENE-1567: --- Attachment: (was: lucene_trunk_FlexQueryParser_2009july27_v9.patch) New flexible query parser

[jira] Updated: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Luis Alves (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Luis Alves updated LUCENE-1567: --- Attachment: lucene_trunk_FlexQueryParser_2009july27_v9.patch New flexible query parser

[jira] Updated: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Luis Alves (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Luis Alves updated LUCENE-1567: --- Attachment: lucene_trunk_FlexQueryParser_2009july27_v9.patch New flexible query parser

[jira] Updated: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Luis Alves (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Luis Alves updated LUCENE-1567: --- Attachment: (was: lucene_trunk_FlexQueryParser_2009july27_v9.patch) New flexible query parser

[jira] Commented: (LUCENE-1567) New flexible query parser

2009-07-27 Thread Adriano Crestani (JIRA)
[ https://issues.apache.org/jira/browse/LUCENE-1567?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12735938#action_12735938 ] Adriano Crestani commented on LUCENE-1567: -- {quote} fixed TextParser.jj - I