Re: 8178380: Module system implementation refresh (5/2017 update)

2017-05-01 Thread Lois Foltan
Hi Alan, Hotspot changes look good. Thanks, Lois On 5/1/2017 4:28 PM, Alan Bateman wrote: As I mentioned in another thread, we need to get the changes accumulated in jake to jdk9/dev. JDK-8178380 [1] has the summary of the changes that have accumulated since the last refresh. One note on

Re: 8177530: Module system implementation refresh (4/2017)

2017-04-04 Thread Lois Foltan
Hi Alan, Hotspot changes look good. One minor comment, can you move the definition of java/lang/Module at line #93 in hotspot/src/share/vm/classfile/vmSymbols.hpp up to a new line after #58 which is java/lang/Package? I wouldn't need to see another webrev for this. Thank you, Lois On 4/4/

Re: 8174823: Module system implementation refresh (3/2017)

2017-03-22 Thread Lois Foltan
Alan, Hotspot changes look good. Lois On 3/21/2017 5:42 PM, Alan Bateman wrote: We have been accumulating changes in the jake forest for the last few weeks to align with the proposals in JSR 376 and also to pick up API changes and bug fixes. It's time to bring these changes into jdk9/dev. Th

Re: 8173393: Module system implementation refresh (2/2017)

2017-02-07 Thread Lois Foltan
Hotspot changes look good to me. Lois On 2/7/2017 8:23 AM, Alan Bateman wrote: We've been accumulating changes in the jake forest for the last few weeks and it's time to bring the changes to jdk9/dev, to make jdk-9+157 if possible. JDK 9 is the first phase of rampdown and so this update will n

Re: RFR: 8171855: Move package name transformations during module bootstrap into native code

2017-01-05 Thread Lois Foltan
On 1/5/2017 11:47 AM, Claes Redestad wrote: Hi, after a round of review comments I've now reworked this to do the transformations in the JNI layer rather than inside the VM, with similar - if not better - results. Webrevs: http://cr.openjdk.java.net/~redestad/8171855/hotspot.03/ http://cr.open

Re: RFR: 8171855: Move package name transformations during module bootstrap into VM

2017-01-03 Thread Lois Foltan
On 1/2/2017 1:27 PM, Claes Redestad wrote: Hi, during jigsaw bootstrap, package names - represented in external form, "java.lang" - are transformed into VM internal form, "java/lang", before calling into the VM. This, however, can effectively be moved into the VM, which removes the need to gen

Re: 8170987: Module system implementation refresh (12/2016)

2016-12-14 Thread Lois Foltan
On 12/14/2016 4:46 PM, Alan Bateman wrote: Folks on jigsaw-dev will be aware that we are on yet another mission to bring the changes accumulated in the jake forest to jdk9/dev. The plan this time is to bring the changes to jdk9/dev to make jdk-9+150. The changes in this update are mostly for

Re: Code review for jigsaw/jake -> jdk9/dev sync up

2016-11-28 Thread Lois Foltan
Hi Alan, I have reviewed the hotspot changes and they look good. Minor nit, src/share/vm/classfile/javaClasses.cpp only differs by the addition of a blank line. Thanks, Lois On 11/24/2016 10:25 AM, Alan Bateman wrote: Folks on jigsaw-dev will know that we are on a mission to bring the chan

Re: Request Review: JDK-6479237 (cl) Add support for classloader names

2016-10-31 Thread Lois Foltan
On 10/28/2016 4:44 PM, Mandy Chung wrote: On Oct 28, 2016, at 11:11 AM, Brent Christian wrote: Should something be done for STEs returned from StackFrameInfo.toStackTraceElement() ? Good catch - I missed it. I added package-private static methods in StackTraceElement class for both Throwa

hg: jigsaw/jake/hotspot: 8162998: Check at module definition that a package named java is not being defined to a class loader other than the boot or platform loader

2016-09-15 Thread lois . foltan
Changeset: de2b914558cd Author:lfoltan Date: 2016-09-15 11:25 -0400 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/de2b914558cd 8162998: Check at module definition that a package named java is not being defined to a class loader other than the boot or platform loader Summa

hg: jigsaw/jake/jdk: 8162998: Check at module definition that a package named java is not being defined to a class loader other than the boot or platform loader

2016-09-15 Thread lois . foltan
Changeset: b25ebe289b7c Author:lfoltan Date: 2016-09-15 11:27 -0400 URL: http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/b25ebe289b7c 8162998: Check at module definition that a package named java is not being defined to a class loader other than the boot or platform loader Summary:

Re: RFR(L) 8136930: Simplify use of module-system options by custom launchers

2016-08-01 Thread Lois Foltan
On 7/17/2016 7:05 PM, harold seigel wrote: Hi, Please review these Hotspot VM only changes to process the seven module-specific options that have been renamed to have gnu-like names. JDK changes for this bug will be reviewed separately. Descriptions of these options are here

hg: jigsaw/jake/hotspot: VM support for -Xpatch:=()*.

2016-04-11 Thread lois . foltan
Changeset: 74b5aac10b48 Author:lfoltan Date: 2016-04-11 12:22 -0400 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/74b5aac10b48 VM support for -Xpatch:=()*. ! src/share/vm/classfile/classLoader.cpp ! src/share/vm/classfile/classLoader.hpp ! src/share/vm/classfile/modules.c

hg: jigsaw/jake/hotspot: 8151908: Fix remaining extension class loader references in AppCDS code

2016-03-15 Thread lois . foltan
Changeset: 5420f2f73383 Author:jiangli Date: 2016-03-15 13:40 -0400 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/5420f2f73383 8151908: Fix remaining extension class loader references in AppCDS code Summary: Fix extension classloader references in AppCDS code and comments.

hg: jigsaw/jake/hotspot: Clean up of InstanceKlass casts within verify_check_access_msg based on code review comment.

2016-03-15 Thread lois . foltan
Changeset: bc1f549323f8 Author:lfoltan Date: 2016-03-15 10:22 -0400 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/bc1f549323f8 Clean up of InstanceKlass casts within verify_check_access_msg based on code review comment. ! src/share/vm/runtime/reflection.cpp

hg: jigsaw/jake/hotspot: Remove use of "jlrM" in field and method names based on code review comments.

2016-03-11 Thread lois . foltan
Changeset: c9950704cbcc Author:lfoltan Date: 2016-03-11 06:49 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/c9950704cbcc Remove use of "jlrM" in field and method names based on code review comments. ! src/share/vm/classfile/classFileParser.cpp ! src/share/vm/classfi

hg: jigsaw/jake/hotspot: Cleanup from internal code review comments.

2016-03-10 Thread lois . foltan
Changeset: 291f29771cd0 Author:lfoltan Date: 2016-03-10 09:43 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/291f29771cd0 Cleanup from internal code review comments. ! src/share/vm/classfile/moduleEntry.cpp ! src/share/vm/oops/klass.cpp ! src/share/vm/runtime/argumen

hg: jigsaw/jake/hotspot: Fix issue with test JFR capturing system properties at startup.

2016-03-10 Thread lois . foltan
Changeset: ee0c70bdad15 Author:lfoltan Date: 2016-03-10 09:08 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/ee0c70bdad15 Fix issue with test JFR capturing system properties at startup. ! src/share/vm/runtime/arguments.cpp ! src/share/vm/runtime/arguments.hpp

hg: jigsaw/jake/hotspot: JDK-8144730, make jdk.boot.class.path.append an internal system property and remove sun.boot.class.path support.

2016-03-07 Thread lois . foltan
Changeset: 7fc12c5280a2 Author:lfoltan Date: 2016-03-07 11:59 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/7fc12c5280a2 JDK-8144730, make jdk.boot.class.path.append an internal system property and remove sun.boot.class.path support. ! src/share/vm/classfile/classL

hg: jigsaw/jake/jdk: JDK-8144730, make jdk.boot.class.path.append and internal system property.

2016-03-07 Thread lois . foltan
Changeset: 22820da90ee1 Author:lfoltan Date: 2016-03-07 11:58 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/22820da90ee1 JDK-8144730, make jdk.boot.class.path.append and internal system property. ! src/java.base/share/classes/jdk/internal/loader/ClassLoaders.java ! src/

hg: jigsaw/jake/hotspot: CDS changes based on review comments.

2016-03-04 Thread lois . foltan
Changeset: a574ffaf90a9 Author:ccheung Date: 2016-03-03 16:01 -0800 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/a574ffaf90a9 CDS changes based on review comments. Reviewed-by: iklam, lfoltan ! src/share/vm/classfile/classLoader.cpp ! src/share/vm/classfile/classLoader.h

hg: jigsaw/jake/hotspot: Continued clean up for JVM's jigsaw support as part of feedback from internal review.

2016-03-03 Thread lois . foltan
Changeset: d66480af11d0 Author:lfoltan Date: 2016-03-03 18:11 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/d66480af11d0 Continued clean up for JVM's jigsaw support as part of feedback from internal review. ! src/share/vm/classfile/classFileParser.cpp ! src/share/v

hg: jigsaw/jake/hotspot: Trivial change to fix cosmetic difference in 2 files between jigsaw and JDK 9.

2016-03-03 Thread lois . foltan
Changeset: 89f7ea11f0cd Author:lfoltan Date: 2016-03-03 11:37 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/89f7ea11f0cd Trivial change to fix cosmetic difference in 2 files between jigsaw and JDK 9. ! make/bsd/makefiles/mapfile-vers-darwin-debug ! make/solaris/make

hg: jigsaw/jake/hotspot: 8150674: [TESTBUG] SharedArchiveFile/SharedStrings.java fails: "WhiteBox.class : no such file or directory"

2016-03-01 Thread lois . foltan
Changeset: 295296819a56 Author:mseledtsov Date: 2016-02-29 11:09 -0800 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/295296819a56 8150674: [TESTBUG] SharedArchiveFile/SharedStrings.java fails: "WhiteBox.class : no such file or directory" Summary: placing classes to be add

hg: jigsaw/jake/hotspot: A module's java.lang.reflect.Module is stored in its respective class loader's ClassLoaderData's handles area, release handles area even if no classes have been defined to tha

2016-02-22 Thread lois . foltan
Changeset: 2818165971bc Author:lfoltan Date: 2016-02-22 12:04 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/2818165971bc A module's java.lang.reflect.Module is stored in its respective class loader's ClassLoaderData's handles area, release handles area even if no cl

hg: jigsaw/jake/hotspot: Improve ModuleEntry::can_read to check for java.base, various code review clean ups.

2016-02-18 Thread lois . foltan
Changeset: 5bae10023cbc Author:lfoltan Date: 2016-02-18 12:37 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/5bae10023cbc Improve ModuleEntry::can_read to check for java.base, various code review clean ups. ! src/share/vm/classfile/moduleEntry.cpp ! src/share/vm/cla

Re: Round #4: RFR: 8049365 - Update JDI and JDWP for modules

2016-01-26 Thread Lois Foltan
On 1/26/2016 6:48 AM, serguei.spit...@oracle.com wrote: Please, review this initial fix for the M4 Jigsaw task: https://bugs.openjdk.java.net/browse/JDK-8049365 Jdk webrev: http://cr.openjdk.java.net/~sspitsyn/webrevs/2016/jdk/8049365-Jigsaw-jdk.4/ Hotspot webrev: http://cr.openjdk.java.net/~

Re: Round #3: RFR: 8049365 - Update JDI and JDWP for modules

2016-01-25 Thread Lois Foltan
On 1/22/2016 5:16 PM, serguei.spit...@oracle.com wrote: Please, review this initial fix for the M4 Jigsaw task: https://bugs.openjdk.java.net/browse/JDK-8049365 Jdk webrev: cr.openjdk.java.net/~sspitsyn/webrevs/2016/jdk/8049365-Jigsaw-jdk.3/ Hotspot webrev: http://cr.openjdk.java.net/~sspitsy

hg: jigsaw/jake/hotspot: Remove handling of the anonymous class prior to calling set_package(), the classLoader of an anonymous class is the same as its host class.

2016-01-07 Thread lois . foltan
Changeset: 58ff624dbef7 Author:lfoltan Date: 2016-01-07 13:31 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/58ff624dbef7 Remove handling of the anonymous class prior to calling set_package(), the classLoader of an anonymous class is the same as its host class. ! sr

hg: jigsaw/jake/hotspot: Use StringTable::intern(Symbol* symbol, TRAPS) method instead of char* version.

2016-01-05 Thread lois . foltan
Changeset: 33007ca5f45b Author:lfoltan Date: 2016-01-05 11:55 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/33007ca5f45b Use StringTable::intern(Symbol* symbol, TRAPS) method instead of char* version. ! src/share/vm/classfile/javaClasses.cpp

hg: jigsaw/jake/hotspot: Improve comment for ClassFileParser::verify_unqualified_name, rename ClassLoaderData's module/package table is_null methods, remove TRAPS parameter for java_lang_class::fixup_

2016-01-05 Thread lois . foltan
Changeset: 34ce2d3ebd40 Author:lfoltan Date: 2016-01-05 10:25 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/34ce2d3ebd40 Improve comment for ClassFileParser::verify_unqualified_name, rename ClassLoaderData's module/package table is_null methods, remove TRAPS paramet

hg: jigsaw/jake/hotspot: Break up large system initialization comment into smaller comments ahead of its respective call_initPhase# method.

2015-12-22 Thread lois . foltan
Changeset: f60f6d307283 Author:lfoltan Date: 2015-12-22 14:29 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/f60f6d307283 Break up large system initialization comment into smaller comments ahead of its respective call_initPhase# method. ! src/share/vm/runtime/thread

hg: jigsaw/jake/hotspot: Correct import statements for -Xlog:modules test.

2015-12-22 Thread lois . foltan
Changeset: 44007466d81e Author:rprotacio Date: 2015-12-22 10:56 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/44007466d81e Correct import statements for -Xlog:modules test. ! test/runtime/logging/ModulesTest.java

hg: jigsaw/jake/hotspot: Rename _fixup_jlrM_list to _fixup_modulefield_list.

2015-12-22 Thread lois . foltan
Changeset: 1a2211dc50c6 Author:lfoltan Date: 2015-12-22 10:35 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/1a2211dc50c6 Rename _fixup_jlrM_list to _fixup_modulefield_list. ! src/share/vm/classfile/javaClasses.cpp ! src/share/vm/classfile/javaClasses.hpp ! src/share

Re: preliminary RFR: 8049365 - Update JDI and JDWP for modules

2015-12-15 Thread Lois Foltan
On 12/10/2015 3:03 AM, serguei.spit...@oracle.com wrote: Please, review this initial fix for the Jigsaw Bill milestone task: https://bugs.openjdk.java.net/browse/JDK-8049365 Jdk webrev: http://cr.openjdk.java.net/~sspitsyn/webrevs/2015/jdk/8049365-Jigsaw-jdk.0/ Hotspot webrev: http://cr.openj

hg: jigsaw/jake/jdk: JVM correctly setting the module field for primitives, arrays and classes defined in unnamed module, java.lang.Class getModule can now reliably use the module field.

2015-12-08 Thread lois . foltan
Changeset: cc95060fced6 Author:lfoltan Date: 2015-12-08 13:16 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/cc95060fced6 JVM correctly setting the module field for primitives, arrays and classes defined in unnamed module, java.lang.Class getModule can now reliably use t

hg: jigsaw/jake/hotspot: Correctly set the mirror's module field for primitives, arrays and classes defined within unnamed modules.

2015-12-08 Thread lois . foltan
Changeset: 34b06d7ab75a Author:lfoltan Date: 2015-12-08 13:14 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/34b06d7ab75a Correctly set the mirror's module field for primitives, arrays and classes defined within unnamed modules. ! src/share/vm/classfile/classFilePar

hg: jigsaw/jake/hotspot: ework -XX:+TraceModules for the unified logging framework, changed to -Xlog:modules.

2015-12-08 Thread lois . foltan
Changeset: c8ba58405e6b Author:rprotacio Date: 2015-12-08 10:45 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/c8ba58405e6b ework -XX:+TraceModules for the unified logging framework, changed to -Xlog:modules. ! src/share/vm/classfile/moduleEntry.cpp ! src/share/vm/c

hg: jigsaw/jake/hotspot: JVM changes to record the j.l.r.Module for unnamed modules

2015-11-24 Thread lois . foltan
Changeset: f4f2580e950a Author:lfoltan Date: 2015-11-24 09:00 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/f4f2580e950a JVM changes to record the j.l.r.Module for unnamed modules ! make/aix/makefiles/mapfile-vers-debug ! make/aix/makefiles/mapfile-vers-product ! ma

hg: jigsaw/jake/jdk: Changes to communicate the j.l.r.Module for the boot loader's unnamed module to the JVM

2015-11-24 Thread lois . foltan
Changeset: fa97a65164bc Author:lfoltan Date: 2015-11-24 09:02 -0500 URL: http://hg.openjdk.java.net/jigsaw/jake/jdk/rev/fa97a65164bc Changes to communicate the j.l.r.Module for the boot loader's unnamed module to the JVM ! make/mapfiles/libjava/mapfile-vers ! src/java.base/share/c

hg: jigsaw/jake/hotspot: Fix 4 Hotspot modules/AccessCheck tests which test access from a named module to an unnamed module.

2015-10-22 Thread lois . foltan
Changeset: 9e3e01a6f042 Author:lfoltan Date: 2015-10-22 11:41 -0400 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/9e3e01a6f042 Fix 4 Hotspot modules/AccessCheck tests which test access from a named module to an unnamed module. ! test/runtime/modules/AccessCheck/ExportAll

Re: InternalError on Class.getPackage()

2015-10-20 Thread Lois Foltan
> On Oct 19, 2015, at 11:01 PM, Mandy Chung wrote: > >> >> On Oct 19, 2015, at 6:04 PM, Alan Bateman wrote: >> >> On 19/10/2015 22:58, Mandy Chung wrote: >>> Hi Chris, >>> >>> Thanks for reporting this (this is not a known issue). >>> >>> java.lang.InternalError: unnamed package in named mo

hg: jigsaw/jake/hotspot: Remove -XX:+TraceAccessControlErrors

2015-10-20 Thread lois . foltan
Changeset: 56344afc8f61 Author:lfoltan Date: 2015-10-20 10:33 -0400 URL: http://hg.openjdk.java.net/jigsaw/jake/hotspot/rev/56344afc8f61 Remove -XX:+TraceAccessControlErrors ! src/share/vm/runtime/globals.hpp ! src/share/vm/runtime/reflection.cpp

Re: RFR: 8087181: Move native jimage code to its own library (maybe libjimage) (against hs-rt)

2015-09-03 Thread Lois Foltan
On 9/3/2015 9:35 AM, Jim Laskey (Oracle) wrote: Passes JPRT -testset hotspot, and no new fails on -testset pit . Thanks Jim. I have reviewed the hotspot piece. Looks good. Lois On Aug 28, 2015, at 2:05 PM, Jim Laskey (Oracle) wrote: https://bugs.openjdk.java.net/browse/JDK-8087181

Re: RFR: JDK-8080511 - Refresh of jimage support

2015-06-18 Thread Lois Foltan
On 6/18/2015 10:59 AM, Karen Kinnear wrote: Code review for the hotspot component: Thank you for the cleanups to jvm.cpp to make them JVM_ENTRY and fix thread_state. If you pass the testing and Lois ok's the hotspot code, then I am ok with checking in the hotspot code as is. I have reviewe