[JSMentors] Re: Comments & critiques on a function/expression please

2011-03-14 Thread RobG
On Mar 14, 8:43 pm, Jason Mulligan wrote: > Hi Rob, thanks for looking. It would've been better if you had looked > at the lib prior to making your comments, for context. Ok, checked out the lib. I don't have time to go over all of it, a couple of quick comments: if (typeof(document.getEleme

[JSMentors] Re: Comments & critiques on a function/expression please

2011-03-14 Thread RobG
On Mar 14, 8:43 pm, Jason Mulligan wrote: > Hi Rob, thanks for looking. It would've been better if you had looked > at the lib prior to making your comments, for context. I looked at the code, thoroughly. It would be better if you would reply below quotes of what you are replying to so that you

Re: [JSMentors] client-side development environment

2011-03-14 Thread Oleg Slobodskoi
Hi, here is my attempt to this problem: https://github.com/kof/node-ams Currently work in progress, but is already in use and works for lots of usecases. It is plugin-enabled build tool with expressive jquery-like api and a bunch of preprocessors, for minifying, adding vendor prefixes for css,

[JSMentors] Re: Comments & critiques on a function/expression please

2011-03-14 Thread Jason Mulligan
During my walk to work today I tried, and failed to rationalize the double iteration I had put in place; so I switched to the forward iteration and figure compilers will decide what's best for them. On Mar 14, 6:48 am, Jason Mulligan wrote: > I prefer the use of .reverse() with the countdown, sin

Re: [JSMentors] Why eval() is considered insecure?

2011-03-14 Thread Lasse Reichstein
On Sun, 13 Mar 2011 16:53:59 +0100, Jarek Foksa wrote: Almost any modern JavaScript book recommends using subscript notation (e.g. object[key]) instead of eval() Stop right there. The two are fundamentally different. You can't use object[key] for most of the things you can use eval for (e

Re: [JSMentors] Re: client-side development environment

2011-03-14 Thread Tim Down
I use WebStorm for my own projects and find it very good for the most part. If you're working on an open source project, you may be able to get a free license for WebStorm. I applied for and was granted an open source WebStorm license for my work on Rangy. Tim On 9 March 2011 09:23, James Morrin

[JSMentors] Re: Comments & critiques on a function/expression please

2011-03-14 Thread Jason Mulligan
I prefer the use of .reverse() with the countdown, since that can be compiler optimized and still out perform the forward iteration in older browsers. It's difference should only come into play when dealing with arrays >50k On Mar 14, 12:32 am, RobG wrote: > On Mar 14, 1:34 pm, RobG wrote: > > >

[JSMentors] Re: Comments & critiques on a function/expression please

2011-03-14 Thread Jason Mulligan
Hi Rob, thanks for looking. It would've been better if you had looked at the lib prior to making your comments, for context. The function returns either a NodeList passed by reference, or an instance. An instance is an occurrence or a copy of an object, so it should be a valid term; hence you get

[JSMentors] Re: Why eval() is considered insecure?

2011-03-14 Thread RobG
On Mar 14, 1:53 am, Jarek Foksa wrote: > Almost any modern JavaScript book recommends using subscript notation > (e.g. object[key]) instead of eval() because of the following three > reasons: > - evaled code execution is slow > - evaled code is less readable than the same code written with > sub