Re: [Kicad-developers] [PATCH 00/27] My current patch stack

2015-04-12 Thread Mark Roszko
You could have probably squished a few of these patches into one to avoid spamming the bzr lovers with git emails hehehe ;) Because they'll end up squishing the commits to bzr anyway : ___ Mailing list: https://launchpad.net/~kicad-developers Post to

[Kicad-developers] [PATCH 17/27] ElectricPinType: Rename PIN_NMAX to PINTYPE_COUNT

2015-04-12 Thread Simon Richter
--- eeschema/dialogs/dialog_erc.cpp | 14 +++--- eeschema/dialogs/dialog_erc.h | 6 +++--- eeschema/erc.cpp| 6 +++--- eeschema/lib_pin.cpp| 6 +++--- eeschema/pin_type.h | 2 +- 5 files changed, 17 insertions(+), 17 deletions(-) diff --git a/

[Kicad-developers] [PATCH 19/27] PinTypeComboBox: Introduce widget

2015-04-12 Thread Simon Richter
--- eeschema/CMakeLists.txt | 1 + eeschema/dialogs/dialog_lib_edit_pin.h| 1 + eeschema/dialogs/dialog_lib_edit_pin_base.cpp | 3 +- eeschema/dialogs/dialog_lib_edit_pin_base.fbp | 2 +- eeschema/dialogs/dialog_lib_edit_pin_base.h | 3 +- eeschema/widgets/pin_

[Kicad-developers] [PATCH 24/27] ElectricPinType: move bitmap lookup

2015-04-12 Thread Simon Richter
--- eeschema/lib_pin.cpp | 28 +- eeschema/lib_pin.h | 8 --- eeschema/pin_type.cpp | 43 ++ eeschema/pin_type.h| 2 ++ eeschema/widgets/pin_type_combobox.cpp | 4 +

[Kicad-developers] [PATCH 22/27] ElectricPinType: move text lookup

2015-04-12 Thread Simon Richter
--- eeschema/CMakeLists.txt | 1 + eeschema/erc.cpp| 8 +++--- eeschema/lib_pin.cpp| 27 ++ eeschema/lib_pin.h | 9 +- eeschema/pin_type.cpp | 73 + eeschema/pin_type.h | 5 6 files changed, 86 inse

[Kicad-developers] [PATCH 27/27] Pin Table: Make pin position column sortable

2015-04-12 Thread Simon Richter
--- eeschema/dialogs/dialog_lib_edit_pin_table.cpp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/eeschema/dialogs/dialog_lib_edit_pin_table.cpp b/eeschema/dialogs/dialog_lib_edit_pin_table.cpp index cfc3ee8..fdb5375 100644 --- a/eeschema/dialogs/dialog_lib_edit_pin_table.cpp

[Kicad-developers] [PATCH 20/27] PinTypeComboBox: fully initialize in c'tor

2015-04-12 Thread Simon Richter
--- eeschema/dialogs/dialog_lib_edit_pin.cpp | 13 - eeschema/dialogs/dialog_lib_edit_pin.h | 1 - eeschema/pinedit.cpp | 2 -- eeschema/widgets/pin_type_combobox.cpp | 15 +++ 4 files changed, 15 insertions(+), 16 deletions(-) diff --git a/eesche

[Kicad-developers] [PATCH 03/27] Make NETLIST_OBJECT::GetConnectionType() const

2015-04-12 Thread Simon Richter
--- eeschema/class_netlist_object.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/eeschema/class_netlist_object.h b/eeschema/class_netlist_object.h index 0b51714..cd3ff48 100644 --- a/eeschema/class_netlist_object.h +++ b/eeschema/class_netlist_object.h @@ -154,7 +154,7 @@ pu

[Kicad-developers] [PATCH 18/27] ElectricPinType: Separate PINTYPE_COUNT from enum

2015-04-12 Thread Simon Richter
This allows us to use compiler warnings for enum coverage in switch statements. --- eeschema/lib_pin.cpp | 6 +++--- eeschema/pin_type.h | 7 +-- 2 files changed, 8 insertions(+), 5 deletions(-) diff --git a/eeschema/lib_pin.cpp b/eeschema/lib_pin.cpp index a47d815..b974438 100644 --- a/ees

[Kicad-developers] [PATCH 21/27] PinTypeComboBox: typesafe Get/Set

2015-04-12 Thread Simon Richter
--- eeschema/dialogs/dialog_lib_edit_pin.h | 2 +- eeschema/widgets/pin_type_combobox.cpp | 12 eeschema/widgets/pin_type_combobox.h | 5 + 3 files changed, 18 insertions(+), 1 deletion(-) diff --git a/eeschema/dialogs/dialog_lib_edit_pin.h b/eeschema/dialogs/dialog_lib_edit_

[Kicad-developers] [PATCH 23/27] ElectricPinType: remove list interfaces

2015-04-12 Thread Simon Richter
--- eeschema/lib_pin.cpp | 11 --- eeschema/lib_pin.h | 6 -- eeschema/widgets/pin_type_combobox.cpp | 5 +++-- 3 files changed, 3 insertions(+), 19 deletions(-) diff --git a/eeschema/lib_pin.cpp b/eeschema/lib_pin.cpp index b0852ef..0783110 100

[Kicad-developers] [PATCH 25/27] TypeSheetLabel: use enum

2015-04-12 Thread Simon Richter
--- eeschema/class_netlist_object.h | 2 +- eeschema/dialogs/dialog_edit_label.cpp | 3 ++- eeschema/dialogs/dialog_sch_edit_sheet_pin.h | 8 ++-- eeschema/edit_label.cpp | 8 eeschema/sch_sheet_pin.cpp | 2 +- eeschema/sch_tex

[Kicad-developers] [PATCH 26/27] Pin Table: display icon in pin type column

2015-04-12 Thread Simon Richter
--- eeschema/dialogs/dialog_lib_edit_pin_table.cpp | 50 +++--- 1 file changed, 45 insertions(+), 5 deletions(-) diff --git a/eeschema/dialogs/dialog_lib_edit_pin_table.cpp b/eeschema/dialogs/dialog_lib_edit_pin_table.cpp index 28b4938..cfc3ee8 100644 --- a/eeschema/dialogs/di

[Kicad-developers] [PATCH 15/27] ElectricPinType: move definition to pin_type.h

2015-04-12 Thread Simon Richter
--- eeschema/lib_pin.h | 20 +--- eeschema/pin_type.h | 49 + 2 files changed, 50 insertions(+), 19 deletions(-) create mode 100644 eeschema/pin_type.h diff --git a/eeschema/lib_pin.h b/eeschema/lib_pin.h index f4b21a8..bc84be6 100

[Kicad-developers] [PATCH 14/27] PinShape: move bitmap lookup

2015-04-12 Thread Simon Richter
This moves the bitmaps out of the data model as well. --- eeschema/lib_pin.cpp| 22 eeschema/lib_pin.h | 7 --- eeschema/pin_shape.cpp | 37 + eeschema/pin_shape.h

[Kicad-developers] [PATCH 11/27] PinShape: move enum to own header

2015-04-12 Thread Simon Richter
--- eeschema/lib_pin.h| 21 +-- eeschema/pin_shape.h | 50 +++ eeschema/widgets/pin_shape_combobox.h | 2 +- 3 files changed, 52 insertions(+), 21 deletions(-) create mode 100644 eeschema/pin_shape.h diff --git a/e

[Kicad-developers] [PATCH 13/27] PinShape: drop list interfaces

2015-04-12 Thread Simon Richter
This removes the list generation, and simply iterates over the allowed values. --- eeschema/lib_pin.cpp| 11 --- eeschema/lib_pin.h | 7 --- eeschema/widgets/pin_shape_combobox.cpp | 11 +++ 3 files changed, 7 insertions(+), 22 deletio

[Kicad-developers] [PATCH 16/27] ElectricPinType: Use enum rather than int where possible

2015-04-12 Thread Simon Richter
--- eeschema/class_netlist_object.cpp| 6 +++--- eeschema/class_netlist_object.h | 8 ++-- eeschema/dialogs/dialog_lib_edit_pin.cpp | 2 +- eeschema/dialogs/dialog_lib_edit_pin.h | 6 +++--- eeschema/erc.cpp | 10 +- eeschema/lib_pin.cpp

[Kicad-developers] [PATCH 12/27] PinShape: move text lookup

2015-04-12 Thread Simon Richter
--- eeschema/CMakeLists.txt | 1 + eeschema/lib_pin.cpp| 29 +++-- eeschema/pin_shape.cpp | 67 + eeschema/pin_shape.h| 5 4 files changed, 76 insertions(+), 26 deletions(-) create mode 100644 eeschema/pin_shape.cpp

[Kicad-developers] [PATCH 06/27] Regenerate "Edit Pin" dialog with newer wxFormBuilder

2015-04-12 Thread Simon Richter
--- eeschema/dialogs/dialog_lib_edit_pin_base.cpp | 8 eeschema/dialogs/dialog_lib_edit_pin_base.h | 2 +- 2 files changed, 5 insertions(+), 5 deletions(-) diff --git a/eeschema/dialogs/dialog_lib_edit_pin_base.cpp b/eeschema/dialogs/dialog_lib_edit_pin_base.cpp index 48b41f8..42d508a

[Kicad-developers] [PATCH 08/27] PinShapeComboBox: Introduce widget

2015-04-12 Thread Simon Richter
Derived from the regular bitmap combobox, this widget should be used for pin shape choices. --- eeschema/CMakeLists.txt | 3 ++ eeschema/dialogs/dialog_lib_edit_pin.h| 1 + eeschema/dialogs/dialog_lib_edit_pin_base.cpp | 3 +- eeschema/dialogs/dialog_lib_edit_pin_

[Kicad-developers] [PATCH 10/27] PinShapeComboBox: typesafe Get/Set

2015-04-12 Thread Simon Richter
These overrides provide typed access to the current selection, overriding the regular integer-based accessor/mutator. --- eeschema/dialogs/dialog_lib_edit_pin.h | 2 +- eeschema/widgets/pin_shape_combobox.cpp | 12 eeschema/widgets/pin_shape_combobox.h | 5 + 3 files changed

[Kicad-developers] [PATCH 07/27] Replace DrawPinShape enum with PinShape

2015-04-12 Thread Simon Richter
The bitmask requires a mapping to a different type used for the combobox, and only few of the enumeration values actually make sense. This removes the mapping, and uses a the same numbering throughout the entire code. --- eeschema/dialogs/dialog_lib_edit_pin.cpp | 2 +- eeschema/dialogs/dialog

[Kicad-developers] [PATCH 09/27] PinShapeComboBox: Fully initialize in c'tor

2015-04-12 Thread Simon Richter
This makes the widget universally usable without special initialisation. --- eeschema/dialogs/dialog_lib_edit_pin.cpp | 12 eeschema/dialogs/dialog_lib_edit_pin.h | 1 - eeschema/pinedit.cpp | 1 - eeschema/widgets/pin_shape_combobox.cpp | 12 4

[Kicad-developers] [PATCH 05/27] Separate ElectricPinType and TypeSheetLabel

2015-04-12 Thread Simon Richter
These enums are silently treated as equivalent in the ERC, because the values are casted to integers. This works for the most part, because the values are similar, but this is in no way enforced, and there is a small inconsistency (NET_UNSPECIFIED vs PIN_PASSIVE). This turns the storage into a di

[Kicad-developers] [PATCH 04/27] Remove superfluous cast

2015-04-12 Thread Simon Richter
--- eeschema/sch_component.cpp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/eeschema/sch_component.cpp b/eeschema/sch_component.cpp index ff7734e..554adb9 100644 --- a/eeschema/sch_component.cpp +++ b/eeschema/sch_component.cpp @@ -1789,7 +1789,7 @@ void SCH_COMPONENT::GetNe

[Kicad-developers] [PATCH 02/27] Use Link Time Optimization with GCC in Release builds

2015-04-12 Thread Simon Richter
This significantly reduces executable file size, and should also improve performance. --- CMakeLists.txt | 15 +++ CMakeModules/PerformFeatureChecks.cmake | 1 + 2 files changed, 16 insertions(+) diff --git a/CMakeLists.txt b/CMakeLists.txt index 62467ce..bb

[Kicad-developers] [PATCH 01/27] Move feature check before dependent tests

2015-04-12 Thread Simon Richter
The GCC/LLVM specific handling for adding -fvisibility options is later in this file, so these options would only be added on the second invocation without clearing the cache. --- CMakeLists.txt | 9 + 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/CMakeLists.txt b/CMakeLis

[Kicad-developers] [PATCH 00/27] My current patch stack

2015-04-12 Thread Simon Richter
Hi, this is my current stack; not all of this may be appropriate for the next stable release. The first two I've posted earlier -- a bugfix and an enhancement to the build. The next two are small and self-explanatory. Number five explicitly acknowledges that the NETLIST_OBJECT::m_ElectricalTyp

Re: [Kicad-developers] Fwd: Documentation update

2015-04-12 Thread Nick Østergaard
I have now done this. 2015-04-11 13:48 GMT+02:00 Nick Østergaard : > So now is a good time to remove the src/markdown and src/rest and move > src/asciidoc to src? > > If so, I can do that now, such that you can pull those changes. > > 2015-04-11 13:43 GMT+02:00 Brian Sidebotham : >> On 11 April 20

Re: [Kicad-developers] [patch?] Handling conflict between projname-cache.lib and an updated library

2015-04-12 Thread Nick Østergaard
I just tested this again, after reporting some of the above, but now solved issues to Chris. Thanks for fixing so fast. 2015-04-12 19:57 GMT+02:00 Chris Pavlina : > And, because I'm excessively stupid today, here's a version of the patch > that I didn't diff incorrectly. > > > On Fri, Apr 10, 2015

Re: [Kicad-developers] 3d-viewer Filling zones issue when not show holes

2015-04-12 Thread jp charras
Le 12/04/2015 13:46, Mário Luzeiro a écrit : > Hello Jean Pierre, > > I am facing an issue related with the filling zones in my development > working branch. Then I build the main trunk version and there is > something I would like to check with you since I believe you may did > some fine tunning

[Kicad-developers] 3d-viewer Filling zones issue when not show holes

2015-04-12 Thread Mário Luzeiro
Hello Jean Pierre, I am facing an issue related with the filling zones in my development working branch. Then I build the main trunk version and there is something I would like to check with you since I believe you may did some fine tunning related with that filling zone code. The attached scr