Re: [PATCH 1/8] KVM: MMU: combine unsync and unsync_children

2012-01-09 Thread Marcelo Tosatti
On Fri, Dec 16, 2011 at 06:13:42PM +0800, Xiao Guangrong wrote: unsync is only used for the page of level == 1 and unsync_children is only used in the upper page, so combine them to reduce the size of shadow page structure Signed-off-by: Xiao Guangrong xiaoguangr...@linux.vnet.ibm.com ---

Re: [PATCH 1/8] KVM: MMU: combine unsync and unsync_children

2012-01-09 Thread Xiao Guangrong
On 01/09/2012 07:16 PM, Marcelo Tosatti wrote: In general, given the number of optimizations made to the shadow mmu code, and the fact that over time NPT will dominate, i'd suggest time should be spent improving other areas. I totally agree with you, thanks Marcelo! -- To unsubscribe from

Re: [PATCH 1/8] KVM: MMU: combine unsync and unsync_children

2011-12-22 Thread Marcelo Tosatti
On Fri, Dec 16, 2011 at 06:13:42PM +0800, Xiao Guangrong wrote: unsync is only used for the page of level == 1 and unsync_children is only used in the upper page, so combine them to reduce the size of shadow page structure Signed-off-by: Xiao Guangrong xiaoguangr...@linux.vnet.ibm.com ---

Re: [PATCH 1/8] KVM: MMU: combine unsync and unsync_children

2011-12-22 Thread Xiao Guangrong
On 12/23/2011 12:06 AM, Marcelo Tosatti wrote: On Fri, Dec 16, 2011 at 06:13:42PM +0800, Xiao Guangrong wrote: unsync is only used for the page of level == 1 and unsync_children is only used in the upper page, so combine them to reduce the size of shadow page structure Signed-off-by: Xiao

Re: [PATCH 1/8] KVM: MMU: combine unsync and unsync_children

2011-12-18 Thread Takuya Yoshikawa
About naming issues in the kvm mmu code. Not restricted to your patch series, so please take as a suggestion for the future. (2011/12/16 19:13), Xiao Guangrong wrote: +static bool sp_is_unsync(struct kvm_mmu_page *sp) +{ + return sp-role.level == PT_PAGE_TABLE_LEVEL sp-unsync; +}

[PATCH 1/8] KVM: MMU: combine unsync and unsync_children

2011-12-16 Thread Xiao Guangrong
unsync is only used for the page of level == 1 and unsync_children is only used in the upper page, so combine them to reduce the size of shadow page structure Signed-off-by: Xiao Guangrong xiaoguangr...@linux.vnet.ibm.com --- Documentation/virtual/kvm/mmu.txt |5 ++-