[PATCH v2] Dynamically add and remove device specific reset functions

2012-03-02 Thread tadeusz . struk
Hi, Reworked according to comments. I have a use case where I need to cleanup resource allocated for Virtual Functions after a guest OS that used it crashed. This cleanup needs to be done before the VF is being FLRed. The only possible way to do this seems to be by using pci_dev_specific_reset()

Re: [PATCH v2] Dynamically add and remove device specific reset functions

2012-03-02 Thread Bjorn Helgaas
Thanks! You didn't fix the subject line :) It should contain PCI: . Thanks for including the v2 inside [PATCH]. That helps keep things straight. On Fri, Mar 2, 2012 at 4:55 AM, tadeusz.st...@intel.com wrote: Hi, Reworked according to comments. All the text here becomes part of the

Re: [PATCH v2] Dynamically add and remove device specific reset functions

2012-03-02 Thread Tadeusz Struk
On 02/03/12 16:29, Bjorn Helgaas wrote: Where do you plan to add calls to pci_dev_specific_reset_add()? In drivers? Yes, I'm working on a driver for a device with SRIOV capability. I'll call it from there. Did you consider adding a reset function pointer to struct pci_driver? That might be

Re: [PATCH v2] Dynamically add and remove device specific reset functions

2012-03-02 Thread Bjorn Helgaas
On Fri, Mar 2, 2012 at 10:06 AM, Tadeusz Struk tadeusz.st...@intel.com wrote: On 02/03/12 16:29, Bjorn Helgaas wrote: Where do you plan to add calls to pci_dev_specific_reset_add()?  In drivers? Yes, I'm working on a driver for a device with SRIOV capability. I'll call it from there. Did

Re: [PATCH v2] Dynamically add and remove device specific reset functions

2012-03-02 Thread Jesse Barnes
On Fri, 2 Mar 2012 10:17:53 -0700 Bjorn Helgaas bhelg...@google.com wrote: On Fri, Mar 2, 2012 at 10:06 AM, Tadeusz Struk tadeusz.st...@intel.com wrote: On 02/03/12 16:29, Bjorn Helgaas wrote: Where do you plan to add calls to pci_dev_specific_reset_add()?  In drivers? Yes, I'm