Re: [PATCH v6 1/4] KVM: PPC: epapr: Factor out the epapr init

2012-02-27 Thread Scott Wood
On 02/23/2012 03:22 AM, Liu Yu wrote: > +static int __init epapr_paravirt_init(void) > +{ > + struct device_node *hyper_node; > + const u32 *insts; > + int len, i; > + > + hyper_node = of_find_node_by_path("/hypervisor"); > + if (!hyper_node) > + return -ENODEV; > +

[PATCH v6 1/4] KVM: PPC: epapr: Factor out the epapr init

2012-02-23 Thread Liu Yu
from the kvm guest paravirt init code. Signed-off-by: Liu Yu --- v6: 1. rename epapr_para to epapr_paravirt 2. remove redundant warnings 3. remove unnecessary init arch/powerpc/include/asm/epapr_hcalls.h |2 + arch/powerpc/kernel/Makefile|1 + arch/powerpc/kernel/epapr_hcall