Re: [PATCH 05/15] ARM: head: use PC-relative insn sequence for __smp_alt

2017-08-11 Thread Nicolas Pitre
On Fri, 11 Aug 2017, Ard Biesheuvel wrote: > On 11 August 2017 at 21:06, Nicolas Pitre wrote: > > On Fri, 11 Aug 2017, Ard Biesheuvel wrote: > > > >> On 11 August 2017 at 20:58, Nicolas Pitre wrote: > >> > On Fri, 11 Aug 2017, Ard Biesheuvel

Re: [PATCH 05/15] ARM: head: use PC-relative insn sequence for __smp_alt

2017-08-11 Thread Ard Biesheuvel
On 11 August 2017 at 21:06, Nicolas Pitre wrote: > On Fri, 11 Aug 2017, Ard Biesheuvel wrote: > >> On 11 August 2017 at 20:58, Nicolas Pitre wrote: >> > On Fri, 11 Aug 2017, Ard Biesheuvel wrote: >> > >> >> On 11 August 2017 at 16:13, Tony

Re: [PATCH 05/15] ARM: head: use PC-relative insn sequence for __smp_alt

2017-08-11 Thread Ard Biesheuvel
On 11 August 2017 at 16:13, Tony Lindgren wrote: > * Ard Biesheuvel [170805 13:54]: >> Replace the open coded PC relative offset calculations with a pair >> of adr_l invocations. >> >> Signed-off-by: Ard Biesheuvel >> ---

Re: [PATCH v2 06/16] arm64: entry.S: convert elX_sync

2017-08-11 Thread James Morse
Hi Catalin, On 10/08/17 17:57, James Morse wrote: > On 09/08/17 18:25, Catalin Marinas wrote: >> On Fri, Jul 28, 2017 at 03:10:09PM +0100, James Morse wrote: >>> @@ -520,9 +514,16 @@ el1_preempt: >>> el0_sync: >>> kernel_entry 0 >>> mrs x25, esr_el1// read the

Re: [PATCH 05/15] ARM: head: use PC-relative insn sequence for __smp_alt

2017-08-11 Thread Tony Lindgren
* Ard Biesheuvel [170805 13:54]: > Replace the open coded PC relative offset calculations with a pair > of adr_l invocations. > > Signed-off-by: Ard Biesheuvel > --- > arch/arm/kernel/head.S | 12 ++-- > 1 file changed, 2

Re: [PATCH 12/15] arm-soc: omap: replace open coded VA->PA calculations

2017-08-11 Thread Ard Biesheuvel
On 10 August 2017 at 15:03, Tony Lindgren wrote: > * Ard Biesheuvel [170810 02:23]: >> On 9 August 2017 at 22:05, Tony Lindgren wrote: >> > * Ard Biesheuvel [170809 12:24]: >> >> On 9 August 2017 at

Re: [PATCH 00/11] ARMv8.3 pointer authentication userspace support

2017-08-11 Thread Mark Rutland
On Tue, Jul 25, 2017 at 01:06:43PM +0100, Mark Rutland wrote: > On Fri, Jul 21, 2017 at 06:05:09PM +0100, Dave Martin wrote: > > On Wed, Jul 19, 2017 at 05:01:21PM +0100, Mark Rutland wrote: > > > This series adds support for the ARMv8.3 pointer authentication extension. > > > > Open questions >

Re: [PATCH 07/11] arm64: add basic pointer authentication support

2017-08-11 Thread Dave Martin
On Fri, Aug 11, 2017 at 08:46:28AM +0100, Yao Qi wrote: > Hi Mark, > > On 19/07/17 17:01, Mark Rutland wrote: > >+#define HWCAP_APIA (1 << 16) > > Can you rename it to HWCAP_ARM64_APIA or HWCAP_ARM_APIA? When we > use it in user space, at least in GDB, we usually do this, > > #ifndef

Re: [PATCH 07/11] arm64: add basic pointer authentication support

2017-08-11 Thread Yao Qi
Hi Mark, On 19/07/17 17:01, Mark Rutland wrote: +#define HWCAP_APIA (1 << 16) Can you rename it to HWCAP_ARM64_APIA or HWCAP_ARM_APIA? When we use it in user space, at least in GDB, we usually do this, #ifndef HWCAP_APIA #define HWCAP_APIA (1 << 16) #endif However, the code use